X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Whenever I click on a link in an Outlook email it opens a new Firefox window instead of opening a new tab on an already open Firefox window

已張貼

Hi,

I use Firefox as my default browser.

Whenever I click on a link in an email it opens a new Firefox window instead of opening a new tab on a Firefox window that is already open.

My preference is for it to open a new tab on an already open Firefox window.

I have looked in the settings / preferences and can’t seem to find where to make this change.

Please can you advise the process / steps for me to make this to happen.

Hi, I use Firefox as my default browser. Whenever I click on a link in an email it opens a new Firefox window instead of opening a new tab on a Firefox window that is already open. My preference is for it to open a new tab on an already open Firefox window. I have looked in the settings / preferences and can’t seem to find where to make this change. Please can you advise the process / steps for me to make this to happen.

被選擇的解決方法

Hi jamesburbidgeking, is it Outlook on the web in a Firefox tab, or the Outlook that is part of the Office suite installed as a separate app on the system?

One reason a link launched from a Firefox tab might not be diverted from a new window to a new tab is if the site specifies features for the window, such as width and height. To ALSO divert those to a tab, you need to make a setting change. For the sake of completeness, I'm going to show all three of these related preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features) <= Change to this
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

This probably isn't relevant, but if -1 doesn't work, try 3

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Also, I have a test page here: https://www.jeffersonscher.com/res/popit.html

Success?

從原來的回覆中察看解決方案 1
引用
jscher2000
  • Top 10 Contributor
8950 個解決方法 73359 個答案

選擇的解決方法

Hi jamesburbidgeking, is it Outlook on the web in a Firefox tab, or the Outlook that is part of the Office suite installed as a separate app on the system?

One reason a link launched from a Firefox tab might not be diverted from a new window to a new tab is if the site specifies features for the window, such as width and height. To ALSO divert those to a tab, you need to make a setting change. For the sake of completeness, I'm going to show all three of these related preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features) <= Change to this
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

This probably isn't relevant, but if -1 doesn't work, try 3

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Also, I have a test page here: https://www.jeffersonscher.com/res/popit.html

Success?

Hi jamesburbidgeking, is it Outlook on the web in a Firefox tab, or the Outlook that is part of the Office suite installed as a separate app on the system? One reason a link launched from a Firefox tab might not be diverted from a new window to a new tab is if the site specifies features for the window, such as width and height. To ALSO divert those to a tab, you need to make a setting change. For the sake of completeness, I'm going to show all three of these related preferences: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''neww''' and pause while the list is filtered (3) Review/Adjust the preferences as follows: (A) '''browser.link.open_newwindow''' - ''for links in Firefox tabs'' This is the one that has a checkbox on the Preferences page: * '''3 = divert new window to a new tab (default)''' * 2 = allow link to open a new window * 1 = force new window into same tab (B) '''browser.link.open_newwindow.restriction''' - ''for links in Firefox tabs'' By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0: * '''0 = apply the setting under (A) to ALL new windows''' (even script windows with features) '''<= Change to this''' * 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) * 1 = override the setting under (A) and always use new windows (C) '''browser.link.open_newwindow.override.external''' - ''for links in other programs'' ''This probably isn't relevant, but if ''-1'' doesn't work, try ''3 * -1 = apply the setting under (A) to external links (default) * 3 = open external links in a new tab in the last active window * 2 = open external links in a new window * 1 = open external links in the last active tab replacing the current page To return to normal if things go haywire, right-click each "modified" preference and choose Reset. Also, I have a test page here: https://www.jeffersonscher.com/res/popit.html Success?
這篇文章有幫助嗎? 1
引用
keithallen12 0 個解決方法 1 個答案

I'm having the same issue - links from sources outside FF open in a new window instead of a new tab on the already open window. I followed your instructions above and set things as follows:

browser.link.open_newwindow 3 browser.link.open_newwindow.disabled_in_fullscreen false browser.link.open_newwindow.override.external 3 browser.link.open_newwindow.restriction 1 services.sync.prefs.sync.browser.link.open_newwindow true

I've tried the override.exeternal as -1 and 3.

I'm clicking links in an outlook (desktop version) email and they keep opening in a new window instead of a new tab on the already open window.

Also, in FF Options - General - Tabs I have "Open links in tabs instead of new windows" checked. Still opens them in a new window.

Until like 5 minutes ago this didn't happen - links clicked anywhere (on an internet page or out of an email) opened in a new tab on the existing window.

Thanks?

I'm having the same issue - links from sources outside FF open in a new window instead of a new tab on the already open window. I followed your instructions above and set things as follows: browser.link.open_newwindow 3 browser.link.open_newwindow.disabled_in_fullscreen false browser.link.open_newwindow.override.external 3 browser.link.open_newwindow.restriction 1 services.sync.prefs.sync.browser.link.open_newwindow true I've tried the override.exeternal as -1 and 3. I'm clicking links in an outlook (desktop version) email and they keep opening in a new window instead of a new tab on the already open window. Also, in FF Options - General - Tabs I have "Open links in tabs instead of new windows" checked. Still opens them in a new window. Until like 5 minutes ago this didn't happen - links clicked anywhere (on an internet page or out of an email) opened in a new tab on the existing window. Thanks?
這篇文章有幫助嗎?
引用
jscher2000
  • Top 10 Contributor
8950 個解決方法 73359 個答案

Hi keithallen12, this part --

Until like 5 minutes ago this didn't happen - links clicked anywhere (on an internet page or out of an email) opened in a new tab on the existing window.

-- makes me wonder whether it is a transient problem. If you haven't already, try exiting out of Firefox and doing a normal shut down of your system to release file locks and complete any pending updates.

Any difference after that?

Hi keithallen12, this part -- <blockquote>Until like 5 minutes ago this didn't happen - links clicked anywhere (on an internet page or out of an email) opened in a new tab on the existing window.</blockquote> -- makes me wonder whether it is a transient problem. If you haven't already, try exiting out of Firefox and doing a normal shut down of your system to release file locks and complete any pending updates. Any difference after that?
這篇文章有幫助嗎?
引用
Discovery222 0 個解決方法 2 個答案

jamesburbidgeking said

Hi, I use Firefox as my default browser. Whenever I click on a link in an email it opens a new Firefox window instead of opening a new tab on a Firefox window that is already open. My preference is for it to open a new tab on an already open Firefox window. I have looked in the settings / preferences and can’t seem to find where to make this change. Please can you advise the process / steps for me to make this to happen.

I had the same problem and in my situation the problem began with a Firefox update. This is apparently a common problem: For one example, you might have a 64-bit version and still have an older 34-bit version on your computer. If you click on an email link and it opens in a different Firefox browser you have at least two versions on your computer. THE FIX FOR THIS PROBLEM: Close the Firefox Browser(s). Go back to your CONTROL PANEL, then click DEFAULT PROGRAMS or DEFAULT APPS, find WEB BROWSER and click on the Firefox icon shown there. When other browser icons come up come up choose the other Firefox icon as your default browser. Then see how your desktop icon, taskbar icon and computer hyperlinks respond now. You’ll need to determine which version of Firefox is the latest so you keep only that version on your computer. DO NOT "UNINSTALL" ANYTHING ... The best choice is always to do a search in your Program Files for Mozilla Firefox and Add/Remove Programs for Mozilla and/or Firefox. If you only see one entry listed in Add/Remove programs, that’s the one that should be "known" Firefox Version by your OS, probably the 64-bit version you seem to use now. In that case, you could choose to remove one version or uninstall from the Program Files folder, AFTER you’ve determined which version you DO NOT need. TO BE SAFE, rename the Mozilla Firefox folder in your Program Files first...to something like Mozilla Firefox2, for example. NOTE: if you have one of the 2 versions of Firefox opened and your computer will not allow you to rename that folder you now know that is the folder for the Firefox version that is opened. FINALLY, you may need to delete the Firefox taskbar icon after you’ve made this determination. You can add it back by selecting the desktop icon and right clicking it, then selecting ‘Pin To Taskbar’. After you’ve determined THE VERSION OF FIREFOX YOU WANT TO KEEP (and tested your ‘desktop icon’, ‘taskbar icon’ and ‘computer hyperlinks’ to insure they are working properly) you can then uninstall any other versions of Firefox on your computer. ALTERNATIVE FIX FOR THIS PROBLEM: You can always delete all versions of Firefox on your computer and then download the latest version of Firefox -- if you have another browser installed to access the internet, such as Google Chrome or Microsoft Edge, for example.

''jamesburbidgeking [[#question-1271344|said]]'' <blockquote> Hi, I use Firefox as my default browser. Whenever I click on a link in an email it opens a new Firefox window instead of opening a new tab on a Firefox window that is already open. My preference is for it to open a new tab on an already open Firefox window. I have looked in the settings / preferences and can’t seem to find where to make this change. Please can you advise the process / steps for me to make this to happen. </blockquote> I had the same problem and in my situation the problem began with a Firefox update. This is apparently a common problem: For one example, you might have a 64-bit version and still have an older 34-bit version on your computer. If you click on an email link and it opens in a different Firefox browser you have at least two versions on your computer. '''THE FIX FOR THIS PROBLEM''': Close the Firefox Browser(s). Go back to your CONTROL PANEL, then click DEFAULT PROGRAMS or DEFAULT APPS, find WEB BROWSER and click on the Firefox icon shown there. When other browser icons come up come up choose the other Firefox icon as your default browser. Then see how your desktop icon, taskbar icon and computer hyperlinks respond now. You’ll need to determine which version of Firefox is the latest so you keep only that version on your computer. '''DO NOT "UNINSTALL" ANYTHING''' ... The best choice is always to do a search in your Program Files for Mozilla Firefox and Add/Remove Programs for Mozilla and/or Firefox. If you only see one entry listed in Add/Remove programs, that’s the one that should be "known" Firefox Version by your OS, probably the 64-bit version you seem to use now. In that case, you could choose to remove one version or uninstall from the Program Files folder, AFTER you’ve determined which version you ''DO NOT ''need. '''TO BE SAFE''', rename the Mozilla Firefox folder in your Program Files first...to something like Mozilla ''Firefox2'', for example. NOTE: if you have one of the 2 versions of Firefox opened and your computer will not allow you to rename that folder you now know that is the folder for the Firefox version that is opened. '''FINALLY''', you may need to delete the Firefox taskbar icon after you’ve made this determination. You can add it back by selecting the desktop icon and right clicking it, then selecting ‘Pin To Taskbar’. After you’ve determined THE VERSION OF FIREFOX YOU WANT TO KEEP ''(and tested your ‘desktop icon’, ‘taskbar icon’ and ‘computer hyperlinks’ to insure they are working properly)'' you can then uninstall any other versions of Firefox on your computer. '''ALTERNATIVE FIX FOR THIS PROBLEM''': You can always delete all versions of Firefox on your computer and then download the latest version of Firefox -- '''''if you have another browser installed to access the internet''''', such as Google Chrome or Microsoft Edge, for example.

由 Discovery222 於 修改

這篇文章有幫助嗎?
引用
Discovery222 0 個解決方法 2 個答案

I had the same problem and in my situation the problem began with a Firefox update. This is apparently a common problem: For one example, you might have a 64-bit version and still have an older 34-bit version on your computer. If you click on an email link and it opens in a different Firefox browser you have at least two versions on your computer. THE FIX FOR THIS PROBLEM: Close the Firefox Browser(s). Go back to your CONTROL PANEL, then click DEFAULT PROGRAMS or DEFAULT APPS, find WEB BROWSER and click on the Firefox icon shown there. When other browser icons come up come up choose the other Firefox icon as your default browser. Then see how your desktop icon, taskbar icon and computer hyperlinks respond now. You’ll need to determine which version of Firefox is the latest so you keep only that version on your computer. DO NOT "UNINSTALL" ANYTHING ... The best choice is always to do a search in your Program Files for Mozilla Firefox and Add/Remove Programs for Mozilla and/or Firefox. If you only see one entry listed in Add/Remove programs, that’s the one that should be "known" Firefox Version by your OS, probably the 64-bit version you seem to use now. In that case, you could choose to remove one version or uninstall from the Program Files folder, AFTER you’ve determined which version you DO NOT need. TO BE SAFE, rename the Mozilla Firefox folder in your Program Files first...to something like Mozilla Firefox2, for example. NOTE: if you have one of the 2 versions of Firefox opened and your computer will not allow you to rename that folder you now know that is the folder for the Firefox version that is opened. FINALLY, you may need to delete the Firefox taskbar icon after you’ve made this determination. You can add it back by selecting the desktop icon and right clicking it, then selecting ‘Pin To Taskbar’. After you’ve determined THE VERSION OF FIREFOX YOU WANT TO KEEP (and tested your ‘desktop icon’, ‘taskbar icon’ and ‘computer hyperlinks’ to insure they are working properly) you can then uninstall any other versions of Firefox on your computer. ALTERNATIVE FIX FOR THIS PROBLEM: You can always delete all versions of Firefox on your computer and then download the latest version of Firefox -- if you have another browser installed to access the internet, such as Google Chrome or Microsoft Edge, for example.

I had the same problem and in my situation the problem began with a Firefox update. This is apparently a common problem: For one example, you might have a 64-bit version and still have an older 34-bit version on your computer. If you click on an email link and it opens in a different Firefox browser you have at least two versions on your computer. '''THE FIX FOR THIS PROBLEM''': Close the Firefox Browser(s). Go back to your CONTROL PANEL, then click DEFAULT PROGRAMS or DEFAULT APPS, find WEB BROWSER and click on the Firefox icon shown there. When other browser icons come up come up choose the other Firefox icon as your default browser. Then see how your desktop icon, taskbar icon and computer hyperlinks respond now. You’ll need to determine which version of Firefox is the latest so you keep only that version on your computer. '''DO NOT "UNINSTALL" ANYTHING''' ... The best choice is always to do a search in your Program Files for Mozilla Firefox and Add/Remove Programs for Mozilla and/or Firefox. If you only see one entry listed in Add/Remove programs, that’s the one that should be "known" Firefox Version by your OS, probably the 64-bit version you seem to use now. In that case, you could choose to remove one version or uninstall from the Program Files folder, AFTER you’ve determined which version you ''DO NOT ''need. '''TO BE SAFE''', rename the Mozilla Firefox folder in your Program Files first...to something like Mozilla ''Firefox2'', for example. NOTE: if you have one of the 2 versions of Firefox opened and your computer will not allow you to rename that folder you now know that is the folder for the Firefox version that is opened. '''FINALLY''', you may need to delete the Firefox taskbar icon after you’ve made this determination. You can add it back by selecting the desktop icon and right clicking it, then selecting ‘Pin To Taskbar’. After you’ve determined THE VERSION OF FIREFOX YOU WANT TO KEEP ''(and tested your ‘desktop icon’, ‘taskbar icon’ and ‘computer hyperlinks’ to insure they are working properly)'' you can then uninstall any other versions of Firefox on your computer. '''ALTERNATIVE FIX FOR THIS PROBLEM''': You can always delete all versions of Firefox on your computer and then download the latest version of Firefox -- '''''if you have another browser installed to access the internet''''', such as Google Chrome or Microsoft Edge, for example.

由 Discovery222 於 修改

這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題