X
點擊此處開啟此網站的行動版。

技術支援討論區

With Firefox on LMDE 3 Cindy, I want to add a new dictionary, but I get the error "Download failed. Please check your connection". Language packs work, though.

已張貼

The problem with add-ons failing to download is well known now. But I tried the solution and it didn't work (addblock+ download failed). The preference "Allow Firefox to install and run studies" is checked and I can't download a dictionary. The weird thing is that I can download language packs and use it. Maybe it's linked to LMDE 3.

The problem with add-ons failing to download is well known now. But I tried the solution and it didn't work (addblock+ download failed). The preference "Allow Firefox to install and run studies" is checked and I can't download a dictionary. The weird thing is that I can download language packs and use it. Maybe it's linked to LMDE 3.

被選擇的解決方法

LMDE 3 Cindy is a Linux distro version as LMDE is short for “Linux Mint Debian Edition”

Many long term support distro versions use Firefox ESR instead of current Release channel.

So the OP may be using Firefox 60 ESR where the current version is 60.7.0 ESR https://www.mozilla.org/firefox/organizations/all/

louki, if you are using 60.6.1esr or older and not say 60.6.2esr or 60.6.3esr or 60.7.0esr then that could explain the "Download failed. Please check your connection" on addons.mozilla.org site

If you have 60.6.1esr or older then check to see if your distro has had Firefox updates in package manager. Or if using Firefox 60 ESR from Mozilla check for updates in Firefox.

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

從原來的回覆中察看解決方案 1
引用

額外的系統細節

已安裝的外掛程式

Codec vidéo OpenH264 fourni par Cisco Systems, Inc. (installed by default). Français language pack.

應用程式

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

更多資訊

FredMcD
  • Top 10 Contributor
4230 個解決方法 59038 個答案

There was an issue with most add-ons when a certificate used by them expired. This May be your problem.

Is there a reason you don't want to update?

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no 66.0.4 May 5, 2019 Fixes add-on certificate issue. 66.0.5 May 7, 2019 Further improvements to re-enable web extensions

67.0 May 21, 2019


https://support.mozilla.org/en-US/questions/1258165#answer-1218833 fixed the issue for my v54.

There was an issue with most add-ons when a certificate used by them expired. This May be your problem. Is there a reason you don't want to update? https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no '''66.0.4''' May 5, 2019 Fixes add-on certificate issue. '''66.0.5''' May 7, 2019 Further improvements to re-enable web extensions '''67.0''' May 21, 2019 ----------------- https://support.mozilla.org/en-US/questions/1258165#answer-1218833 fixed the issue for my v54.
這篇文章有幫助嗎? 1
引用
James
  • Moderator
1594 個解決方法 11232 個答案

選擇的解決方法

LMDE 3 Cindy is a Linux distro version as LMDE is short for “Linux Mint Debian Edition”

Many long term support distro versions use Firefox ESR instead of current Release channel.

So the OP may be using Firefox 60 ESR where the current version is 60.7.0 ESR https://www.mozilla.org/firefox/organizations/all/

louki, if you are using 60.6.1esr or older and not say 60.6.2esr or 60.6.3esr or 60.7.0esr then that could explain the "Download failed. Please check your connection" on addons.mozilla.org site

If you have 60.6.1esr or older then check to see if your distro has had Firefox updates in package manager. Or if using Firefox 60 ESR from Mozilla check for updates in Firefox.

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

LMDE 3 Cindy is a Linux distro version as LMDE is short for “Linux Mint Debian Edition” Many long term support distro versions use Firefox ESR instead of current Release channel. So the OP may be using Firefox 60 ESR where the current version is 60.7.0 ESR https://www.mozilla.org/firefox/organizations/all/ '''louki,''' if you are using 60.6.1esr or older and not say 60.6.2esr or 60.6.3esr or 60.7.0esr then that could explain the "Download failed. Please check your connection" on addons.mozilla.org site If you have 60.6.1esr or older then check to see if your distro has had Firefox updates in package manager. Or if using Firefox 60 ESR from Mozilla check for updates in Firefox. https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/
這篇文章有幫助嗎? 1
引用

提出問題者

FredMcD said

Is there a reason you don't want to update?

There are no reason I don't want to. But there is a reason it is not. I'm using LMDE 3 ant its repository haven't the last Firefox version.

I have updated it manually and now add-ons work ! Thank you :D

''FredMcD [[#answer-1225537|said]]'' <blockquote> Is there a reason you don't want to update? </blockquote> There are no reason I don't want to. But there is a reason it is not. I'm using LMDE 3 ant its repository haven't the last Firefox version. I have updated it manually and now add-ons work ! Thank you :D
這篇文章有幫助嗎?
引用

提出問題者

James said

LMDE 3 Cindy is a Linux distro version as LMDE is short for “Linux Mint Debian Edition” Many long term support distro versions use Firefox ESR instead of current Release channel.

Exactly. But I had forgotten that ! I hadn't used LMDE for several months and this detail escaped me.

James said

louki, if you are using 60.6.1esr or older

It was the case.

It happens on this distro that the update manager has not the good package names (or not a newer version I need). Then I copy-paste the link (here : http://mint.remi.lu/pool/upstream/f/firefox/firefox_60.6.3esr~linuxmint1+cindy_amd64.deb ) into firefox (and I remove the package name, which doesn't exist) and I download from the list the .deb package. Gdebi tell me the repository has an older version and that I should follow blablabla, I ignore it (because I know what I'm doing) and I install it.

Thank you for your answer !

''James [[#answer-1225550|said]]'' <blockquote> LMDE 3 Cindy is a Linux distro version as LMDE is short for “Linux Mint Debian Edition” Many long term support distro versions use Firefox ESR instead of current Release channel. </blockquote> Exactly. But I had forgotten that ! I hadn't used LMDE for several months and this detail escaped me. ''James [[#answer-1225550|said]]'' <blockquote> '''louki,''' if you are using 60.6.1esr or older </blockquote> It was the case. It happens on this distro that the update manager has not the good package names (or not a newer version I need). Then I copy-paste the link (here : http://mint.remi.lu/pool/upstream/f/firefox/firefox_60.6.3esr~linuxmint1+cindy_amd64.deb ) into firefox (and I remove the package name, which doesn't exist) and I download from the list the .deb package. Gdebi tell me the repository has an older version and that I should follow blablabla, I ignore it (because I know what I'm doing) and I install it. Thank you for your answer !

由 louki 於 修改

這篇文章有幫助嗎?
引用
問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題