搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Web links received in Thunderbird emails not working in Firefox V67.0, 64Bit

  • 42 回覆
  • 1 有這個問題
  • 25 次檢視
  • 最近回覆由 TheUrbaneOne

more options

Emailed 'Links' worked with all prior versions of Firefox until installing 67.0 this yesterday. Firefox opens to 'New Tab' without linking to the selected webpage. (No website name in the new tab.) No net activity. Desired website can only be accessed via direct entry or 'cut & paste' entry of the URL.

所有回覆 (20)

more options

Hi TheUrbaneOne, there are some differences with how Firefox 67 works with profiles, and this might be related to how "external" links open in Firefox. I'm still trying to get an understanding of whether that is relevant.

Do you know whether your Firefox shortcut is customized with any command-line options related to profiles? For example, your shortcut Target might usually be:

"C:\Program Files\Mozilla Firefox\firefox.exe"

and a customized one might be

"C:\Program Files\Mozilla Firefox\firefox.exe" -P "workstuff"

Or if you were starting up directly into the Profile Manager

"C:\Program Files\Mozilla Firefox\firefox.exe" -P

Anything along those lines?

more options

Do you possibly have a xxxxxxxx.default and a xxxxxxxx.default-release profile folder?

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\
more options

Is that a question or a statement? I have xxx.default no xxx.default-release. The system was working fine until I upgraded to 67.0 yesterday. Prior upgrade was last week. Firefox is also not taking links from the Taskbar/'Links' - with both emails and Taskbar/Links it just opens to 'New Tab' and does nothing else...

more options

1) No customized shortcuts. 2) Has xxx.default does not have xxx.default-release

Again, the prior upgrade which i Installed about a week ago worked fine. Never problems until the installation of 67.0, 64 Bit yesterday afternoon. If I can get the prior version I would like to do a rollback...

more options

Hi TheUrbaneOne, could you take a look on the Profile Manager page:

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Firefox may list multiple profiles here, each with information about its folder locations (you can ignore that for the moment). The currently running profile should have:

This is the profile in use and it cannot be deleted.

If that profile has a button below its table to Set as default profile try clicking that button. If it doesn't have that button, then never mind.

more options

see attached...

more options

Hmm, there might be an issue in your Profiles.ini file. We are just beginning to get reports about external link issues, so I'm not sure what to recommend at this point. If you can tolerate the situation for a little longer, we may learn more from other sources.

more options

Try to rename/remove compatibility.ini in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page and go to the root location.

more options

I generally wait awhile before doing full version upgrades for this very reason. However, this time I just thought 'what-the-heck?'... guess I should have waited. It's not a crippling issue, just an inconvenience as it is a feature/function I depend on constantly. I'll try the suggestion mentioned by 'cor-el' regarding the compatibility.ini file and report back. But as long as similar reports are starting to be returned, if the issue is not immediately repaired I'll wait to see what transpires and eagerly download .01...

Back to you two shortly...

more options

Okay - I'm back. Changed the compatibility.ini file name, tried both an emailed link in Thunderbird and a link in the Taskbar/'Links' - same situation. Firefox boots-up and stops at 'New Tab' - no linking.

FYI... The new compatibility.ini file generated by the Foxfire boot-up and the old copy were 100% identical in their scripting.

If there are other suggestions I am open to assisting. Otherwise, I can live with this issue for awhile while better heads than mine ponder the problem and devise a patch...

Thank you jscher2000 and cor-el.

more options

What profile is opened if you check this in the "Help -> Troubleshooting Information" (about:support) page?

Is that the same profile that you use normally and that is set as default on the about:profiles page? You can open "about:" pages via the location/address bar

  • "about:" is a protocol to access special pages
more options

I have only one profile. And it is the same referenced profile in 'About:Profiles', Troubleshooting Information and confirmed in Windows Explorer. As I keep stating - everything worked perfectly until I updated to V67.0 ... ... ...

more options

Hi TheUrbaneOne, if I understand correctly, when you use a link in Thunderbird, Firefox opens a useless window that doesn't navigate. Could you check the about:profiles page in that window? We are (half) expecting to see that there is a new profile being used for that window instead of your regular one (the one with .default on the end). But either way, if that about:profiles page has "Set as default profile" for your normal profile, please click it.

more options

Are you not reading my responses??? I've answered this in almost every response... I HAVE ONLY ONE PROFILE - I sent a photo of the 'about:profiles' section at 5:30 PM yesterday. And I have the same problem with the 'Taskbar/Links'. (see attached)

more options

Obviously the problem is with the 'enhancements' added to V67.0. ¿Pop-up video blocker issues?

more options

FYI, I also removed all blocking, rebooted the system and it didn't alter the problem. (see attached)

more options

TheUrbaneOne said

Are you not reading my responses??? I've answered this in almost every response... I HAVE ONLY ONE PROFILE - I sent a photo of the 'about:profiles' section at 5:30 PM yesterday. And I have the same problem with the 'Taskbar/Links'. (see attached)

Yes, I'm reading your replies and comparing experiences of other posters with odd external link issues. However, I wasn't sure if you checked the about:profiles page in BOTH a normal working window AND the dysfunctional window generated by an external link. That is why I asked you to check that.

installs.ini and Profiles.ini

Firefox 67 has changed some settings files and I was hoping to repair any inconsistencies through the about:profiles screen. If that isn't possible, you could look at these files in a text editor. This is exploratory as I haven't had to ask other users to try this yet.

First, please set Windows to show all file extensions to ensure that any changes are made to the correct files. This page has the steps: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Next, open the Firefox folder by pasting the following shortcut into the Windows 7 Start menu search box and pressing Enter to launch a new Windows Explorer window:

%APPDATA%\Mozilla\Firefox

This folder should have two INI files -- installs.ini and Profiles.ini -- as well as a Profiles folder and potentially some other folders.

INI files are plain text files with a specific structure to them. They are fairly easy to understand. However, it is important to only change them in a plain text editor and not a word processor that might insert formatting codes. The Windows "Notepad" program should work (right-click > Edit on most systems).

installs.ini

This file should contain at least one section headed by a random-looking identifier and listing a default profile. For example:

[369C369C369C369C]
Default=Profiles/abcd1234.default-release
Locked=1

This needs to match up with your actual default profile folder name.

Profiles.ini

This file may contain several sections but one should look roughly like this:

[Install369C369C369C369C]
Default=Profiles/abcd1234.default-release
Locked=1

Or in other words, it's the same, except the word Install appears before the random-looking identifier. Again, the profile folder listed under Default needs to match up with your actual default profile folder name.

Can you check whether those match and, if not, edit them?

more options

Only one .ini profile reference (see attached)

FYI... - Using <%APPDATA%\Mozilla\Firefox> brings up the search engine and not the requested information. - I accessed the information directly using Windows Explorer. - My Windows Explore is always set to show the extensions. - Though it has been many years since I have kept my certifications current I do have an extensive technical background in digital and broadcast engineering - so I am comfortable with whatever you ask me to look for.

more options

Anyone have another idea or something else they would like me to check???

more options

You could try the double-default-browser-switch to force Firefox to update those registry entries used for links. Let IE make itself the default browser (I think there is a button in the Internet Options control panel), and then let Firefox make itself the default browser again.

  1. 1
  2. 2
  3. 3