搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why do other websites think I am using Opera version 38 when I have FireFox version 65.0.1?

  • 3 回覆
  • 1 有這個問題
  • 29 次檢視
  • 最近回覆由 jhuller

more options

I am using FireFox v65.0.1 with the latest macOS Mojave. When I go to some websites, I get a message that my browser is outdated. If I go to whatismybrowser.com, I get the message that I am using Opera version 38. Why is my FireFox browser being misidentified.

I am using FireFox v65.0.1 with the latest macOS Mojave. When I go to some websites, I get a message that my browser is outdated. If I go to whatismybrowser.com, I get the message that I am using Opera version 38. Why is my FireFox browser being misidentified.
附加的畫面擷圖

被選擇的解決方法

hi, your useragent (the information the browser sends to websites to identify its version) - apparently mistakenly - shows you're on opera. probably some sort of extension has overwritten it.

please see here in order to reset the user-agent settings in firefox and fix this problem: How to reset the default user agent on Firefox

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

選擇的解決方法

hi, your useragent (the information the browser sends to websites to identify its version) - apparently mistakenly - shows you're on opera. probably some sort of extension has overwritten it.

please see here in order to reset the user-agent settings in firefox and fix this problem: How to reset the default user agent on Firefox

more options

The User Agent you displayed to this site is Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36 OPR/38.0.2220.41

So either you have a User Agent related Extension installed or manually modified the UA or something else is sending this UA.

If the UA was modified in Firefox then see https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

more options

Yes, the process of resetting my default user agent worked. I had to reset some additional settings as well. There were two other "general useragent" fields in bold, one of which had a value of Opera. I reset them, and now my browser is correctly recognized. Thanks so much!!