X
點擊此處開啟此網站的行動版。

技術支援討論區

Cannot set Firefox as PDF default viewer

已張貼

Prior FF option to select "preview PDF in FF" is no longer offered (or visible). But my selecting "just" "Firefox" from the drop-down list of available PDF default viewers does not "stick"--the PDF viewer always remains "Edge"--even though FF is set as the general default browser. The same problem was occurring when Acrobat Reader DC was on the computer and it was the default for PDF's--so I entirely removed that app, but now I get (MS's built-in) Edge as the PDF default but not FF. Changing file associations, etc. just does not have any effect! I am using the current versions of FF and Windows 10 Pro.

Prior FF option to select "preview PDF in FF" is no longer offered (or visible). But my selecting "just" "Firefox" from the drop-down list of available PDF default viewers does not "stick"--the PDF viewer always remains "Edge"--even though FF is set as the general default browser. The same problem was occurring when Acrobat Reader DC was on the computer and it was the default for PDF's--so I entirely removed that app, but now I get (MS's built-in) Edge as the PDF default but not FF. Changing file associations, etc. just does not have any effect! I am using the current versions of FF and Windows 10 Pro.

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 31.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

更多資訊

Ruba 13 個解決方法 64 個答案

Hello Steven22, as for "Preview PDF in Firefox" it is still exist Click the menu button then choose Options. Select the General panel and scroll down to the Applications section. Select the Portable Document Format (PDF) entry and double check that the action is set to "Preview in Firefox".

This option for links within browsers, if you want and PDF file to be opened outside the browser, then on your Windows 10 Go to Settings -> Apps -> Default Apps then at bottom of the window you have 3 options : Choose default Apps by File Type, Choose Default Apps by Protocol and Set Default by App . in "Choose Apps by File Type" scroll down to .pdf and change the default app to Firefox :)

Hello Steven22, as for "Preview PDF in Firefox" it is still exist Click the menu button then choose Options. Select the General panel and scroll down to the Applications section. Select the Portable Document Format (PDF) entry and double check that the action is set to "Preview in Firefox". This option for links within browsers, if you want and PDF file to be opened outside the browser, then on your Windows 10 Go to Settings -> Apps -> Default Apps then at bottom of the window you have 3 options : Choose default Apps by File Type, Choose Default Apps by Protocol and Set Default by App . in "Choose Apps by File Type" scroll down to .pdf and change the default app to Firefox :)

由 Ruba 於 修改

提出問題者

Ruba, thanks for responding. But I tried your suggestions before I posted the problem, and they did not work. I also reset Firefox and that did not work either. As I noted, selecting he choice that now says "Firefox" simply does not work, and the link that used to say "preview PDFs in Firefox" (which worked) does not appear at all.

Ruba, thanks for responding. But I tried your suggestions before I posted the problem, and they did not work. I also reset Firefox and that did not work either. As I noted, selecting he choice that now says "Firefox" simply does not work, and the link that used to say "preview PDFs in Firefox" (which worked) does not appear at all.