X
點擊此處開啟此網站的行動版。

技術支援討論區

firefox automatically redirects me to msn canada website

已張貼

Just bought a new acer aspire. When I use firefox as my search engine I am automatically redirected to MSN Canada website.

Just bought a new acer aspire. When I use firefox as my search engine I am automatically redirected to MSN Canada website.

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

更多資訊

jscher2000
  • Top 10 Contributor
8792 個解決方法 71897 個答案

I think the Acer Aspire runs Windows 10; a moderator can move your post from Android to Desktop/Windows.

Where do you see MSN Canada in Firefox? For example:

(1) At startup, it's the home page, or in new windows (Ctrl+n), it's the page there

Please see this article: How to set the home page

(2) When searching from the address bar or one of Firefox's built-in pages, instead of getting Google results, end up on MSN

That's weird! Could you check: Change your default search settings in Firefox


Even with a new installation of Firefox, it's possible some add-ons were already present on the system and Firefox activated them.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

I think the Acer Aspire runs Windows 10; a moderator can move your post from Android to Desktop/Windows. Where do you see MSN Canada in Firefox? For example: (1) At startup, it's the home page, or in new windows (Ctrl+n), it's the page there Please see this article: [[How to set the home page]] (2) When searching from the address bar or one of Firefox's built-in pages, instead of getting Google results, end up on MSN That's weird! Could you check: [[Change your default search settings in Firefox]] ---- Even with a new installation of Firefox, it's possible some add-ons were already present on the system and Firefox activated them. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement?