搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

My Firefox browser doesn't do auto login when I enter the websites, anybody know how to fix it?

  • 20 回覆
  • 5 有這個問題
  • 13079 次檢視
  • 最近回覆由 Happy112

more options

When I enter some site such as Facebook or Youtube, the browser doesn't auto login. I have to manually type the username and password myself.

被選擇的解決方法

I think I just fixed it. I went to Preferences > Privacy. Then, in the History section, I changed the Firefox will: from "Use custom settings for history" to "Remember History", and it works.

從原來的回覆中察看解決方案 👍 0

所有回覆 (20)

more options

Hi   !

Would you make sure that you're not in permanent Private Browsing mode :

3-bar menu (or 'Tools') => Options => Privacy => Firefox will : 'Use custom settings for history' Uncheck : 'Always use private browsing mode'

And in Options => Security => under 'Logins': make sure that 'Remember logins for sites' is checked.

https://support.mozilla.org/kb/Private+Browsing

more options

Yes, the private browsing is unchecked and the 'Remember logins' is enabled, but the browser still not doing an auto login.

more options

Would you check this setting :

Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type in the search bar signon and look for the preference : signon.rememberSignons it's value should be set to true

more options

I checked it, it marks as 'true'.

Is it possible that it might be some sort of settings? Since when I signing in my Firefox account to the browser in another computer, it also doesn't auto login.

Also, I have a Tor browser installed in my computer, not sure if this causing the problem.

more options

Boyd951 said

Is it possible that it might be some sort of settings?

You checked the settings and they were all correct .....

Would you consider this add-on :

https://addons.mozilla.org/en-US/firefox/addon/secure-login-webextension/

more options

Hi,

The add-on automatically fill the username and password when I click the lock icon at the top left. However, in the past time, the site automatically login after I open it, and does the same after I reopen the browser. But now, after I reopen the browser, the site is signing off and I have to login again. Is there any Firefox changes that I don't know?

more options

Boyd951 said

Also, I have a Tor browser installed in my computer, not sure if this causing the problem.

That shouldn't have any effect :

https://ssd.eff.org/en/module/how-use-tor-macos

more options

You can check in the Password Manager if you have multiple names saved from the domain because that will prevent Firefox from filling the name automatically.

3-bar menu (or 'Tools') => Options => Security : Passwords : 'Saved Passwords' => 'Show Passwords'

You could also check in 'about:config' the preference :

signon.autofillForms Its value should be set to true

more options

The Password Manager Looks fine and the signon.autofillForms is already set to true. Should the signon.autofillForms.http and signon.autologin.proxy be set to true as well?

more options

Not giving up just yet .......

Let's start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem.

If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And also : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

more options

Still not auto login in the safe mode. Even when all the add-ons, hardware acceleration and extension turning off.

more options

The reason why I suspect the Tor browser is because this happens after I've installed the Tor browser. There also have some Tor sites bookmark automatically added to Firefox.

more options

Boyd951 said

The reason why I suspect the Tor browser is because this happens after I've installed the Tor browser. There also have some Tor sites bookmark automatically added to Firefox.

Only one way to find out ...... (Firefox acting like a woman scorned, since you installed another browser)


Running completely out of ideas, but giving it one more shot :

In case you use "Clear history when Firefox closes" or otherwise clear history :

do not clear the Cookies do not clear the Site Preferences

Options => Privacy => Firefox will : "Use custom settings for history" : [X] "Clear history when Firefox closes" => Settings

https://support.mozilla.org/kb/remove-recent-browsing-search-and-download-history

Clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data.

Clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep.

由 Happy112 於 修改

more options

A little miracle happened here. I signed in my Firefox sync account to the browser in my another computer but unchecked the add-ons and preference syncing, the another computer doesn't have a problem. So, the problem seems to be the settings or add-ons.

more options

This is weird since the cookies and site preferences are both unchecked.

more options

Boyd951 said

A little miracle happened here. I signed in my Firefox sync account to the browser in my another computer but unchecked the add-ons and preference syncing, the another computer doesn't have a problem. So, the problem seems to be the settings or add-ons.

Then, would you disable them again (Safe Mode will do that for you) and then re-enable them one by one till you find the culprit  ? And when you find it : let us know ......

more options

選擇的解決方法

I think I just fixed it. I went to Preferences > Privacy. Then, in the History section, I changed the Firefox will: from "Use custom settings for history" to "Remember History", and it works.

more options

Boyd951 said

I think I just fixed it. I went to Preferences > Privacy. Then, in the History section, I changed the Firefox will: from "Use custom settings for history" to "Remember History", and it works.

Yay  !   Finally  ! Would you be a dear and mark your last post as 'Chosen Solution' - that way others will know and might benefit from it.

Well done  !

more options

Thanks for the help!!!

more options

Boyd951 said

Thanks for the help!!!

My pleasure   !

One little thing though : You inadvertenly marked my post as 'Chosen Solution', while it was you who solved the problem ...... You can rectify that by clicking the Undo button to the right, and then mark your post (the one that says what solved the problem) as such.

You've done a great job  !