X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox takes a long time to connect to websites on start.

已張貼

This problem is weirdly specific, I have tried other browsers and firefox is the only thing affected, so its firefox specific. When I first open firefox, firefox itself opens and loads within seconds perfectly fine, I can do things with it offline perfectly fine (like using it to open a file) But when I try to go to any website, it takes ages to load and function normally. It doesnt even matter how many tabs I open, I can load one website, or three, it takes the same amount of time.

Once it has loaded the website(s) it functions completely normally! I can load new websites or pages just fine, and everything works perfectly, until I close firefox and open it again. Its driving me insane because I'm not going to just leave firefox open at all times (This is a gaming PC, I try to not have too many unnecessary programs running in the background)

I have tried several things, I reset firefox, didnt work. I have reset my PC, didnt work. I ran firefox in safe mode...worked! So it must be a add-on or extension, right? ...Nope, turned them all off one by one and every time it didn't work. (I only run uBlock anyway)

So whatever the issue is, has something to do with something safe-mode would prevent/turn off, but not add-on's/extensions.

EDIT: Forgot to also mention, I tried clearing cache/cookies/history as well, so pretty much everything short of a completely clean re-install of firefox with none of my personal data, but hoping to avoid the nuclear option if I can.

This problem is weirdly specific, I have tried other browsers and firefox is the only thing affected, so its firefox specific. When I first open firefox, firefox itself opens and loads within seconds perfectly fine, I can do things with it offline perfectly fine (like using it to open a file) But when I try to go to any website, it takes ages to load and function normally. It doesnt even matter how many tabs I open, I can load one website, or three, it takes the same amount of time. Once it has loaded the website(s) it functions completely normally! I can load new websites or pages just fine, and everything works perfectly, until I close firefox and open it again. Its driving me insane because I'm not going to just leave firefox open at all times (This is a gaming PC, I try to not have too many unnecessary programs running in the background) I have tried several things, I reset firefox, didnt work. I have reset my PC, didnt work. I ran firefox in safe mode...worked! So it must be a add-on or extension, right? ...Nope, turned them all off one by one and every time it didn't work. (I only run uBlock anyway) So whatever the issue is, has something to do with something safe-mode would prevent/turn off, but not add-on's/extensions. EDIT: Forgot to also mention, I tried clearing cache/cookies/history as well, so pretty much everything short of a completely clean re-install of firefox with none of my personal data, but hoping to avoid the nuclear option if I can.

由 Zaayl 於 修改

被選擇的解決方法

I finally "fixed" the problem (Still no clue as to the root cause of the problem.) by doing a clean reinstall.

This included deleting all of the Mozilla data in the %Appdata% sections as simply reinstalling the program/ "refreshing" firefox did absolutely nothing. (This process was outright infuriating, since one of the folders appears impossible to access or delete even with admin privileges, I assume its where saved passwords are kept. But this resulted in the deletion process taking way longer than necessary since it would reach that folder and try to delete it, then stop the entire process, forcing me to go into the directories and delete things folder by folder)

I then reinstalled firefox, restarted my PC, and now it works absolutely perfectly. I really wish Mozilla would bring back the "uninstall all data" option in the uninstaller, it would have saved so much time, hassle and frustration.

從原來的回覆中察看解決方案 3

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 25.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

更多資訊

FredMcD
  • Top 10 Contributor
4305 個解決方法 60415 個答案

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key;<Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General. ''' Look for and turn off Use '''Hardware Acceleration. ''' Type '''about:addons'''<enter> in the address bar to open the Add-ons Manager. Hot key;'''<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance. ''' Then select '''Default. ''' Now restart Firefox.

提出問題者

FredMcD said

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key;<Control> (Mac=<Command>) <Shift> A) On the left side of the page, select Appearance. Then select Default. Now restart Firefox.

Did not work.

''FredMcD [[#answer-961729|said]]'' <blockquote> Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General. ''' Look for and turn off Use '''Hardware Acceleration. ''' Type '''about:addons'''<enter> in the address bar to open the Add-ons Manager. Hot key;'''<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance. ''' Then select '''Default. ''' Now restart Firefox. </blockquote> Did not work.
FredMcD
  • Top 10 Contributor
4305 個解決方法 60415 個答案

Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Start Firefox in Safe Mode by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

提出問題者

In my original post I mention that safe mode worked fine, but turning off add-ons did not work.

In my original post I mention that safe mode worked fine, but turning off add-ons did not work.
FredMcD
  • Top 10 Contributor
4305 個解決方法 60415 個答案

Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.

有幫助的回覆

One of them was already off, turning both off did nothing.

One of them was already off, turning both off did nothing.
Andrew
  • Moderator
324 個解決方法 4090 個答案

Team, are there any more suggestions or fixes for this?

Thanks!

ref: https://twitter.com/Zaayl/status/856662475604807680

Team, are there any more suggestions or fixes for this? Thanks! ''ref: https://twitter.com/Zaayl/status/856662475604807680''

選擇的解決方法

I finally "fixed" the problem (Still no clue as to the root cause of the problem.) by doing a clean reinstall.

This included deleting all of the Mozilla data in the %Appdata% sections as simply reinstalling the program/ "refreshing" firefox did absolutely nothing. (This process was outright infuriating, since one of the folders appears impossible to access or delete even with admin privileges, I assume its where saved passwords are kept. But this resulted in the deletion process taking way longer than necessary since it would reach that folder and try to delete it, then stop the entire process, forcing me to go into the directories and delete things folder by folder)

I then reinstalled firefox, restarted my PC, and now it works absolutely perfectly. I really wish Mozilla would bring back the "uninstall all data" option in the uninstaller, it would have saved so much time, hassle and frustration.

I finally "fixed" the problem (Still no clue as to the root cause of the problem.) by doing a clean reinstall. This included deleting all of the Mozilla data in the %Appdata% sections as simply reinstalling the program/ "refreshing" firefox did absolutely nothing. (This process was outright infuriating, since one of the folders appears impossible to access or delete even with admin privileges, I assume its where saved passwords are kept. But this resulted in the deletion process taking way longer than necessary since it would reach that folder and try to delete it, then stop the entire process, forcing me to go into the directories and delete things folder by folder) I then reinstalled firefox, restarted my PC, and now it works absolutely perfectly. I really wish Mozilla would bring back the "uninstall all data" option in the uninstaller, it would have saved so much time, hassle and frustration.
FredMcD
  • Top 10 Contributor
4305 個解決方法 60415 個答案

That was very good work. Well done.

That was very good work. Well done.