X
點擊此處開啟此網站的行動版。

技術支援討論區

Videos playing only with sound after update to 49.0.2

已張貼

After Firefox update to 49.0.2 i have problems with videos on sites like: http://www.cc.com/video-clips/07m87l/the-daily-show-with-trevor-noah-donald-trump-hints-at-a-not-so-peaceful-transfer-of-power or http://time.com/4514971/iphone-7-worlds-tallest-building/

There is only sound, no picture, just grey/black background. Downgrading to 48.0.2 helped, but on this version Netflix videos aren't working.

After Firefox update to 49.0.2 i have problems with videos on sites like: http://www.cc.com/video-clips/07m87l/the-daily-show-with-trevor-noah-donald-trump-hints-at-a-not-so-peaceful-transfer-of-power or http://time.com/4514971/iphone-7-worlds-tallest-building/ There is only sound, no picture, just grey/black background. Downgrading to 48.0.2 helped, but on this version Netflix videos aren't working.

由 sparrhawk 於 修改

被選擇的解決方法

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste async and pause while the list is filtered (3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.


One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

從原來的回覆中察看解決方案 2

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • Shockwave Flash 23.0 r0
  • 5.1.41212.0

應用程式

  • Firefox 49.0.2
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/49.0.2/WINNT/pl/

擴充套件

  • 1-Click YouTube Video Downloader 2.4.1 (YoutubeDownloader@PeterOlayev.com)
  • Auto Refresh 1.0.2.1-signed.1-signed (autorefresh@plugin)
  • Eliminator Slajdów 3.1.48 (jid0-GaZOxvWNYcafEsmayJDIG3XXVi8@jetpack)
  • EPUBReader 1.5.0.9 ({5384767E-00D9-40E9-B72F-9CC39D655D6F})
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • uBlock Origin 1.9.12 (uBlock0@raymondhill.net)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • YouTube Video and Audio Downloader 0.5.5 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack)
  • Avira Browser Safety 1.12.2.9301 (abs@avira.com) (Inactive)
  • ReloadEvery 45.0.0 ({888d99e7-e8b5-46a3-851e-1ec45da1e644}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics 5500
  • adapterDescription2: AMD Radeon(TM) R9 M375
  • adapterDeviceID: 0x1616
  • adapterDeviceID2: 0x6820
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 382417aa
  • adapterSubsysID2: 382417aa
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x1002
  • crashGuards: [{u'prefName': u'gfx.crash-guard.status.glcontext', u'type': u'glcontext'}]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 10.0.14393.321
  • driverDate: 8-5-2015
  • driverDate2: 8-6-2015
  • driverVersion: 10.18.15.4268
  • driverVersion2: 15.201.1101.0
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'name': u'HW_COMPOSITING', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}]}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}]}, {u'status': u'unavailable', u'description': u'Direct2D', u'name': u'DIRECT2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}]}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}]}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

有幫助的回覆

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

提出問題者

Thanks, but these unfortunately don't sove my problems. This is apparently html5 question, not Flash. And since downgrading FF version helps, i guess it's something with latest update.

Thanks, but these unfortunately don't sove my problems. This is apparently html5 question, not Flash. And since downgrading FF version helps, i guess it's something with latest update.
Happy112 561 個解決方法 5694 個答案

Hi, Would you take a look at the article   'HTML5 audio and video in Firefox' :
        http://mzl.la/1aoxUbC
and also:
https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

Hi, Would you take a look at the article &nbsp; 'HTML5 audio and video in Firefox' :<BR> &nbsp; &nbsp; &nbsp; &nbsp; http://mzl.la/1aoxUbC <BR> and also:<BR> https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

提出問題者

Yes, I've seen these links before but these suggestions didnt help. All plugins are apparently updated and working properly.

I just hope it's FF update thing and will be fixed with the next version.

Yes, I've seen these links before but these suggestions didnt help. All plugins are apparently updated and working properly. I just hope it's FF update thing and will be fixed with the next version.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

Some have tried this; Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Some have tried this; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe websites. Are there any problems?

提出問題者

Also tried this, no effect however.

Also tried this, no effect however.
Happy112 561 個解決方法 5694 個答案

sparrhawk said

Also tried this, no effect however.

Bummer   !!!
I'm a bit confused about your question;   in the heading you say : 'Videos playing without sound  ....',   while at the bottow you say: 'There is only sound   .......'.
Help me out here:   which is it   ?

''sparrhawk [[#answer-929305|said]]'' <blockquote> Also tried this, no effect however. </blockquote> Bummer &nbsp; !!!<BR> I'm a bit confused about your question; &nbsp; in the heading you say : 'Videos playing without sound&nbsp; ....', &nbsp; while at the bottow you say: 'There is only sound &nbsp; .......'.<BR> Help me out here: &nbsp; which is it &nbsp; ?

提出問題者

Sorry! My terrible mistake, don't know how I wrote that. Only sound, no picture, I apologize for the confusion. Thanks for correction.

Sorry! My terrible mistake, don't know how I wrote that. Only sound, no picture, I apologize for the confusion. Thanks for correction.
Happy112 561 個解決方法 5694 個答案

sparrhawk said

Sorry! My terrible mistake, don't know how I wrote that. Only sound, no picture, I apologize for the confusion. Thanks for correction.

Aww,   don't worry about it;   I make mistakes all the time   !

''sparrhawk [[#answer-929310|said]]'' <blockquote> Sorry! My terrible mistake, don't know how I wrote that. Only sound, no picture, I apologize for the confusion. Thanks for correction. </blockquote> Aww, &nbsp; don't worry about it; &nbsp; I make mistakes all the time &nbsp; !
Happy112 561 個解決方法 5694 個答案

You have tried everything that was sugggested,   and still no luck   ........
Stab in the dark:
www.thewindowsclub.com/flash-player-settings-windows

You have tried everything that was sugggested, &nbsp; and still no luck &nbsp; ........<BR> Stab in the dark:<BR> www.thewindowsclub.com/flash-player-settings-windows
Mildrew 1 個解決方法 18 個答案

I also have the same problem, sound but no video on http://www.independent.co.uk

First frame of video shows but then blank screen and only sound. Tried all suggestions but all to no avail. Other browsers work fine but Firefox no. Think I might "jump ship" with Firefox, as this is not the first time problems have occurred with an "update" but like the add-ons on Firefox

I also have the same problem, sound but no video on http://www.independent.co.uk First frame of video shows but then blank screen and only sound. Tried all suggestions but all to no avail. Other browsers work fine but Firefox no. Think I might "jump ship" with Firefox, as this is not the first time problems have occurred with an "update" but like the add-ons on Firefox
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

選擇的解決方法

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste async and pause while the list is filtered (3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.


One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

(1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''async''' and pause while the list is filtered (3) Double-click the '''dom.ipc.plugins.asyncdrawing.enabled''' preference to switch the value from true to false This might not take effect until the next time you exit Firefox and start it up again. ------------------------------ One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, check the row for '''Multiprocess Windows''' and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s. ''If you are using e10s:'' To help evaluate whether that feature is causing this problem, you could turn it off as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autos''' and pause while the list is filtered (3) Double-click the '''browser.tabs.remote.autostart.2''' preference to switch the value from true to false ''Note: the exact name of the preference may vary, but it will start with '''browser.tabs.remote.autostart''''' At your next Firefox startup, it should run in the traditional way. Any difference?
Mildrew 1 個解決方法 18 個答案

Thanks that seems to have done the trick, after just spending a few hours getting Chrome to act the way I like it. Much prefer Firefox though.

Thanks that seems to have done the trick, after just spending a few hours getting Chrome to act the way I like it. Much prefer Firefox though.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

提出問題者

Thanks a lot, that "asyncdrawing" change helped!

Thanks a lot, that "asyncdrawing" change helped!
RandomTroll 5 個解決方法 51 個答案

I have exactly this problem. The commercials display video, the show doesn't. I view videos at the library (because my home connection is too slow); this behavior happens with both the library's installation and the installation I have on my flash drive. IE and Chrome work.

Being the library I can't change a lot of these settings.

I have exactly this problem. The commercials display video, the show doesn't. I view videos at the library (because my home connection is too slow); this behavior happens with both the library's installation and the installation I have on my flash drive. IE and Chrome work. Being the library I can't change a lot of these settings.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

At the library, are you using your own computer or the libraries?

At the library, are you using your own computer or the libraries?
RandomTroll 5 個解決方法 51 個答案

FredMcD said

At the library, are you using your own computer or the libraries?

The library's. I hoped that would be obvious from my comment that I can't make changes in the Firefox configuration.

''FredMcD [[#answer-934263|said]]'' <blockquote> At the library, are you using your own computer or the libraries? </blockquote> The library's. I hoped that would be obvious from my comment that I can't make changes in the Firefox configuration.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59390 個答案

You must inform the staff there about the issue.

You must inform the staff there about the issue.
RandomTroll 5 個解決方法 51 個答案

FredMcD said

You must inform the staff there about the issue.

I did. It's wishful thinking that they will troubleshoot it to the extent this thread proposes. If the people who write Firefox think this behavior is okay, that's their call. I'm just letting them know how it works out in 1 case.

''FredMcD [[#answer-934342|said]]'' <blockquote> You must inform the staff there about the issue. </blockquote> I did. It's wishful thinking that they will troubleshoot it to the extent this thread proposes. If the people who write Firefox think this behavior is okay, that's their call. I'm just letting them know how it works out in 1 case.