搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Open Files instead of saving?

  • 3 回覆
  • 12 有這個問題
  • 9705 次檢視
  • 最近回覆由 FredMcD

more options

When I used to click on a PDF file, it would automatically open in my default PDF viewer. Now it askes me to save even though I have set in preferences that PDF should be opened automatically with my PDF viewer.

Now I have to wait for it download, then click on it again. I do not want these files saved permanently, they should save to the %temp% directory and be automatically opened in the default program. Please tell me what I need to do to get this working again.

Thank you!

被選擇的解決方法

Check with the IP for the company.

從原來的回覆中察看解決方案 👍 1

所有回覆 (3)

more options

Type about:preferences#applications<enter> in the address bar. Use the search bar on the page. What is the setting?


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Thank you For the tip. I have set it to "Use PDF-XChange Editor (default). Now files open in that program, however it still always asks me if I would like to save or open the file, even though I have selected "Do this automatically for files like this from now on". Note that from most websites, the PDF just open without asking if I want to save or open. It only asks from the back-end of my company's website. I can live with that, but it would be nice to hear some advice on how to fix this.

Thanks!

more options

選擇的解決方法

Check with the IP for the company.