Search Support

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Untrusted connection error on almost every website

  • 10 回覆
  • 15 有這個問題
  • 1262 次檢視
  • 最近回覆由 philipp

more options

Every time I try to go to a website I get "an untrusted connection error" it gives me "(Error code: sec_error_unknown_issuer)".wa I have made sure my clock is the right time and date, still get error. I have reset firefox, still get error. I have deleted cert8.db, still get error. I ran ADWcleaner, still get error. I cant fix this error no matter what I do please help it will be very much appreciated.

被選擇的解決方法

hi, if you have parents who set those controls, then they'd have to lift the restrictions as well.

alternatively (and this is just a hunch, i don't know if it would work) you could try the steps mentioned in this ms help article for windows 8: https://support.microsoft.com/en-us/kb/2965142 - there's a section called Known issues for Firefox usersdescribing a workaround to import the necessary certificates into firefox...

從原來的回覆中察看解決方案 👍 2

All Replies (10)

more options

hi muchispac, unfortunately this can currently happen on windows accounts that are restricted by the Microsoft Family safety settings - in order to disable those, please refer to http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

more options

When I got to the page it just tells me whos in my family and I acnt change anything, do I need to sign in as my parent??

more options

選擇的解決方法

hi, if you have parents who set those controls, then they'd have to lift the restrictions as well.

alternatively (and this is just a hunch, i don't know if it would work) you could try the steps mentioned in this ms help article for windows 8: https://support.microsoft.com/en-us/kb/2965142 - there's a section called Known issues for Firefox usersdescribing a workaround to import the necessary certificates into firefox...

more options

Thank you so very much, my problem is now fixed and I cant browse happily again =]

more options

great, thanks for your feedback - just to confirm (because it is affecting a number of users): did you try the manual workaround to import the ms cert that solved the issue?

more options

Yes, I follwed the instructions given and it worked fine

more options

thanks for following up & glad that it's working. have fun with firefox & windows 10 :))

more options

This is what I did to fix the problem and it worked fine without having to disable Microsoft family safety.

To consent to such snooping, and suppress all "Untrusted Certificate" warnings arising from this scheme, you need to instruct Firefox to trust Microsoft's SSL certificate that is used for re-encrypting. (Microsoft Internet Explorer doesn't have this "problem" because it trusts Microsoft's certificate out of the box. Google Chrome is the same, since it relies on cryptography mechanisms built into Windows. Firefox, however, uses its own cryptographic routines that consult a separate list of trusted root certificates.)

The certificate that you need to import is Microsoft's. Go to Control Panel → Network and Internet → Internet Options → Content → Certificates → Trusted Root Certification Authorities. Select the Microsoft Family Safety certificate, then click Export…. Answer No, do not export the private key. Either of the two .CER formats is fine. Save it to any convenient temporary location, such as familysafety.cer on your Desktop.

Then, you need to tell Firefox to trust the certificate that you just exported. In the Firefox menu, choose Options → Advanced → Certificates → View Certificates → Authorities → Import…. Select the familysafety.cer that you had just saved. Select Trust this CA to identify websites, then click OK, and close the Options dialog.

Once you do this restart Firefox and you should have no problem

由 Stretch4030 於 修改

more options

I have the same problem but I no have a family account , i no have malware, The date and time are correct, I try with internet explorer and no problem at all. i try chrome and opera no problems at all, only Firefox make problems. There is a solution or I have to uninstall Firefox , because I cannot use it

more options

pando, would you please open a new question about your issue? as appendix to a 5 months old solved thread you probably won't get much attention...