X
點擊此處開啟此網站的行動版。

技術支援討論區

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Firefox 31 changes all PDF icons to Firefox HTML icons that I can not seem to change back, can this be rectified? Using Windows XP.....

已張貼

Once Firefox 31 is installed it sees all PDF files as Firefox HTML files and changes all of the PDF icons to Firefox HTML icons. This change can not seem to be reversed without uninstalling Firefox. Only the icon is changed, not the .PDF extension.

Once Firefox 31 is installed it sees all PDF files as Firefox HTML files and changes all of the PDF icons to Firefox HTML icons. This change can not seem to be reversed without uninstalling Firefox. Only the icon is changed, not the .PDF extension.

被選擇的解決方法

This can happen if there is no default application that handles PDF files.

  • bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html


EDIT: This can also happen even though another application (e.g., Adobe Reader) is already set to handle PDF files. See: Bug 1069375 - Firefox 31 registers as PDF handler even when another handler is already registered

To solve this, you can reassociate PDF files to the application you wish to use. A solution for Adobe Reader was given by Pharteon in his Sept 18, 2014 answer (see below) which was also the solution given by dlschool in another thread, /questions/1014919#answer-618531.

從原來的回覆中察看解決方案 5

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 14.0 r0
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Plug-in for detecting Nero Kwik Media.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Logitech Harmony Remote Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

選擇的解決方法

This can happen if there is no default application that handles PDF files.

  • bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html


EDIT: This can also happen even though another application (e.g., Adobe Reader) is already set to handle PDF files. See: Bug 1069375 - Firefox 31 registers as PDF handler even when another handler is already registered

To solve this, you can reassociate PDF files to the application you wish to use. A solution for Adobe Reader was given by Pharteon in his Sept 18, 2014 answer (see below) which was also the solution given by dlschool in another thread, /questions/1014919#answer-618531.

This can happen if there is no default application that handles PDF files. *[https://bugzilla.mozilla.org/show_bug.cgi?id=452254 bug 452254] - Register for audio/video .ogg and .pdf file handlers if nothing else has <i>Please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i> ----- <sub>'''EDIT''': This can also happen even though another application (e.g., Adobe Reader) is already set to handle PDF files. See: [https://bugzilla.mozilla.org/show_bug.cgi?id=1069375 Bug 1069375] - Firefox 31 registers as PDF handler even when another handler is already registered</sub> <sub>To solve this, you can reassociate PDF files to the application you wish to use. A solution for Adobe Reader was given by Pharteon in his Sept 18, 2014 answer ([https://support.mozilla.org/en-US/questions/1013642#answer-630162 see below]) which was also the solution given by dlschool in another thread, [/questions/1014919#answer-618531].</sub>

由 AliceWyman 於 修改

提出問題者

Thank you very much, cor-el.

Your help was greatly appreciated.

Thank you very much, cor-el. Your help was greatly appreciated.
Bob_in_Calgary 0 個解決方法 5 個答案

有幫助的回覆

Cor-el is partly right, but this did happen on XP Pro 32 and 64 even when Foxit Reader is the default application for PDF's. I fixed this using this procedure. -Right click on any PDf file. -From the context options, go to "Open with" and click on "Choose program" -When the "Open With" window opens, select the program you want to use to open the pdf file. If it is installed but not listed, use the browse button. -Make this the default by clicking "Always use the selected program..." -Now click the "OK" button. All PDF's will now be opened with the program you selected. It is very rare that no PDF application is installed, but it does happen. In my opinion, the Firefox coders did a sloppy job with this version 31 update.

Cor-el is partly right, but this did happen on XP Pro 32 and 64 even when Foxit Reader is the default application for PDF's. I fixed this using this procedure. -Right click on any PDf file. -From the context options, go to "Open with" and click on "Choose program" -When the "Open With" window opens, select the program you want to use to open the pdf file. If it is installed but not listed, use the browse button. -Make this the default by clicking "Always use the selected program..." -Now click the "OK" button. All PDF's will now be opened with the program you selected. It is very rare that no PDF application is installed, but it does happen. In my opinion, the Firefox coders did a sloppy job with this version 31 update.

由 Bob_in_Calgary 於 修改

2kidsdad 0 個解決方法 6 個答案

Just started having the same problem last night in Windows XP running Firefox 31.0 I changed file type (.pdf) back to it's original settings to open with Adobe Reader. The association is correct. The file opens in Adobe Reader. However, the icon remains Mozilla Firefox icon. This is not good.

  • EDIT

I found a few more threads about this. I did not see any "fix" yet. I did see something in common though. Most made mention of the fact that the problem began after clicking on "Firefox / current browser" message when the box popped up. That's what happened here as well. And as far as I can tell I should never even had that pop up in the first place. Firefox has been the default browser for years / unchanged.

Also noticed this when I look at folder options / file types: You have customized files with extension "PDF". To restore these files to their default type (Firfox HTML Document) click Restore.

Just started having the same problem last night in Windows XP running Firefox 31.0 I changed file type (.pdf) back to it's original settings to open with Adobe Reader. The association is correct. The file opens in Adobe Reader. However, the icon remains Mozilla Firefox icon. This is not good. *EDIT I found a few more threads about this. I did not see any "fix" yet. I did see something in common though. Most made mention of the fact that the problem began after clicking on "Firefox / current browser" message when the box popped up. That's what happened here as well. And as far as I can tell I should never even had that pop up in the first place. Firefox has been the default browser for years / unchanged. Also noticed this when I look at folder options / file types: You have customized files with extension "PDF". To restore these files to their default type (Firfox HTML Document) click Restore.

由 2kidsdad 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案

You need to change the icon as well if you change the application to another program if Windows doesn't do this automatically or at least offers some choices. This is not a Firefox fault, but something that is not implemented in Windows.

You need to change the icon as well if you change the application to another program if Windows doesn't do this automatically or at least offers some choices. This is not a Firefox fault, but something that is not implemented in Windows.
2kidsdad 0 個解決方法 6 個答案

有幫助的回覆

Thank you for your reply but it's not that simple: Windows now thinks that the default file type for .pdf is Firfox HTML Document. I can change which program opens .pdf files but I can't change the icon. Not a Firefox problem? Really?

EDIT:

Let me explain further so that you can understand. In folder options / file types I can scroll thru and choose any file type / advanced and change the icon...every one of them except (now) .pdf. There is no advanced tab. Only the message about "restore" I mentioned before. Firefox changed the file association for .pdf files and now I can't fix it.

And from another thread:

"Firefox 31 is not converting or renaming your files. All it is doing is registering with the Windows OS as an application that is able to open the files and Windows then changes the file's icons accordingly.

This should only occur if no other application has already registered your .pdf files."

Well I guess that's not true is it?

Thank you for your reply but it's not that simple: Windows now thinks that the default file type for .pdf is Firfox HTML Document. I can change which program opens .pdf files but I can't change the icon. Not a Firefox problem? Really? EDIT: Let me explain further so that you can understand. In folder options / file types I can scroll thru and choose any file type / advanced and change the icon...every one of them except (now) .pdf. There is no advanced tab. Only the message about "restore" I mentioned before. Firefox changed the file association for .pdf files and now I can't fix it. And from another thread: "Firefox 31 is not converting or renaming your files. All it is doing is registering with the Windows OS as an application that is able to open the files and Windows then changes the file's icons accordingly. This should only occur if no other application has already registered your .pdf files." Well I guess that's not true is it?

由 2kidsdad 於 修改

2kidsdad 0 個解決方法 6 個答案

I figured it out: Use regedit to change this: HKEY_CLASSES_ROOT\.pdf Name: Default Type: Reg_SZ Data: FirefoxHtm

I figured it out: Use regedit to change this: HKEY_CLASSES_ROOT\.pdf Name: Default Type: Reg_SZ Data: FirefoxHtm
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

Hi 2kidsdad, thank you for identifying that value in the registry.

For users with Adobe Reader XI or Adobe Acrobat XI, I think you would want to change "(Default)" from

  FirefoxHTML

to

  AcroExch.Document.11

Was that what you did, or did something else work for you?

Hi 2kidsdad, thank you for identifying that value in the registry. For users with Adobe Reader XI or Adobe Acrobat XI, I think you would want to change "(Default)" from FirefoxHTML to AcroExch.Document.11 Was that what you did, or did something else work for you?
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案
See also: *http://mxr.mozilla.org/mozilla-central/source/browser/installer/windows/nsis/installer.nsi *http://mxr.mozilla.org/mozilla-central/source/browser/installer/windows/nsis/shared.nsh
gevv 0 個解決方法 1 個答案

FirefoxHTML to

AcroExch.Document

and restart pc

FirefoxHTML to AcroExch.Document and restart pc
2kidsdad 0 個解決方法 6 個答案

Changed registry entries to:

HKEY_CLASSES_ROOT\.pdf Name: Default Type: Reg_SZ Data: AcroRd32.exe

I'm not sure that's exactly correct but I got my icons back.

Changed registry entries to: HKEY_CLASSES_ROOT\.pdf Name: Default Type: Reg_SZ Data: AcroRd32.exe I'm not sure that's exactly correct but I got my icons back.

由 2kidsdad 於 修改

2kidsdad 0 個解決方法 6 個答案

I am still experiencing file type / open with problems.

For the record, I am running Windows XP SP3 and have had Firefox installed as the default browser within minutes of a fresh install probably 4 years ago and have never had an issue like this.

When I click on a pdf or jpeg file in Firefox it still shows open with / browse. All settings in Windows folder options / file types are correct. pdf files open with Adobe and jpeg files open with Windows Picture and Fax Viewer.

Firefox tools / applications reflect the same settings.

When I click on one of these file types with the settings I have what I should see is the choice to open with (shows the default program associated with that file type) or save. It doesn't show that any more. It is only open with / browse or save file. I have to "browse" every time I want to open the file.

This is not a Windows problem.

Something else is going on here. And please don't tell me to choose "do this automatically for files like this from now on". That is not what that box is for. That simply determines whether I am offered to open or save the next time automatically. I like the choice and want to keep it that way.

I am still experiencing file type / open with problems. For the record, I am running Windows XP SP3 and have had Firefox installed as the default browser within minutes of a fresh install probably 4 years ago and have never had an issue like this. When I click on a pdf or jpeg file in Firefox it still shows open with / browse. All settings in Windows folder options / file types are correct. pdf files open with Adobe and jpeg files open with Windows Picture and Fax Viewer. Firefox tools / applications reflect the same settings. When I click on one of these file types with the settings I have what I should see is the choice to open with (shows the default program associated with that file type) or save. It doesn't show that any more. It is only open with / browse or save file. I have to "browse" every time I want to open the file. This is not a Windows problem. Something else is going on here. And please don't tell me to choose "do this automatically for files like this from now on". That is not what that box is for. That simply determines whether I am offered to open or save the next time automatically. I like the choice and want to keep it that way.
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

Hi 2kidsdad, have you tried having Firefox rebuild its settings file that stores the program associations? These are the steps for that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again and it should read the associations stored in the Windows registry and restore the default behavior of the Open/Save/Cancel dialog. Any improvement?

Hi 2kidsdad, have you tried having Firefox rebuild its settings file that stores the program associations? These are the steps for that: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information In the first table on the page, click the "Show Folder" button Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * File menu > Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Start Firefox back up again and it should read the associations stored in the Windows registry and restore the default behavior of the Open/Save/Cancel dialog. Any improvement?
2kidsdad 0 個解決方法 6 個答案

Thank you for your reply. I followed the instructions. Renamed mimeTypes.rdf to mimeTypes.old with Firefox closed and rebooted. There is a new mimeTypes.rdf file in that folder now (as I'm sure you know) but nothing changed.

Thank you for your reply. I followed the instructions. Renamed mimeTypes.rdf to mimeTypes.old with Firefox closed and rebooted. There is a new mimeTypes.rdf file in that folder now (as I'm sure you know) but nothing changed.
cor-el
  • Top 10 Contributor
  • Moderator
17539 個解決方法 158588 個答案
Try: *[[/questions/1014919#answer-618531]]
Pharteon 1 個解決方法 4 個答案

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler...

Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader).

The other options described above and in other threads did not fix the problem for me.

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler... Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader). The other options described above and in other threads did not fix the problem for me.
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

Pharteon, Thanks for posting your solution for Adobe Reader. I've edited the chosen solution for this question (posted by cor-el on Aug 2, 2014) with a link to your answer, a similar answer in another thread, and a related bug report.

Since this question has been marked as solved by the original poster Morgan1, I'll close the thread.

Pharteon, Thanks for posting your solution for Adobe Reader. I've edited the [/questions/1013642#answer-611219 chosen solution] for this question (posted by cor-el on Aug 2, 2014) with a link to your answer, a similar answer in another thread, and a related bug report. Since this question has been marked as solved by the original poster Morgan1, I'll close the thread.