Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox will not open saved desktop bookmarks, it always defaults to home page, why is that?

  • 7 个回答
  • 7 人有此问题
  • 12 次查看
  • 最后回复者为 BetaTester

more options

I like to launch Firefox by clicking on desktop shortcuts I have saved (bank, Netflix, Gmail, Amazon, Yahoo, eBay, etc...). With Firefox 29 any desktop shortcut now opens to my home page, Google. If I choose open to a blank page in the options, then all of my shortcuts open to a blank page.

In Firefox 28 all of desktop shortcuts worked just fine. I like being able to start Firefox on a specific page. Now it looks like I can only open to my home page or a blank page. This is terrible!!! I have tried creating new desktop shortcuts from Firefox 29 and I get this same results. Really terrible.

I can deal with the interface (which I really do not like now) but this simple lose of how I like to start Firefox is going to drive me away. Please fix or explain to me how I can launch Firefox from a shortcut and have it open that web page. Many thanks!

I like to launch Firefox by clicking on desktop shortcuts I have saved (bank, Netflix, Gmail, Amazon, Yahoo, eBay, etc...). With Firefox 29 any desktop shortcut now opens to my home page, Google. If I choose open to a blank page in the options, then all of my shortcuts open to a blank page. In Firefox 28 all of desktop shortcuts worked just fine. I like being able to start Firefox on a specific page. Now it looks like I can only open to my home page or a blank page. This is terrible!!! I have tried creating new desktop shortcuts from Firefox 29 and I get this same results. Really terrible. I can deal with the interface (which I really do not like now) but this simple lose of how I like to start Firefox is going to drive me away. Please fix or explain to me how I can launch Firefox from a shortcut and have it open that web page. Many thanks!

被采纳的解决方案

Forgot to add;

Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.<

定位到答案原位置 👍 0

所有回复 (7)

more options

Go to your desktop. Pick one of the problem shortcuts and right click it. Select Properties. On the top bar select Web Document and check what is in the URL box. If everything looks okay, Manually go to one of the web pages. Create a new shortcut to the desktop. Then test it.

more options

Sorry didn't work. I am using MacOS 10.6. New shortcuts created in FF29 have the same problem. If FF29 is not open, clicking on the shortcut opens FF to my default home page, never to the shortcut URL I clicked. For example, clicking an Amazon.com shortcut I just dragged to the desktop, then quitting FF29 and clicking the shortcut launches FF29 to my Google home page. If I change my default browser to Safari all of my desktop shortcuts open Safari to the right page. Chrome had the same problem but I couldn't stand Chrome so I don't care. This is definitely a FF29 problem.

I am really attached to FF in general and this is not a deal breaker, just a huge annoyance. Again, thanks for any help.

more options

Try this, manually go to a web page. Create a shortcut on the desktop. Blank the browser. Double click the new shortcut. Does it work? If it does, close Firefox, and click the shortcut again.

more options

Followed your instructions exactly. If I create a shortcut by dragging from the ULR bar to the desktop, then close all open FF29 windows but leave the program running, then click the bookmark (Amazon.com this time) the web page opens correctly.

Then I quit FF29 and double click the same shortcut FF29 opens to my default home page, Google. I use a Windows machine at work and I am not having this problem with desktop shortcuts.

Many thanks again!

more options

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, Go into the list of programs that are on your computer. Go thru the list and use a web search to check any that you don't know what they are.

more options

选择的解决方案

Forgot to add;

Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration.<

more options

Problem solved. I am not sure what worked but FF29 now opens desktop shortcuts to the correct web page. Thanks for sticking with me!

I did a virus scan and found no problems. I started in safe mode and turned off hardware acceleration. Then I turned off all of my add-ons. That's when it started opening the shortcuts correctly.

So I added my add-ons back 1 by 1 till I had what I needed and FF29 is still opening shortcuts to the correct web page. Many thanks again!

由BetaTester于修改