Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Why won't Firefox 17 give me search results with Google by pressing enter instead of refreshing?

  • 5 个回答
  • 41 人有此问题
  • 5 次查看
  • 最后回复者为 sebecky

more options

I used to be able to search from Google by typing the words in the search box and pressing enter to bring up the results. Since I updated to Firefox 17, I type the words in the box and press enter and nothing happens. Even when I click the blue search box, nothing happens. I have to refresh the entire page to see the results. Until this happened, I was glad I didn't have to use Internet Explorer anymore. Now I'm probably going to go back to it. By the way, I use the https secure setting. Thanks

I used to be able to search from Google by typing the words in the search box and pressing enter to bring up the results. Since I updated to Firefox 17, I type the words in the box and press enter and nothing happens. Even when I click the blue search box, nothing happens. I have to refresh the entire page to see the results. Until this happened, I was glad I didn't have to use Internet Explorer anymore. Now I'm probably going to go back to it. By the way, I use the https secure setting. Thanks

所有回复 (5)

more options

Hi,

Please try a Ctrl + F5 refresh. You may also have to Clear Now the Cache and Cookies with Time range to clear set to Everything via Tools (Alt + T) > Clear Recent History.

If you have security software (antivirus, firewall etc.) installed, you can try deleting all existing instances of Firefox and its related processes/files in all the different configuration modules/areas of the security software like process monitoring, sub/spawned process control, virtualization, HIPS etc., in addition to the security software's main configuration panel. Instead create new fully allowed/trusted rules for Firefox + its related processes in all the different modules/panels - a genuine/original Firefox installer as well as all the installed EXEs (Application) and DLLs (Application extension) are digitally signed by Mozilla Corporation (right-click > Properties > Digital Signatures). Even otherwise, some security software may also ask again when Firefox and/or its sub processes are started, and you may be able to allow/trust at that time. Please see this.

AV/Firewalls Configuration

If the problem persists, you can reset Firefox and start afresh.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

If you would like to save a listing of the add-ons, important modified preferences/settings etc. to quickly replicate the previous profile, please Copy all to clipboard (on the left of the reset button), and paste it into Office Excel, or OpenOffice/LibreOffice Calc, or notepad. However, it would be a good idea to check for the existence of the issue immediately after the reset.

more options

Thank you for your response. I tried the ctrl + F5 refresh and it did not fix the problem. I don't have the option to Clear Recent History/Clear Now the cache, possibly because of my browser settings: tell websites I do not want to be tracked, I don't accept third party cookies, always use private browsing mode, and I use CCleaner every time I close my browser. My Windows firewall is set to allow an exception for Firefox. Avast is my antivirus program, and I don't understand how to delete the existing instances of Firefox in the configuration modules like you suggested, or the part about the digital signatures. I haven't tried resetting Firefox because I wanted to give you the above information first. I will await your reply.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
more options

@dumdidadida-- wow, I just found the problem. I went into tools>options>privacy>accept cookies from sites>exceptions, and for some strange reason, google.com was listed there. I don't remember blocking cookies from Google, but anyway, the problem is solved. I hope it's that simple for the other people having the same issue. Thanks again.

more options

Thank you cor-el for your reply. Yes, I had already tried running Firefox in safe mode. As you can see from my previous post, the fix was embarrassingly simple. :-)