搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Context menus and drop down lists stay open

  • 6 个回答
  • 1 人有此问题
  • 133 次查看
  • 最后回复者为 Joergen

more options

If I right click on a webpage the context menu opens. If I then click outside the context menu it doesn't close, but stays open. If I move focus to the search bar (not the address bar), starts typing and select an item from the drop down list, the drop down list stay open. If I start typing in the address bar and select an item from the drop down lost, the drop down list stay open. If I click the Bookmark menu icon on the toolbar the drop down list with bookmarks open, but if I click outside the list, it doesn't close but stay open. The same thing happens with the program menu in Firefox. Even when I start a different program, the menus and drop down lists from Firefox stays open on top of the other program. The problem also happens when I run Firefox in Troubleshoot Mode.

Any ideas?

If I right click on a webpage the context menu opens. If I then click outside the context menu it doesn't close, but stays open. If I move focus to the search bar (not the address bar), starts typing and select an item from the drop down list, the drop down list stay open. If I start typing in the address bar and select an item from the drop down lost, the drop down list stay open. If I click the Bookmark menu icon on the toolbar the drop down list with bookmarks open, but if I click outside the list, it doesn't close but stay open. The same thing happens with the program menu in Firefox. Even when I start a different program, the menus and drop down lists from Firefox stays open on top of the other program. The problem also happens when I run Firefox in Troubleshoot Mode. Any ideas?

被采纳的解决方案

If you go to about:config, what's the value of "ui.popup.disable_autohide"?

Does this happen in a clean profile?

在上下文中阅读这个答案 👍 1

所有回复 (6)

more options

选择的解决方案

If you go to about:config, what's the value of "ui.popup.disable_autohide"?

Does this happen in a clean profile?

more options

Hi TyDraniu

I changed the pref "ui.popup.disable_autohide" from true to false. That solved the problem. Thank you!

more options

Now I know how this pref was changed: I was debugging the GUI in Firefox and selected "Disable Popup Auto-Hide" in the Developer Tools. I forgot to change the pref back

more options

I did the same mistake few years ago ;).

more options

That also happens to me occasionally. Most of the time it works properly if I close the Browser Toolbox with "Disable Popup Auto-Hide" still selected and sometimes not, might be related to not closing the toolbox before closing Firefox and then closing the prompt to allow the connection on the next start instead of closing the toolbox properly.

more options

Hi cor-el

I have been debugging the GUI before, but I never had this problem before. So I didn't associate "Disable Popup Auto-Hide" with my problem. I can't remember how I exited the debug mode last time. I think I found an old bug regarding this behavior: "Disable popup auto hide" state if the Browser Toolbox closes as a result of Firefox being closed https://bugzilla.mozilla.org/show_bug.cgi?id=1415016

由Joergen于修改