搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Opens two windows on every boot.

  • 8 个回答
  • 1 人有此问题
  • 93 次查看
  • 最后回复者为 idiocracy

more options

On every boot ff69 opens two windows, one empty and one with opened tabs, every time i manually close the empty window. Next boot it reopens it. Same with laptop. On occasion if i close the window on laptop it'll only open main window on desktop on next boot. But this might only happen once and next boot the second window starts opening again for no reason. How do i make ff stop opening two windows on boot?

On every boot ff69 opens two windows, one empty and one with opened tabs, every time i manually close the empty window. Next boot it reopens it. Same with laptop. On occasion if i close the window on laptop it'll only open main window on desktop on next boot. But this might only happen once and next boot the second window starts opening again for no reason. How do i make ff stop opening two windows on boot?

被采纳的解决方案

I have figured out the problem and a solution. The problem appears to be ff starting too fast, by using scheduler and delaying the task by 30 secs, it has solved the problem on both machines.

定位到答案原位置 👍 0

所有回复 (8)

more options

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.


You can check for problems with the sessionstore.jsonlz4 file in the Firefox profile folder that stores session data.

  • delete sessionstore.jsonlz4 and sessionstore.js

When sessionstore.jsonlz4 is deleted you lose pinned tabs and open tabs and you will have to recreate them, so if necessary make a note or bookmark them.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

FredMcD said

What is the value?

about:home

cor-el said

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure nothing is appended after the path to the Firefox program.

Nothing is appended. Also, remember this happens on two separate machines, where desktop is primary and used everyday, laptop is not.

more options

Is there a reason you use Beta instead of Public release to use? Beta is consider for testing and evaluation purpose and shouldn't be use for everyday browsing.

more options

WestEnd said

Is there a reason you use Beta instead of Public release to use? Beta is consider for testing and evaluation purpose and shouldn't be use for everyday browsing.

Trying to fix the problem, stable or beta. Same thing.

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Just an update, restored my laptop because of a different matter. After installing ff it immediately started doing it, so even if it's a fresh install.

more options

选择的解决方案

I have figured out the problem and a solution. The problem appears to be ff starting too fast, by using scheduler and delaying the task by 30 secs, it has solved the problem on both machines.