搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

what is the correction for "https://support.mozilla.org/en-US/questions/1163380" ?

  • 8 个回答
  • 6 人有此问题
  • 5 次查看
  • 最后回复者为 trouen

more options

Quoted from questions - 1163380. The post says there is an answer but none is provided

"When I open a file whose character encoding is UTF-8 in Firefox via a file:// URL, it displays all the non-ASCII characters incorrectly. In the View->Chacter Encoding sub-menu, I see the check mark near "Western". When I choose "Unicode" manually from the View->Character Encoding menu, the file displays correctly. But when I then hit <f5> to reload the page, Firefox sets character encoding to "Western" again, the display is garbled again, and to display the file correctly I have to set the right character encoding manually once more.

Since I need that functionality frequently, this is a real nuisance which debases the user experience a lot for me.

Similar questions have been asked on the Internet, but no one seems to have got a satisfactory answer. "

Quoted from questions - 1163380. The post says there is an answer but none is provided "When I open a file whose character encoding is UTF-8 in Firefox via a file:// URL, it displays all the non-ASCII characters incorrectly. In the View->Chacter Encoding sub-menu, I see the check mark near "Western". When I choose "Unicode" manually from the View->Character Encoding menu, the file displays correctly. But when I then hit <f5> to reload the page, Firefox sets character encoding to "Western" again, the display is garbled again, and to display the file correctly I have to set the right character encoding manually once more. Since I need that functionality frequently, this is a real nuisance which debases the user experience a lot for me. Similar questions have been asked on the Internet, but no one seems to have got a satisfactory answer. "

所有回复 (8)

more options

You can consider to add a UTF-8 BOM (byte order mark) at the start of the file. A lot of text editors have a setting to add such a mark automatically.

more options

The answer I was looking for is how to change the default text encoding from 'western' to 'unicode' and in the Firefox browser?

more options

This applies to TB & my version is 52.3.0 but maybe FF has a similar setting. Having set both incoming and outgoing text to Unicode, and then selecting View/Text Encoding/Unicode--the setting would revert back to Western every time I left the message where I set it.

right click Inbox and select Properties and change the Fallback Text Encoding from Western to Unicode.

It worked for me--hopefully it will for you, Ron

more options

Hi Ron;

I am using Juno webmail and am unable to find properties for the Inbox regardless of which area I select the word INBOX. This is using juno webmail with Firefox 56.0.1. The firefox option is to default to locale encoding or has different language options.

Thanks

more options

I am not experienced with changing the Text Encoding in FF, My reply clearly stated it was for TB--in case someone who had the problem I did happens to see this one. There are no OPTIONS easily available to change to Unicode--see next.

You could try typing about:config into the url box. Be very careful and heed the warnings--if you screw up you could disable FF. I'd do a search for Western and Unicode, Encoding.

If you haven't, experiment with changing to some of the European texts and see if that fixes it. It did not for me with TB--but that's a different animal.

I hope you have posted this in the Firefox Support forum. If you don't have this problem viewing regular web pages--perhaps it is a setting in Juno WebMail???

Does Google Chrome have this problem with Juno WebMail? If so, perhaps there may be a system (OS) setting which may need changing.

hth, Ron

more options

Hi trouen, sorry for the confusion.

On Windows, the classic menu bar defaults to hidden, so you do not have immediate access to the View menu. If you tap the Alt key to activate the menu bar temporarily, then View > Text Encoding you'll see the available options there. Check to make sure "auto detect" is off.

However, about changing the default, I don't have a solution.

For pages that do not declare a particular encoding, Firefox will use windows-1252 as the default fallback encoding. The Options page does not list Unicode as an option. You can confirm that if you haven't seen this list before. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Firefox 4-55: In the left column, click Content. Then on the right side, find and click the "Advanced" button.

Firefox 56-58: In the search box at the top of the page on the right side, type enco and Firefox should filter to the "Advanced" button, which you can click.

In All Versions: In the "Text Encoding for Legacy Content" section, you usually will find:

Fallback Text Encoding: Default for current Locale

You can change that to a specific language, but there's no way to change it to Unicode (not for a long time).

I thought some people might have changed the preference value to UTF-8 and had success with that, but it isn't working for me. If you want to try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste fallb and pause while the list is filtered

(3) Double-click the intl.charset.fallback.override preference and enter UTF-8 and click OK (note: lower case utf-8 also did not work for me)

more options

I think that utf-8 is explicitly excluded as a fallback value.


Bug 1034960 - Restore menu option to fallback to UTF-8 (or other) encoding in case it is not specified in the content Bug 967981 - Provide some way for addons/prefs to control the default fallback character set

由cor-el于修改

more options

cor-el and jscher2000;

Thank you for your inputs but I haven't seen any changes in FF. I try not to use Chrome because of the advertisement pop-ups within Juno using Chrome. The initial response received from Juno support was to stop using FF and go to Chrome. What I am doing now is every time I login to Juno web-mail using FF I do as jscher2000 mentioned, which is to change the encoding under View before starting to process my email.

Again thanks to everyone for their help.