Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

@font-face Thai fonts with Mozilla Firefox in normal mode can't rendered correctly, how to fix this?

  • 2 àwọn èsì
  • 5 ní àwọn ìṣòro yìí
  • 26 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ kreaninw

more options

@font-face Thai fonts with Mozilla Firefox in normal mode can't rendered correctly, how to fix this?

It's a problem with text rendering, a tone mark stay above the place it should be.

In normal mode even with all my add-ons disabled, the problem still remains.

Note that, it rendered correctly only in safe mode.

Among all five major web browsers, the problem only happens with Firefox! This is a critical issue for Thai language when the web developers use @font-face in their website.

'''@font-face Thai fonts with Mozilla Firefox in normal mode can't rendered correctly, how to fix this?''' '''It's a problem with text rendering, a tone mark stay above the place it should be.''' '''In normal mode even with all my add-ons disabled, the problem still remains.''' '''Note that, it rendered correctly only in safe mode.''' Among all five major web browsers, the problem only happens with Firefox! This is a critical issue for Thai language when the web developers use @font-face in their website.

Ti ṣàtúnṣe nípa kreaninw

All Replies (2)

more options

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Try to toggle some Boolean gfx.font_rendering prefs on the about:config page to disable some features.
Filter: gfx

Some to try:

  • set gfx.direct2d.disabled to true to disable Direct2D
  • set gfx.font_rendering.directwrite.use_gdi_table_loading to false
more options

This solution doesn't help at all. T-T

I think it's a bug.