Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Setting up Gmail or Yahoo mail, selected with OAuth2, but cannot see the authentication window pop up.

  • 10 àwọn èsì
  • 0 ní àwọn ìṣòro yìí
  • 4 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ Kin Zhang

more options

I am struggling with Gmail and Yahoo mail account in TB these few days. I hit almost the same errors from both. I generated app password for Yahoo mail, and put it in when setting up new account. For connection security: SSL/TLS For authentication method: tried with Normal password, Encrypted password, and OAuth2 However, I am seeing the expected authentication window pop up when trying the OAuth2. For all three authentication method: errors are always the same --- unable to connect to your IMAP server. I've followed another instruction to change maximum number of server connections to cache into 1 or 10. Error messages were the same imap one. So, what should I do/try for next?

I am struggling with Gmail and Yahoo mail account in TB these few days. I hit almost the same errors from both. I generated app password for Yahoo mail, and put it in when setting up new account. For connection security: SSL/TLS For authentication method: tried with Normal password, Encrypted password, and OAuth2 However, I am seeing the expected authentication window pop up when trying the OAuth2. For all three authentication method: errors are always the same --- unable to connect to your IMAP server. I've followed another instruction to change maximum number of server connections to cache into 1 or 10. Error messages were the same imap one. So, what should I do/try for next?

Ọ̀nà àbáyọ tí a yàn

Toad-Hall said

Do you have a VPN switched on? If yes, then switch it off because servers may not accept from what they think is someone trying to hack the account.

OK, the proxy is where the actual problem is. Once I switched off the proxy, the OAuth webpage pops up. However, without the proxy on I just cannot load the page, just with a pop up window. So, I believe the cause is identified: proxy problem. As for the situation is far beyond what I can reach. I have to give up the combination of Thunderbird + Yahoo or Gmail.

Do you have any program using the localhost such as Apache ? If yes, then close those programs until the account has have been created.

No, nothing like Apache or server hosted from my computer.

Thank you Toad, I would mark the problem as solved as the reason has been found.

Ka ìdáhùn ni ìṣètò kíkà 👍 0

All Replies (10)

more options

For both, Yahoo, and Gmail accounts OAuth2 is the preferred authentication method. Are you trying to set up the accounts in Thunderbird? Use the automatic account configuration. The wizard will pick the correct settings. https://support.mozilla.org/kb/automatic-account-configuration

Also make sure to allow cookies in Thunderbird. https://support.mozilla.org/kb/automatic-conversion-google-mail-accounts-oauth20

For all three authentication method: errors are always the same --- unable to connect to your IMAP server.

If there is a general connectivity problem with your Internet access, you'll have to fix this first.

Helpful?

more options

Hi Christ,

Thanks for the response first.

I have enabled in setting to accept all cookies, and yes. And the javascript.enabled is true for all the moments, as the screenshot 1 shows.

Regards to the interest access, I assume it is good because other accounts in Thunderbird are sending and receiving emails as expected, as the screenshot 2 shows.

I follow the automatic account config with Account password, App Password, and leaving blank. However, it is not going through, and the error message is: unable to log in at server. as screenshot 3 & 4 show.

Basically, I expect a webpage pop up from thunderbird when putting in email address and the account password, which is the behavior for other email client. And I am using Microsoft Edge as default browser in Windows, but I don't expect that would be the problem.

So, I am a bit confused by the current situation.

Helpful?

more options

christ1 said

For both, Yahoo, and Gmail accounts OAuth2 is the preferred authentication method. Are you trying to set up the accounts in Thunderbird? Use the automatic account configuration. The wizard will pick the correct settings. https://support.mozilla.org/kb/automatic-account-configuration Also make sure to allow cookies in Thunderbird. https://support.mozilla.org/kb/automatic-conversion-google-mail-accounts-oauth20
For all three authentication method: errors are always the same --- unable to connect to your IMAP server.

If there is a general connectivity problem with your Internet access, you'll have to fix this first.

Hi Christ,

Thanks for the response first.

I have enabled in setting to accept all cookies, and yes. And the javascript.enabled is true for all the moments, as the screenshot 1 shows.

Regards to the interest access, I assume it is good because other accounts in Thunderbird are sending and receiving emails as expected, as the screenshot 2 shows.

I follow the automatic account config with Account password, App Password, and leaving blank. However, it is not going through, and the error message is: unable to log in at server. as screenshot 3 & 4 show.

Basically, I expect a webpage pop up from thunderbird when putting in email address and the account password, which is the behavior for other email client. And I am using Microsoft Edge as default browser in Windows, but I don't expect that would be the problem.

So, I am a bit confused by the current situation.

Helpful?

more options
I have enabled in setting to accept all cookies.

Good. You don't need to allow 3rd-party cookies though.

Regards to the interest access, I assume it is good because other accounts in Thunderbird are sending and receiving emails as expected

That sounds reasonable.

I follow the automatic account config with Account password, App Password, and leaving blank.

With OAuth authentication you cannot use an app password. Use your account password.

I am using Microsoft Edge as default browser in Windows, but I don't expect that would be the problem.

Correct, it's irrelevant which browser you're using.

What is your anti-virus software?

Helpful?

more options

christ1 said

What is your anti-virus software?

So I use the default Windows Security with the default set up. About the firewall, I use the system built-in one, moreover, I've added Thunderbird manually to allow it for both private and public networks.

I have the troubleshoot information here, not sure if that would be helpful.

Helpful?

more options

You mentioned you had 'generated an app specific password' "I generated app password for Yahoo mail, and put it in when setting up new account."

The problem is this - you switched on 2 step authentication so yahoo expect an app specific password, but by default Thunderbird will look up settings for Imap using Oauth2, so app specific password is no good. It will fail.

Using 'Authentication Method: OAuth2' for incoming server and smtp outgoing server You cannot use an app generated password - so you need to make sure 2 step authentication is switched off, which you do via the yhaoo webmail account. This mean Yahoo will stop expecting the app specific password.

Using 'Authentication Method: Normal Password' for incoming server and smtp outgoing server You must switch on 2 step verification and generate app specific password which you use instead of Normal Password when you first start to create the account.

However, make sure you do not have any stored passwords for those accounts before trying to create account. Settings > Privacy & Security > SAved Passwords

Helpful?

more options

Toad-Hall said

You mentioned you had 'generated an app specific password' "I generated app password for Yahoo mail, and put it in when setting up new account." The problem is this - you switched on 2 step authentication so yahoo expect an app specific password, but by default Thunderbird will look up settings for Imap using Oauth2, so app specific password is no good. It will fail. Using 'Authentication Method: OAuth2' for incoming server and smtp outgoing server You cannot use an app generated password - so you need to make sure 2 step authentication is switched off, which you do via the yhaoo webmail account. This mean Yahoo will stop expecting the app specific password. Using 'Authentication Method: Normal Password' for incoming server and smtp outgoing server You must switch on 2 step verification and generate app specific password which you use instead of Normal Password when you first start to create the account. However, make sure you do not have any stored passwords for those accounts before trying to create account. Settings > Privacy & Security > SAved Passwords

Hi Toad, thanks for the advise, and I tried both, and confirm no related password saved for any Yahoo accounts.

At first I try was: 2FA on, App password and Normal Password in Authentication Method then I tried: 2FA off, Account password and OAtuth2 in Authentication Method

but still hit the same error message: Unable to log in at server. Probably wrong configuration, username or password.

At the same time, I am posting the screenshot for developer tool, perhaps some DNS error?

Helpful?

more options

When leaving the developer tool on for one or two hours, notice more errors.

They are similar entries like: 1713930673452 Toolkit.Telemetry ERROR TelemetrySend::sendPersistedPings - failed to send ping 021f2bb5-f523-468b-acc8-b4590ba42181: {"isTrusted":true} Log.sys.mjs:722 1713930673457 Toolkit.Telemetry ERROR TelemetrySend::_doPing - error making request to https://incoming-telemetry.thunderbird.net/submit/telemetry/fa09cab2-1468-42ea-8904-8a1b4a2c476c/event/Thunderbird/115.10.1/release/20240417192958?v=4: eUnreachable Log.sys.mjs:722 1713930673457 Toolkit.Telemetry ERROR TelemetrySend::sendPersistedPings - failed to send ping fa09cab2-1468-42ea-8904-8a1b4a2c476c: {"isTrusted":true} Log.sys.mjs:722 1713930673464 Toolkit.Telemetry ERROR TelemetrySend::_doPing - error making request to https://incoming-telemetry.thunderbird.net/submit/telemetry/465bfe70-0016-43ce-b411-eadce72f5f1f/health/Thunderbird/115.10.1/release/20240417192958?v=4: eUnreachable Log.sys.mjs:722 1713930673464 Toolkit.Telemetry ERROR TelemetrySend::sendPersistedPings - failed to send ping 465bfe70-0016-43ce-b411-eadce72f5f1f: {"isTrusted":true} Log.sys.mjs:722 1713930673469 Toolkit.Telemetry ERROR TelemetrySend::_doPing - error making request to https://incoming-telemetry.thunderbird.net/submit/telemetry/e8df1d8e-7878-4c90-a12d-422a53726615/health/Thunderbird/115.10.1/release/20240417192958?v=4: eUnreachable Log.sys.mjs:722 1713930673469 Toolkit.Telemetry ERROR TelemetrySend::sendPersistedPings - failed to send ping e8df1d8e-7878-4c90-a12d-422a53726615: {"isTrusted":true} Log.sys.mjs:722

Not sure if these are helpful information.

Helpful?

more options

Do you have a VPN switched on? If yes, then switch it off because servers may not accept from what they think is someone trying to hack the account.

Do you have any program using the localhost such as Apache ? If yes, then close those programs until the account has have been created.

Helpful?

more options

Ọ̀nà àbáyọ Tí a Yàn

Toad-Hall said

Do you have a VPN switched on? If yes, then switch it off because servers may not accept from what they think is someone trying to hack the account.

OK, the proxy is where the actual problem is. Once I switched off the proxy, the OAuth webpage pops up. However, without the proxy on I just cannot load the page, just with a pop up window. So, I believe the cause is identified: proxy problem. As for the situation is far beyond what I can reach. I have to give up the combination of Thunderbird + Yahoo or Gmail.

Do you have any program using the localhost such as Apache ? If yes, then close those programs until the account has have been created.

No, nothing like Apache or server hosted from my computer.

Thank you Toad, I would mark the problem as solved as the reason has been found.

Helpful?

Béèrè ìbéèrè

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.