Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Impossible to stop Thunderbird compacting folders it hasn't seen before?

  • 5 àwọn èsì
  • 0 ní àwọn ìṣòro yìí
  • 7 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ psollich

more options

Hi,

About a month ago I accidentally activated the "Delete all but the most recent 2000 messages" option for one of my mail account in Thunderbird (15.10.1 (64-bit) on a MacBook Air). Luckily our local support were able to restore the affected folders. BUT - every time I opened the restored folders in Thunderbird, all the restored messages would disappear again. Correspondingly, the support team can see at this time large numbers of messages being deleted.

I've tried to delete the affected mail account from Thunderbird - didn't help. I've hidden my profile and started Thunderbird from scratch, set up the mail account again (so there should have been no leftover information from any previous instance of the account) - didn't help. I can see that whenever I open a folder for the first time, Thunderbird says "Compacting" - this is even though I have "Always ask before compacting" set. Even after I turn off automatic compacting for space saving >20MB, Thunderbird still compacts when it first sees a folder.

I have verified this behaviour by connecting to the same mail server using alpine - I see messages flagged for deletion in the restored folder; as soon as Thunderbird touches the folder, they disappear (even though no compacting should be happening and I should be prompted before it does, see above). Conversely, if I remove the "to delete" mark from the messages using alpine and then open a folder in Thunderbird, the messages are visible there.

From my understanding of what Thunderbird should be doing when compacting (or rather when not compacting), I would say the behaviours I've seen are rather significant bugs. But if I've misunderstood and there is some other way to stop Thunderbird from purging messages marked for deletion, I would be grateful for any advice.

Many thanks in advance for your help.

Hi, About a month ago I accidentally activated the "Delete all but the most recent 2000 messages" option for one of my mail account in Thunderbird (15.10.1 (64-bit) on a MacBook Air). Luckily our local support were able to restore the affected folders. BUT - every time I opened the restored folders in Thunderbird, all the restored messages would disappear again. Correspondingly, the support team can see at this time large numbers of messages being deleted. I've tried to delete the affected mail account from Thunderbird - didn't help. I've hidden my profile and started Thunderbird from scratch, set up the mail account again (so there should have been no leftover information from any previous instance of the account) - didn't help. I can see that whenever I open a folder for the first time, Thunderbird says "Compacting" - this is even though I have "Always ask before compacting" set. Even after I turn off automatic compacting for space saving >20MB, Thunderbird still compacts when it first sees a folder. I have verified this behaviour by connecting to the same mail server using alpine - I see messages flagged for deletion in the restored folder; as soon as Thunderbird touches the folder, they disappear (even though no compacting should be happening and I should be prompted before it does, see above). Conversely, if I remove the "to delete" mark from the messages using alpine and then open a folder in Thunderbird, the messages are visible there. From my understanding of what Thunderbird should be doing when compacting (or rather when not compacting), I would say the behaviours I've seen are rather significant bugs. But if I've misunderstood and there is some other way to stop Thunderbird from purging messages marked for deletion, I would be grateful for any advice. Many thanks in advance for your help.

All Replies (5)

more options

1. I would uncheck the automatic compact.

2. If you have imap accounts, I would create a new profile to start fresh. https://support.mozilla.org/en-US/kb/using-multiple-profiles

Please give us an update.

Helpful?

more options

Hi,

Many thanks for taking the time to reply.

I've already done both of the things you recommend (see original question) - I moved my original profile so that TB could no longer find it, and then set up to affected mail account from scratch; in my most recent experiments I've also turned off automatic compacting. Neither has made a difference, so if there is a solution it must be something else.

Thanks again, Peter

Helpful?

more options

PS: And yes, I connect to this mail server via IMAP.

Helpful?

more options

Perhaps the following is your issue. Worth checking it out.

Are the 'deleted' emails actually on the server - which you can access via webmail account in a browser ? If no then that explains why you cannot see them in an imap mail account. Imap account can only show what is on server.

re :Luckily our local support were able to restore the affected folders.

If they 'restored' the effected folders (mbox files) within the imap account in profile, then when you start Thunderbird, it checks with server and will auto remove emails that were 'restored' because they were not restored to server.

Suggest you get the 'restored' mbox files put into the 'Local Folders' folder in profile whilst Thunderbird is not running. Then start Thunderbird and you should see emails in 'Local Folders' mail account. You can then 'Copy' batches of emails into the imap folders to get them uploaded back onto the server. There may be a limit on how much you can upload within a given period.

Helpful?

more options

Hi,

Many thanks for taking the time to reply.

Yes, the deleted messages are on the server - I can see them via webmail or alpine. And yes, the support team restored the messages on the server, not somewhere in my Thunderbird file space.

I've now managed to retrieve the messages after a whole lot of bulk "undeleting" using alpine. So the immediate issue is solved, but I think it is a serious bug that Thunderbird will get rid of restored messages on the server that are marked "delete", even when automatic compacting is turned off.

Thanks again and best wishes, Peter

Helpful?

Béèrè ìbéèrè

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.