Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to fix nss3.dll Entry point not found error?

  • 4 tontu
  • 22 am na jafe-jafe bii
  • 6 views
  • i mujjee tontu mooy jwb6658

more options

When I start firefox I receive the following error window:

'The procedure entry point PK11_PubDerive could not be located in the dynamic link library nss3.dll.'

All Replies (4)

more options

Hello,

Uninstall Firefox from the Windows Control Panel > Programs and Features, and delete the Firefox folder from your Program Files as well:

  • C:\Program Files (x86)\Mozilla Firefox ; or
  • C:\Program Files\Mozilla Firefox

Reinstalling Firefox after downloading a fresh copy from the official Mozilla servers:

CoryMH moo ko soppali ci

more options

I've tried uninstalling completely and deleting all folders inside Program Files using the automatic installer as well as the offline installer. I tried using the XULRunner nss3.dll but it does not include all necessary functions to run Firefox.

The clean reinstall persists the issue which makes me think there may be an issue with the final nss3.dll binary.

more options
more options

Well...I see inside pk11pub.h that the prototype exists for PK11_PubDerive(). The function is written in pk11skey.c.

Now is it compiled and working properly in the final binary?? I'm no developer so I can't verify this.. any help would be appreciated.