Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon search option on Home screen prevents me from just navigating to the site

  • 3 ప్రత్యుత్తరాలు
  • 1 ఈ సమస్య కలిగినది
  • 3 వీక్షణలు
  • చివరి సమాధానమిచ్చినది RASHII

more options

I'm slightly baffled that I seem to be the only person that has a problem with this. Amazon appears in my top sites with a search icon. If I click on any other Top Site, it takes me to the site. This is what I want to happen when I click on Amazon. Instead, it prompts me to search Amazon via the address bar, and there appears to be no way around this.

I want to be able to navigate to Amazon in one click like I can with any other top site. Why can't I?

I'm slightly baffled that I seem to be the only person that has a problem with this. Amazon appears in my top sites with a search icon. If I click on any other Top Site, it takes me to the site. This is what I want to happen when I click on Amazon. Instead, it prompts me to search Amazon via the address bar, and there appears to be no way around this. I want to be able to navigate to Amazon in one click like I can with any other top site. Why can't I?

న user1931531 చే మార్చబడినది

ప్రత్యుత్తరాలన్నీ (3)

more options

Hi Bort, that icon is a search shortcut. Not useful? You can remove it and create one for https://www.amazon.com/ instead.

To remove an icon, hover the tile, then click the tile's ••• menu button, then either:

  • Unpin, if you want it to float somewhere in the collection, or
  • Dismiss, to hide it

To add a site, hover the "Top Sites" title and use the ••• menu at the far right to add a new site.

Success?

more options

Hello,

I can't unpin a search shortcut, only dismiss it. Yes, I can create my own top site entry, which pins it automatically and removes the search shortcut, but that seems like a very roundabout way of giving me the option to just not use search shortcuts.

Thanks anyway.

more options

Check your add-on or cookies section