Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot use twitter all of a sudden using Firefox 17

  • 32 பதிலளிப்புகள்
  • 13 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Daronn22

Ordinarily I can use twitter no problem with Firefox. But now all of a sudden it logs me in, and takes me to pages but will not allow me to post tweets, reply to others, or retweet or log out or send direct messages. So basically I cannot do anything unless I use internet explorer, where it seems to work. I don't want to use IE or I wouldn't have Firefox! It is not my twitter account because the same thing happens on other accounts logged in on this pc. I have tried downloading a new version of firefox, removing all twitter cookies and everything else. My account and firefox work on the "Tweetdeck" site but not the actual twitter site. Is there anything I can do because you cannot email twitter (well, I don't have an email address that works for them!! )

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Thanks. It seems the add on that is causing MY problem is the AVG search toolbar. So I have disabled that. AVG always seems to cause a problem for me!!!

Read this answer in context 👍 3

All Replies (20)

Hi Andromedakraken,

This might be due to updated code on causing Firefox to fail due to obsolete cache. Follow these instructions and see if that solves the issue:

Hope this helps!

- David

Thanks so much for the suggestion but I am afraid following those instructions did not help. I still have the same problem.

I had this same problem from this morning. So restarted Firefox in 'safe mode' with all addons etc disabled - and twitter worked!

Now all I have to do is work out which addon is the problem... *grumbles* *goes to make another cup of tea*

Found it. In my case anyway. My problems with twitter not working in firefox were caused by the 'Ghostery 2.8.3' extension. Disabled it and twitter worked fine.

Very interesting. I don't suppose you could tell me how to do this??

Oh it's OK! I just tried it and you are correct! Whichever add on we must both be using is interfering with twitter. It works for me now.

If you have Ghostery, it should be in your addons list. Access this through the firefox menu. It should be on the 'extensions' tab.

Cool! Have just checked on the developer's site - and they are aware of the problem and working on a fix.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Thanks. It seems the add on that is causing MY problem is the AVG search toolbar. So I have disabled that. AVG always seems to cause a problem for me!!!

Hi Andromedakraken,

The AVG toolbar is useless, to be perfectly honest. It's definitely best to leave it disabled like you did. Glad your problem was solved!

Cheers, David

PS. I have had that toolbar on my browser for aeons so I cannot understand why it would suddenly interfere with twitter. Weird

I don't have ghostery or AVG toolbar but in Fx 17 I cannot log into Twitter, follow anyone or post tweets. When I click on login the form that usually drops down does not appear.

I also am not able to log into sites using Facebook connect.

Something is interfering with the javascript libraries they use, no doubt (not "noscript" which I turn off).

Everything works in Chrome and IE.

mt3ch மூலமாக திருத்தப்பட்டது

Hi mt3ch

Try to clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

I narrowed this problem down to the "ShareMeNot" addon that is blocking certain script libraries used on Twitter and Facebook Connect.

Spot the emerging theme.

Seems to me that the twitter button (on websites) is now regarded as a 'tracker' by anti-tracking add-ons. Unless the writer's update their add-ons, users must "whitelist" Hmmm. Interesting. You want to use their website - you must allow them to track you?!

Derek C மூலமாக திருத்தப்பட்டது

Firefox 18 and same problems with Twitter. I've even tried accessing Twitter while using Firefox in "safe mode" and does not work. I've disabled all add ons and Twitter does not work. What am I missing?

ryderwriter, try clearing your cache to rule out that being the issue:

See also:

You can try to reset (power off/on) the router.

Cleared the cache. No luck. Cleared cookies, history. No luck. Rebooted. No luck.

The only way Twitter will work with Firefox 18 for me is to use Firefox in Safe Mode.

  1. 1
  2. 2