Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Server Sent Events in Dev tools -> Network tab

  • 3 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 26 views
  • Last reply by cor-el

I'm having a pretty frustrating developer experience using Firefox to help develop an app that uses Server Sent Events. Now, I'm not sure if I'm the one at fault or if it's something to do with Firefox itself (most likely I'm missing a config option somewhere).

Anways, the issue I'm having is that I cannot seem to be able to see Server Sent Events in the network tab of dev tools. This is specifically what I'm looking for: https://firefox-source-docs.mozilla.org/devtools-user/network_monitor/inspecting_server-sent_events/index.html

I'm testing this functionality by going to https://sse.dev/testpage.html, opening my network tab. I can see the connection to the SSE endpoint however, all I see is "No headers for this request" or "No response data for this request". I know it's getting the data through the event source because I can do stuff with the data. I've also tested this in Edge and everything appears in their network tab as expected which, makes me feel like this is more of a browser-specific issue. Again, I feel like it's me missing a config somewhere or having a privacy setting set which is somehow messing with the event stream.

Any help is appreciated... I guess I got to use Edge for the time being 🤮

I'm having a pretty frustrating developer experience using Firefox to help develop an app that uses Server Sent Events. Now, I'm not sure if I'm the one at fault or if it's something to do with Firefox itself (most likely I'm missing a config option somewhere). Anways, the issue I'm having is that I cannot seem to be able to see Server Sent Events in the network tab of dev tools. This is specifically what I'm looking for: https://firefox-source-docs.mozilla.org/devtools-user/network_monitor/inspecting_server-sent_events/index.html I'm testing this functionality by going to https://sse.dev/testpage.html, opening my network tab. I can see the connection to the SSE endpoint however, all I see is "No headers for this request" or "No response data for this request". I know it's getting the data through the event source because I can do stuff with the data. I've also tested this in Edge and everything appears in their network tab as expected which, makes me feel like this is more of a browser-specific issue. Again, I feel like it's me missing a config somewhere or having a privacy setting set which is somehow messing with the event stream. Any help is appreciated... I guess I got to use Edge for the time being 🤮
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

See comment 3.

  • 1830230 - Server sent events not displayed in the Network panel

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 👍 1

All Replies (3)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

See comment 3.

  • 1830230 - Server sent events not displayed in the Network panel

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

cor-el said

See comment 3.
  • 1830230 - Server sent events not displayed in the Network panel
(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Sorry, I didn't see this bug report, my bad!

Helpful?

See also this netmonitor-sse-inspector meta bug:

  • 1405706 - (netmonitor-sse-inspector) [meta] Inspect Server-Sent Events/SSE/EventSource Messages

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.