Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Weird character shows on screen and email

  • 4 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 40 views
  • Last reply by cor-el

On some pages, strange characters appear and cannot be read at all, please see the attached image

On some pages, strange characters appear and cannot be read at all, please see the attached image
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I've found the solution, select settings, search for fonts and remove the tick at the bottom "Allow pages to choose their own fonts, instead of your selections above"

Thank you very much

Read this answer in context 👍 1

All Replies (4)

Could you check what that font is using the Font Inspector -- here's how:

right-click (or Ctrl+click) the funky text and choose Inspect from the context menu.

Firefox should open a developer tools panel with that portion of the page's HTML code highlighted. On the right side, there will be one or two panes. On the right-most pane, if you see Fonts as an option after Layout Computed Changes (etc.), click Fonts. If you don't, click the tiny triangle at the end of that row and choose Fonts from the menu.

Then Firefox should tell you what font the site wants it to use and what it actually is using. For example:

Is your Firefox substituting some other font for Arial, or does it think it is using Arial?

Helpful?

Thank you, I check the font is Helvetica

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I've found the solution, select settings, search for fonts and remove the tick at the bottom "Allow pages to choose their own fonts, instead of your selections above"

Thank you very much

Helpful?

You shouldn't disable "Allow pages to choose their own fonts, instead of your selections above" as this will cause issues with iconic fonts used by webpages to display small icons.

You see little boxes with the hex code of the character or text labels if you do not have a font installed that covers this Unicode range or block downloadable fonts or if you do not allow pages to choose their own fonts.


You should identify what font is causing and instead fix this.

You can check in Font Book for font issues like corrupted and duplicate fonts.

Did you check what font is causing this issue ?

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.