Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Missing favicons

  • 18 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by PSL-MN

Some sites are missing favicons making the toolbar useless if I have to use text to identify them. I quit using FF because of this about a year ago as all the solutions on here did not work. Seems as though FF could fix this internally as it is not a problem on Chrome, IE, Edge or any other browser I have used. Why can't FF fix what seems to be very simple problem? Came back and it is still a problem. Again all the listed fixes that I have to initiate, have not worked. Why can't FF fix this through an update. I am not the only one who has this issue and it is exclusively a FF problem. Not a computer expert but this seems to be a VERY easy fix via updates especially since it has been an issue for literally years. Don't want to go back to Chrome as I like all that FF stands for, but... Thanks for reading

All Replies (18)

Hi mwagner13, did you have a thread here before under a different username or account, or is it your first time posting?

To see whether this might be a setting or add-on issue, could you try:

New Profile Test

This takes about 3 minutes, plus the time to test some problem sites.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like July2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile:

(A) Set your normal profile back to default to avoid unwanted surprises later

Check for a Set as Default Profile button under that profile and if you find it, click it.

(B) Scroll down to your new profile and click its Launch profile in new browser button

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem sites work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (July2020 will remain available for future testing.)

Thanks for the very quick reply. Can't remember if I had another thread as it has been a long time since I used FF. But I have created only 1 FF account and always use this username, I believe. I just went back to Chrome and figured (wrongly) after all this time FF would have the issue resolved for me and lots of other people.

This did nothing to help. It seems to me it is a FF browser problem, rather than something in my profile or my system, since so many others have the same problem. And if most replies are to be believed the suggested fixes do not work for them either. And in addition I have no problems with this on multiple other browsers. Why is the fix not being approached from that viewpoint rather than multiple fixes (none that have worked for me or for the most part others I see posting about the same issue). I am not a computer pro but anecdotal evidence points to this being an issue that starts internally from FF not individuals settings. Again thanks for the quick reply. I don't want to but it appears I need to go back to Chrome as this is not something that FF can fix for me or many other users. Pity as FF is my 1st choice but if I have to use text to recognize websites then the toolbar will only hold a minimal amount of shortcuts.


Why would Mozilla patch something they don't know about? You're complaining about a problem that only you have. Yet you refuse to give us any information to work with. I bet if I had access to your system I would be able to find out what the issue is in a few moments.

What jscher2000 suggested wasn't a fix but a troubleshoot.

Try sending screenshots next time of the issue. You said, some sites. Not all. Which means that those sites are specifically configured to block you from seeing their favicons. If there are many then I suggest you backup your bookmarks and passwords or sync them. Then do a refresh setup. You can find it in Troubleshooting Information in the help menu.

Engage மூலமாக திருத்தப்பட்டது

mwagner13 said

It seems to me it is a FF browser problem, rather than something in my profile or my system, since so many others have the same problem.

Firefox is not without problems, that is for sure. And Enhanced Tracking Protection has increased the number of ways that content can be blocked. However, I'm not aware of any major sites where Firefox cannot display icons (image-based or font-based) as long as they are not blocked.

I think I see a couple posts a year from users who do not see important icons on Google sites, such as the applications menu icon (3x3 grid of squares). Sometimes we can solve that, and sometimes we can't.

If you want to use Firefox, work with us to understand where you're having problems. Name names.


Why would FF fix something they are not aware of? Look at top right of this page and there is a post about this issue. I tried to be as polite as I could be by thanking for the quick reply and thanking several other times. The sites that you suggest " those sites are specifically configured to block you from seeing their favicons" do not block me on any other browser than FF. I have FF set on the default settings. Rather than berate me perhaps you could have asked for the info you needed to help me. I am not computer savvy as I stated twice in my posts.

BTW I noticed you edited out part of the comment you sent to me via email..." It sounds to me like you just like to complain and make demands without giving any information to those who could help you. If you have had a bad setting this whole time and you refuse to cooperate when asking for help then that's entirely on you."

I never refused to cooperate but don't let the facts destroy a good rant...I would be happy to furnish any info needed. I just did not know what that might be due to my lack of computer knowledge.


mwagner13 மூலமாக திருத்தப்பட்டது

Jscher2000 One of the sites that won't display the favicon is Walmart. I visit them daily on other browsers by using my bookmark favicon on my toolbar. I am not complaining. I did not send info because I had no idea what I should send. Please ask me for whatever info you need to help me. Should I send a screenshot of my toolbar with the Walmart bookmark that just looks like a globe. I had no idea that would be useful. I am using the default FF settings for everything.

Engage please do not engage with me anymore. Your combative attitude serves no useful purpose.


mwagner13 said

One of the sites that won't display the favicon is Walmart. ... Should I send a screenshot of my toolbar with the Walmart bookmark that just looks like a globe.

Sorry, I thought the problem was in web pages. Now I see why you referred to favicons.

Does Firefox show the Walmart site icon on the tab after the page loads? If so, Firefox is retrieving it successfully. Now, why isn't it showing with that bookmark on the toolbar? Hmm...

The most common reason would be if the bookmarked URL redirects. You can compare the final destination URL in the address bar to the address of the bookmark (right-click the bookmark, and click Properties). One typical scenario for a redirect is older bookmarks for http:// addresses have been updated to https:// addresses.

Or you can just create a new bookmark: drag the lock icon from the address bar to the desired spot on the Bookmarks Toolbar and release to create the new bookmark there. Assuming it works properly, you can right-click > Delete the old one.

If Firefox keeps the site icons initially but they disappear later, is there any pattern to that? For example, do they all vanish at system startup -- could indicate a problem with cleaning software -- or after a huge crash -- could indicate file damage.

The favicon/icon is on the tab. Looks like a gold asterisk. I dragged and dropped the lock as you suggested and this is what it looked like. Just a globe like all the others that aren't retrieved. I also tried manually typing in and then re saving with the same results.

As to your other question I occasionally "lose" the icon but clicking on it and going to the site restores it typically.

Thanks again and apologies again if I came across as complaining.

mwagner13 மூலமாக திருத்தப்பட்டது

This took a really long time to figure out, partly because it wasn't a very recent change.

Firefox 72 modified the window of time that it would store site icons to avoid updating them with post-load modifications like little badges showing the number of new messages that had come into your mailbox. As part of the new code, Firefox no longer saves site icons in the favicon.sqlite database if the server indicated they should not be stored. As an example of how that looks, Walmart is sending this HTTP header with the response --

cache-control: max-age=0, no-cache, no-store

-- as shown in the attached screenshot from Firefox's Network Monitor. So, the icon is shown on the tab, but not saved with the bookmark.

I can understand why the developers think it is important to honor the instructions from the server, but the end result is annoying.

I think one possible workaround would be to use an add-on that removes any no-store header for site icons, but this is a little complicated because the file names can vary. Nevertheless, even if it only modified the headers for the exact file name favicon.ico that probably would cover a lot of sites. There are some general purpose header modifying extensions, but they look a bit complicated to use. I wasn't planning on writing another extension but considering that we can hardly celebrate National Tequila Day this year, perhaps it's a good "Plan B."

Thanks again for your quick reply. If I understand you the Walmart server is, in laymans terms, asking that you not store/save the favicons and FF is honoring their request. The only workaround is to download an add on that won't honor that request. But it may or may not work for all sites. And is complicated. Since I am "computer knowledge" challenged I guess I will have to do w/out some favicons if I choose to continue to use FF. Thank you again for looking into this so thoroughly. Happy Tequila Day...

I created an add-on to work around this. When you load a bookmarked site whose favicon(s) Firefox won't store, you can click a button in the address bar to research the icon URL(s) -- I think this is reliable but have only tested a few sites so far -- and the extension then offers the option to add those to a list of URLs to recognize and modify the cache-control headers to allow storage. To trigger Firefox to retrieve the icons, it reloads the page.

Maybe there is a better way to do it, but that's what I was able to come up with.


Thank you for your top notch help. It is people like yourself and that attitude that makes me want to use and support FF. That kind of hands on individual and personal help is not typical in today's world.

Thank you

2020-09-10 - I have had issues with bookmark favicons not working for about 3 or 4 years, completely installing and uninstalling fire-fox many, many times, using different computers, always the latest version of Windows 10, using fire-fox sync, using 3rd party bookmark managers - often when importing bookmarks, there is no favicon, and I need to open every bookmark to load the favicon - can you please allow favicons to work normally in fire-fox?

I just replaced my old Mac with a new Mac. I restored all files and settings using a TIMEMACHINE backup. One fallout is that ALL of my favicons reverted to the generic globe. Trying some of the BMs some updated (UTUBE, Yahoo finance - but not main Yahoo), while some did not, including Google.

I found your add-on “Cache Favicons for Bookmarks", which worked on one of the favicon that otherwise would not update (Schwab), but not for several others of them. For example See attachment.

For Google I tried deleting the BM and re-adding it. I also tried dragging the tab (containing the favicon) to the BM bar. Both failed to update the favicon.

I am using FF version 80.0.1.

Am I missing something?


Hi PSL-MN, could you double-check the "Location" in your G bookmark (right-click > Properties)? If it isn't exactly the same as the final URL after redirects (for example, => ), you can update the location and see whether that helps Firefox make the match. Otherwise, I'm not sure what the issue would be.

Thanks for the reply….

As one who has done software support for 43 years I am mystified. Truly mystified.

This morning my Google BM displayed the Favicon. I did nothing that I am aware of to prompt that. I did retry your tool a day or so ago without success.

Moving on then I turned my attention to my Yahoo! BM, labeled simply Y! on my tool bar. In this case the address bar displays whereas your tool displays addresses which are totally different.

The comcast (Xfinity) site exhibits a different symptom. In this case the "reload" button is not active.

Please see attachments.

Thanks again for looking into this.

For G: that's good news. I don't know what changed.

For Y!: in the Location, change the protocol from http: to https: so it exactly matches the destination address. As for why the site icons are on a different server (, that is common for Yahoo sites.

For Xfinity: I'm not sure what is going wrong. I notice that if I display the panel, and then close it using either of these methods:

  • clicking the extension button in the address bar
  • pressing the Esc key

then when I click the extension button again, the button usually is NOT enabled. However, if I click Cancel and then click the extension button again, it works as intended.

Does yours follow that pattern? I should try to fix that if I can figure out what is going on there.

If it's not that issue, hmm, what is broken...

The order of actions is:

(1) Run a script to extract the addresses If the script returns a list: (2) Create list items on the panel to show the URLs (3) Enable the Reload button

Code for (2-3):

Perhaps Step 2 is dying because it is getting some garbage data from the script run in Step 1?? I didn't build in any error messaging there, so I'm not sure.

Thank you again for your help.

I have not (yet) found a BM where the option to reload was not active, so could not attempt the experiment.

Your suggestion for Y! worked.

As for Xfinity. I was now presented with the option to reload, which failed. I checked its properties and found them to be different, but when I tried changing from http to https I got a nasty-gram from firefox about trying to open a questionable site! (Sorry I did not take sufficient notes.)

In the end I dragged the tab containing the favicon to the tool bar which did update the favicon in the new BM. I deleted the old and clipped the name of the new to get what I wanted.

My main tool bar is now properly showing all favicons.

The bad news is that I have a score or more of folders, some with subfolders all full of BMs. Most have been around for ages and I have noted that for many of those the current address no longer matches what I captured, potentially years ago, on other browsers running on Windows at the time.

I started poking at them to see what sort of different cases I might find - none where the reload button didn’t activate. But I found several where the properties address no longer matched the current - none of these updated upon simple invocation. For these the tool did not work - as I now know is to be expected. Upon updating the properties they then picked up the favicon without need to employ the tool or they updated when prodded by the tool.

I have hours and hours in front of me if I want to regenerate all those favicons. I will probably ignore the issue and do them one at a time as I use the BMs. If a year from now I find, as I expect, many that have not been touched it is probably time to delete them.

I will monitor this thread from time to time and post an update if I find something interesting, or if I can find a case where the update button is not active.

Thank you so much for your help. Your assistance has been invaluable resolving this frustration!