Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

v72.0.1 Under Applications, I have KMZ set to Google Earth. Opening a KMZ file, popup appears asking what to open this with

  • 19 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 1 view
  • Last reply by cor-el

Whwn trying to open a KMZ file on a web page, a popup appears asking What should Firefox do with this file. Open with is checked yet no file is associated and I have to use the Browse option and find Google Earth.

All Replies (19)

Hi chuck.ott1, In Windows settings, check that

  • Choose default apps by file type
  • Set defaults by app

are set to Google Earth.

Helpful?

Google Earth is the default program for KMZ's in Windows. GE is also set as the default application for KMZ's in Firefox under Options....Applications. Firefox still asks me to set a default program when I try to download a KMZ

Helpful?

Try this: Download a KMZ and in the dialog Save it to your downloads folder. Do not select the Always Do This... Open it into GE. Then, try another KMZ download, Firefox should Open it in GE.

Helpful?

Didn't work.

Saved file to drive and opened it with GE, works

Next step, got:

Could not open .....kmz for reading

I tried multiple times, every time FF asked me what FF should do with this file

Helpful?

When everything is setup properly in the Applications handler, you shouldn't get a What should Firefox do... dialog.

Could you please browse through this article and double-check the setup: Change what Firefox does when you click on or download a file

Helpful?

If nothing in the article helps you solve the issue, you can reset your Applications handler.

Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox.

In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf

Close the folder window and launch Firefox. Your Applications handler will be reset to the default.

Helpful?

It's partially solved. FF will let GE open the file now, it just isn't automatic. I still have to select the program every time, even though GE is set as the default program under Options....Applications

Helpful?

Try de-selecting the Do this automatically... first then browse for GE and open the file. Double-check that GE is still set in the Applications for KMZ files. Then see what happens with the next file.


(I think we're getting closer without having to reset your Applications handler)

Helpful?

Tried this with both the Do this Automatically option checked & unchecked

I'm always asked what program to use the next time

Helpful?

Well... it is Monday

Everything else seems to be setup OK Maybe you should just reset the Applications handler

Helpful?

deleted that handlers.json setting and restarted. Still can't associate KMZ's with GE.

At least I can open them now after I select GE as the default program

Helpful?

I'm out of ideas right now but, I'll keep looking into it for you.

Helpful?

Thanks. I'm a 1/2 step closer. This morning FF would make me save the files to my drive and since the GE auto file opening would give me an error message from GE.

At least now I can open them, I just have to do the association

Helpful?

OK Like I said, I'll keep drilling. Let me know if anything changes on your end.

Helpful?

I couldn't find anything else relevant so, I downloaded and installed Google Earth Pro and left it open. Then I went to GoogleEarthHacks, found a KMZ file and downloaded it. A "What to do... " window opened. I selected Open With and Browsed for GE then clicked OK and the file opened in GE. "Always do this... " was Not selected. Then I went to Applications and KMZ was listed but it was set to Always Ask so, I changed it to Use Google Earth. I went back to GEHacks and selected another file. It opened right away in GE.

Helpful?

Under Applications....KMZ, my FF also shows Google Earth as the default program but when I click on a KMZ, I still get prompted for a program to use

Helpful?

A Note... when I use the File..Open in FF, the KMZ opens just fine. It's when I use an HTML shortcut in SalesForce that the problem exists.

I've chatted to SF to see if they're aware of this

Helpful?

Actions that appear in "Options/Preferences -> General -> Applications" are for a specific MIME type (content type) as send by the server, so if this isn't working then you may have created the action for a different content type or the server send the file with a generic content type or as a content disposition header.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.