Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why despite 'Open new windows in a new tab instead' is set do I keep getting new windows opening?

  • 7 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 99 views
  • Last reply by jscher2000

I have always had this set, but suddenly links have started opening in a new window [another Firefox browser opens], and despite checking open in new tab is set, it continues.

All Replies (7)

Hi PetePassword, your Firefox identified itself as versoin 52 running on Windows XP. Is that correct, so the relevant settings would be the ones from back in the day?

There are three related settings to check:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Review/Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will let it be a separate window. To force those into a tab as well, you can change this preference to 0:

  • 0 = apply the setting under (A) to ALL new windows (even script windows with features) <= you might want to try this
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Any improvement?

By the way, the extension list you shared includes something called "Package" which I don't think I've heard of before. Is that something useful you remember installing, or a possible bundleware item that snuck in and could be causing issues?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Excellent solution, precisely explained. Thanks very much indeed. Apologies for using something from the distant past, but I prefer stable XP with all the bugs removed to the juvenile animated versions that simply confuse and irritate!

I followed all instructions, and nothing changed. Why does each update require us to tweak it in order to have it the way we want? I'm tired of this; the developers know how to create an update that can follow existing settings, so do it.

Hi mcclenaghan, there wasn't a settings change; it should work the same way it always has.

What's happening on your Firefox, what's the pattern you're seeing?

Did your Firefox mention having to create a new profile and logging into your Firefox Account to retrieve settings?

To address your questions specifically--

(1)What's happening on your Firefox, what's the pattern you're seeing?

Trying to log into Facebook--page loads partially with icons only, which don't work; does not load postings; will not open my own timeline.

YouTube--it won't accept my password to sign into my Google account which works fine on Chrome.

Did your Firefox mention having to create a new profile and logging into your Firefox Account to retrieve settings?

Yes, and I clicked "create a new profile" but nothing changed. No message about logging into Firefox Account to retrieve settings, but I did try to access Firefox Account, and it rejected my password.

I tried uninstalling and reinstalling version 70 but that didn't do anything to change my problems. The problem is not with my passwords or accounts, because they all work in Chrome.

In exasperation, I reverted to the previous version of Firefox where everything works. No problem with Facebook or Gmail, or Firefox accounts where I posted the question.

Hi mcclenaghan, I don't think your issues are related to the subject of this thread, so you should start a different one.

Several users have reported problems loading FB and logging into some sites that insist cookies are disabled. It seems to be a problem with local storage, but the exact cause and best solution or workaround are still under discussion in several threads.

As a short-term workaround, it may help to change this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste next and pause while the list is filtered

(3) Double-click the dom.storage.next_gen preference to switch the value from true to false