Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Websites tell me I can't use websockets

  • 3 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 158 views
  • Last reply by x4fyr

Hey, mutiple sites tell me that the browser doesn't support websockets. First I saw this at the pushbullet add-on. There I thought it was a site-specific problem. But now I tried IPython notebook, and the erro came again. I tried http://www.websocket.org/echo.html and the same again. But http://caniuse.com/websockets tells me that it should be supported. Checked both in normal and in safe-mode, so it isn't an add-on problem. Firefox Developer works with this sites.

Here the system specs: Archlinux x64 fully up-to-date

As the Troubleshooting Information button below seems not to do its work I add it here: {

 "application": {
   "name": "Firefox",
   "version": "33.1.1",
   "userAgent": "Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0",
   "supportURL": "https://support.mozilla.org/1/firefox/33.1.1/Linux/en-US/",
   "numTotalWindows": 1,
   "numRemoteWindows": 0
 },
 "lockedPreferences": {},
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 0,
   "windowLayerManagerType": "Basic",
   "windowLayerManagerRemote": false,
   "numAcceleratedWindowsMessage": [
     ""
   ],
   "adapterDescription": "NVIDIA Corporation -- GeForce GTX 560 Ti/PCIe/SSE2",
   "adapterVendorID": "NVIDIA Corporation",
   "adapterDeviceID": "GeForce GTX 560 Ti/PCIe/SSE2",
   "adapterRAM": "",
   "adapterDrivers": "",
   "driverVersion": "4.4.0 NVIDIA 343.22",
   "driverDate": "",
   "webglRenderer": "NVIDIA Corporation -- GeForce GTX 560 Ti/PCIe/SSE2",
   "info": {
     "AzureCanvasBackend": "cairo",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "none",
     "AzureContentBackend": "cairo"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.7",
     "version": "4.10.7"
   },
   "NSS": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.17.2",
     "version": "3.17.2"
   },
   "NSSSSL": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": [
   {
     "name": "Add to Amazon Wish List Button",
     "version": "1.10",
     "isActive": false,
     "id": "amznUWL2@amazon.com"
   },
   {
     "name": "Cert Alert",
     "version": "0.0.8",
     "isActive": false,
     "id": "{c45ac2c6-14d5-11df-844d-001f16155cce}"
   },
   {
     "name": "Clean Links",
     "version": "2.6.1.0",
     "isActive": false,
     "id": "{158d7cb3-7039-4a75-8e0b-3bd0a464edd2}"
   },
   {
     "name": "Click to Play per-element",
     "version": "0.0.7",
     "isActive": false,
     "id": "ClickToPlayPerElement@uaSad.addons.mozilla.org"
   },
   {
     "name": "Disconnect",
     "version": "3.14.0",
     "isActive": false,
     "id": "2.0@disconnect.me"
   },
   {
     "name": "DuckDuckGo Plus",
     "version": "0.4.6",
     "isActive": false,
     "id": "jid1-ZAdIEUB7XOzOJw@jetpack"
   },
   {
     "name": "Expiry Canary",
     "version": "1.1",
     "isActive": false,
     "id": "canary-extension@gerv.net"
   },
   {
     "name": "FlashGot",
     "version": "1.5.6.8",
     "isActive": false,
     "id": "{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}"
   },
   {
     "name": "Force-TLS",
     "version": "4.0.0",
     "isActive": false,
     "id": "forcetls@sid.stamm"
   },
   {
     "name": "FoxyProxy Standard",
     "version": "4.4.1",
     "isActive": false,
     "id": "foxyproxy@eric.h.jung"
   },
   {
     "name": "Ghostery",
     "version": "5.4.1",
     "isActive": false,
     "id": "firefox@ghostery.com"
   },
   {
     "name": "KDE Wallet password integration",
     "version": "2.4",
     "isActive": false,
     "id": "kwallet@guillermo.molina"
   },
   {
     "name": "Lightbeam",
     "version": "1.1.0",
     "isActive": false,
     "id": "jid1-F9UJ2thwoAm5gQ@jetpack"
   },
   {
     "name": "NoScript",
     "version": "2.6.9.5",
     "isActive": false,
     "id": "{73a6fe31-595d-460b-a920-fcc0f8843232}"
   },
   {
     "name": "Pentadactyl",
     "version": "1.1",
     "isActive": false,
     "id": "pentadactyl@dactyl.googlecode.com"
   },
   {
     "name": "Personas Plus",
     "version": "1.7.3",
     "isActive": false,
     "id": "personas@christopher.beard"
   },
   {
     "name": "Perspectives",
     "version": "4.5.2",
     "isActive": false,
     "id": "perspectives@cmu.edu"
   },
   {
     "name": "Private Tab",
     "version": "0.1.7.3",
     "isActive": false,
     "id": "privateTab@infocatcher"
   },
   {
     "name": "Pushbullet",
     "version": "37",
     "isActive": false,
     "id": "jid1-BYcQOfYfmBMd9A@jetpack"
   },
   {
     "name": "RequestPolicy",
     "version": "0.5.28",
     "isActive": false,
     "id": "requestpolicy@requestpolicy.com"
   },
   {
     "name": "Safe",
     "version": "1.1.2",
     "isActive": false,
     "id": "safe@cesaroliveira.net"
   },
   {
     "name": "Self-Destructing Cookies",
     "version": "0.4.6",
     "isActive": false,
     "id": "jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack"
   },
   {
     "name": "Send to XBMC",
     "version": "1.2",
     "isActive": false,
     "id": "jid0-YCM0p5WlCGjvBJcZhAusQ5h26wM@jetpack"
   },
   {
     "name": "Stylish",
     "version": "1.4.3",
     "isActive": false,
     "id": "{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}"
   },
   {
     "name": "Troubleshooter",
     "version": "1.1a",
     "isActive": false,
     "id": "troubleshooter@mozilla.org"
   },
   {
     "name": "Turn Off the Lights",
     "version": "3.0.0.16",
     "isActive": false,
     "id": "stefanvandamme@stefanvd.net"
   },
   {
     "name": "User Agent Overrider",
     "version": "0.2.4",
     "isActive": false,
     "id": "useragentoverrider@qixinglu.com"
   },
   {
     "name": "Vimperator",
     "version": "3.8.3",
     "isActive": false,
     "id": "vimperator@mozdev.org"
   }
 ],
 "experiments": []

}

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Ok. Another profile solved this. It was a simple setting that was set false. I think this was a fragment of firefox 4/5 (yes my actual config have its root in the firefox 3.xx times), ther was simply the key network.websocket.enabled set to false, and I never used it till now. So I'm able to keep my good old config, and just have to change this in about:config.

So if someone have the same problem: Before resetting the config or even worse the whole profile: - Open the link "about:config" in browser - Search for the key: network.websocket.enabled - Check if it's set to true (the default option)

Read this answer in context 👍 0

All Replies (3)

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Ok. Another profile solved this. It was a simple setting that was set false. I think this was a fragment of firefox 4/5 (yes my actual config have its root in the firefox 3.xx times), ther was simply the key network.websocket.enabled set to false, and I never used it till now. So I'm able to keep my good old config, and just have to change this in about:config.

So if someone have the same problem: Before resetting the config or even worse the whole profile: - Open the link "about:config" in browser - Search for the key: network.websocket.enabled - Check if it's set to true (the default option)