Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox randomly slow at startup

  • 8 majibu
  • 0 wana tatizo hili
  • 65 views
  • Last reply by Inglebard

more options

Hello,

For an unknown reason, my firefox sometimes is really slow to startup.

It can take up to 10 minutes before the webpage start to load. My hardware is not that bad. I try to use the "performance" to capture the issue : https://share.firefox.dev/3x2rgHj I don't know if there is something to see because, the tool is also slow.

It happens on 3 different computers on linux.

I try to disable all extensions and without telemetry but nothing change. I'm reporting the problem now but it's much older

If you have a idea to fix this issue please share because it's really annoying.

Hello, For an unknown reason, my firefox sometimes is really slow to startup. It can take up to 10 minutes before the webpage start to load. My hardware is not that bad. I try to use the "performance" to capture the issue : https://share.firefox.dev/3x2rgHj I don't know if there is something to see because, the tool is also slow. It happens on 3 different computers on linux. I try to disable all extensions and without telemetry but nothing change. I'm reporting the problem now but it's much older If you have a idea to fix this issue please share because it's really annoying.

Chosen solution

  • Click the "Clear startup cache" button in about:support.
  • Try changing widget.use-xdg-desktop-portal.settings to 0 in about:config.
  • Keep fonts to a minimum, avoid installing large font packs.
Read this answer in context 👍 1

All Replies (8)

more options

Does the following command time out?

hostname -f

Helpful?

more options

Hello @zeroknight,

hostname -f works properly and return my machine name.

Helpful?

more options

Does it still happen with the flatpak package?

Helpful?

more options

I use the distribution package. I never use the flatpak package.

I may try to see if the issue is present with flatpak.

Helpful?

more options

What OS? What Desktop? X11 or Wayland?

Helpful?

more options

Hello jonzn4SUZE,

I use Manjaro and Gnome on both of them. One use Wayland and the other two use X11 with NVIDIA proprietary driver.

Before, I used to have Archlinux and the problem was also present.

Helpful?

more options

Suluhisho teule

  • Click the "Clear startup cache" button in about:support.
  • Try changing widget.use-xdg-desktop-portal.settings to 0 in about:config.
  • Keep fonts to a minimum, avoid installing large font packs.

Helpful?

more options

"Clear startup cache" button seems to reproduce the problem. I was not able to reproduce my issue on an empty profile.

So I suppose startup cache use some cookies and other data. After clearing cookies and data on my other computer, it is better.

So I consider my issue as solved.

Helpful?

Uliza swali

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.