Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

How to make Firefox always show navigation buttons in context menu, also when right clicking an image?

  • 4 odpovede
  • 0 má tento problém
  • 25 zobrazení
  • Posledná odpoveď od zenuity

more options

Is there any way to make Firefox show the "back", "forward", "reload", "bookmark" buttons that are shown in the default context menu when right clicking a web page also in the context menu that is shown when right clicking an image?

I think those buttons should always be included in all context menus opened for a web page, no matter if you happen to click on the background, on selected text, on an image or a link because.

It is so frustrating having to open the context menu multiple times to find a location where the default context menu is opened instead of the specific ones for selected texts, images, links etc.

Thanks!

Is there any way to make Firefox show the "back", "forward", "reload", "bookmark" buttons that are shown in the default context menu when right clicking a web page also in the context menu that is shown when right clicking an image? I think those buttons should always be included in all context menus opened for a web page, no matter if you happen to click on the background, on selected text, on an image or a link because. It is so frustrating having to open the context menu multiple times to find a location where the default context menu is opened instead of the specific ones for selected texts, images, links etc. Thanks!
Priložené obrázky

Vybrané riešenie

zeroknight said

Paste the following into a text file and save it to <profile>/chrome/userChrome.css. Change toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config then restart the browser. #context-navigation, #context-navigation > menuitem, #context-sep-navigation { display: flex; } #context-stop[disabled="true"] { display: none; } #context-reload:has(+ #context-stop:not([disabled])) { display: none; }

Thank you very much, this works perfectly!

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (4)

more options

The context menu only shows items relevant to where you open the context menu, hence the name context menu, so you only get those buttons if you right-click in an area that doesn't have its own context menu (i.e. you get the standard menu). You can always click those buttons directly in the Navigation Toolbar or use the keyboard.

Pomohla vám táto odpoveď?

more options

Paste the following into a text file and save it to <profile>/chrome/userChrome.css. Change toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config then restart the browser.

#context-navigation,
#context-navigation > menuitem,
#context-sep-navigation {
  display: flex;
}
#context-stop[disabled="true"] {
  display: none;
}
#context-reload:has(+ #context-stop:not([disabled])) {
  display: none;
}

Pomohla vám táto odpoveď?

more options

cor-el said

The context menu only shows items relevant to where you open the context menu, hence the name context menu, so you only get those buttons if you right-click in an area that doesn't have its own context menu (i.e. you get the standard menu). You can always click those buttons directly in the Navigation Toolbar or use the keyboard.

I argue that the browser page context menu should always show the actions relevant for the web page. If a link or image has been clicked, the menu should additionally show the more specific actions for the clicked entity.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

zeroknight said

Paste the following into a text file and save it to <profile>/chrome/userChrome.css. Change toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config then restart the browser. #context-navigation, #context-navigation > menuitem, #context-sep-navigation { display: flex; } #context-stop[disabled="true"] { display: none; } #context-reload:has(+ #context-stop:not([disabled])) { display: none; }

Thank you very much, this works perfectly!

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.