Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Videos buffering and/or not playing

  • 7 odpovedí
  • 12 má tento problém
  • 155 zobrazení
  • Posledná odpoveď od peterdonchev

more options

When I try to play a video on Firefox desktop, it takes it a long time to load. Once it has loaded, whenever I pause it for more than a few seconds, or if I try to skip around the video (either by clicking around in the loaded section of the progress bar or using +/- seconds buttons), the video begins buffering again before the video resumes. This makes it extremely difficult and frustrating to watch anything that requires me to pause, rewind, or fast forward. I've noticed this issue affect multiple video viewing sites, such as YouTube, Vimeo, and Netflix. My roommate also uses Firefox, but doesn't have this issue, so I know it's not a problem with my internet. I thought it might be a problem with my computer, but I tried to replicate the issue in Chrome and everything worked fine there. The issue has persisted almost a week. I have:

  • Rebooted my computer several times
  • Deleted my history/cache
  • Disabled my extensions
  • Turned off Java scripts in firefox (this disabled my ability to load sites like YouTube completely, so I turned it back on)
  • Updated my computer
  • Updated my graphics drivers
  • Refreshed firefox
  • Uninstalled and reinstalled firefox (and rebooted my computer)
  • Uninstalled and reinstalled firefox AND deleted all the data it stored on my computer (and rebooted my computer)

I am currently using version 123.0.1 of Firefox. My OS is Windows 10 22H2.

When I try to play a video on Firefox desktop, it takes it a long time to load. Once it has loaded, whenever I pause it for more than a few seconds, or if I try to skip around the video (either by clicking around in the loaded section of the progress bar or using +/- seconds buttons), the video begins buffering again before the video resumes. This makes it extremely difficult and frustrating to watch anything that requires me to pause, rewind, or fast forward. I've noticed this issue affect multiple video viewing sites, such as YouTube, Vimeo, and Netflix. My roommate also uses Firefox, but doesn't have this issue, so I know it's not a problem with my internet. I thought it might be a problem with my computer, but I tried to replicate the issue in Chrome and everything worked fine there. The issue has persisted almost a week. I have: * Rebooted my computer several times * Deleted my history/cache * Disabled my extensions * Turned off Java scripts in firefox (this disabled my ability to load sites like YouTube completely, so I turned it back on) * Updated my computer * Updated my graphics drivers * Refreshed firefox * Uninstalled and reinstalled firefox (and rebooted my computer) * Uninstalled and reinstalled firefox AND deleted all the data it stored on my computer (and rebooted my computer) I am currently using version 123.0.1 of Firefox. My OS is Windows 10 22H2.

Vybrané riešenie

I have actually figured out a fix. I don't know if it will work long term, so I'll update here if it comes back. SOLUTION:

  1. Opened control panel
  2. Opened "hardware and sound"
  3. Opened "sound"
  4. Selected my current audio device (I switch between headphones and speakers) and opened "Properties"
  5. Opened "advanced" tab
  6. Unchecked a box marked "enable audio enhancements"

Once I did this, videos started playing normally again. I had to repeat this process for every audio device my computer is connected to, but so far it seems to have fixed it. I'm still at a complete loss as to why this affected Firefox but not chrome, but I'm just happy I've got it working again. Thanks for your help everyone!

Čítať túto odpoveď v kontexte 👍 4

Všetky odpovede (7)

more options

Try changing browser.privatebrowsing.forceMediaMemoryCache to true in about:config, then restart the browser and play a video in a private window.

Does it still happen with Developer Edition? Make sure you stay signed out of your sync account when testing.

Pomohla vám táto odpoveď?

more options

I tried both:

  • Private window: tried changing the setting to true, restarted browser, opened private window. No change. I switched setting back to false.
  • Developer edition: installed and made sure I was signed out. If anything, the problem was worse in developer edition than in the normal edition.

Update: I muted a tab while playing YouTube, and the buffering issue vanished, which leads me to believe that this may be an audio issue. I tried updating all my audio drivers, as well as playing videos on different audio devices, and the issue did not change. I have also noticed that when I switch audio devices, the switch takes several seconds to process. This leads me to believe the issue might be with my computer after all. I will now be looking into that, and will post a solution here in case anyone else runs into this problem. That said, I'm still not ruling out that this might be a Firefox issue, since it doesn't seem to be affecting chrome (although I have started noticing a delay when I start videos on chrome, but after the video begins it works fine). Any advice anyone might have on this problem would be greatly appreciated!

Upravil(a) AccidentalRogue dňa

Pomohla vám táto odpoveď?

more options

Windows home or pro? If pro, try testing in Windows Sandbox (VM) and see if you have the same issue. https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/ WiFi or plugged in? Who are you using for DNS? You can right click on the youtube video and show the stats for nerds to see you connection speed. see screenshot What security software are you running?

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

I have actually figured out a fix. I don't know if it will work long term, so I'll update here if it comes back. SOLUTION:

  1. Opened control panel
  2. Opened "hardware and sound"
  3. Opened "sound"
  4. Selected my current audio device (I switch between headphones and speakers) and opened "Properties"
  5. Opened "advanced" tab
  6. Unchecked a box marked "enable audio enhancements"

Once I did this, videos started playing normally again. I had to repeat this process for every audio device my computer is connected to, but so far it seems to have fixed it. I'm still at a complete loss as to why this affected Firefox but not chrome, but I'm just happy I've got it working again. Thanks for your help everyone!

Pomohla vám táto odpoveď?

more options

Same issue in Firefox on a Framework 13 laptop here. YT videos play fine in Edge. A few weeks ago on my desktop PC the YT videos played just fine in Firefox. Appears many others have similar issues, see Reddit below. I do have a fair amount of Firefox extensions, haven't tried without them.

I tried both solutions above but no improvement. Is there a way to objectively quantify video playback stutter in YT other than just eyeballing it?

https://www.reddit.com/r/firefox/comments/1774nlp/everything_youtube_is_just_bad_on_firefox_how_to/

https://www.reddit.com/r/firefox/comments/18ujbm6/the_addon_h264ify_fixed_my_frame_drops_stutter_on/

https://www.reddit.com/r/firefox/comments/18oa6kt/youtube_video_stutter/

https://www.reddit.com/r/firefox/comments/194iq2o/youtube_stutters/

https://www.reddit.com/r/firefox/comments/16pl9xo/videos_started_to_stutter/ - WE MAY HAVE A WINNER! This seemed to do it for me. Some sort of DXVA issue but not sure how it relates, honestly, as it's not explained in the reddit post. media.wmf.dxva.d3d11.enabled switched from true to false.

Upravil(a) Pär L dňa

Pomohla vám táto odpoveď?

more options

I downloaded FF "Developer Edition" and that fixed it for about a week... now FF won't play Youtube or NetFlix again. Prior to that I attempted a suggested fix by resetting my DRM stuff, to no avail.

This shit started not long after my last FF update about 6 weeks ago. So I'm running Chrome now.

I'd like to know why the Engineers at Firefox don't fix it themselves. Why do I have to poke around inside to fix their bad programing or ill-settings.

Actually I can't figure out why I"m here complaining... Chrome is working good for me.

LOL NO MORE DONATIONS TO MOZ FROM ME! I usually donate a couple times a year when they have their fund drive.

Thank You Ran Ticked Off in Florida

Pomohla vám táto odpoveď?

more options

Similar problem here. Some youtube videos always freezes. I am forced to switch to Chrome or Edge when I want to watch these videos.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.