Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Can I change the the full-screen video mode or force which GPU is used for playback?

  • 3 odpovede
  • 0 má tento problém
  • 2 zobrazenia
  • Posledná odpoveď od TyDraniu

more options

Hi :)

I use Firefox on my Asus laptop running Windows 10. It's one of these laptops with both integrated and dedicated graphics (Intel plus Nvidia).

I often experience this issue when putting a video in full-screen (especially when viewing trailers on Steam, but this may just be because I mainly use my Windows laptop for gaming, and thus most of my video consumption here is from steam). This screen will briefly (for less than one second) turn black and audio will pause before the video appears in full-screen, and playback resumes normally.

It "feels" like a GPU switch is taking place, I'd assume from the integrated graphics to the GeForce card. This is not the proble. The issue appears when I return from full-screen mode. I always have several Command Prompts open with SSH connections to my Linux server and sometimes my MacBook Pro. These windows are now empty. That is, all text is gone, and I can no longer interact with the sessions. They're not "broken," as in they're not saying "Not responding" and don't ask to be forcefully closed, they're just black windows with borders around them. All I can do is close them all down and open new ones to reconnect and start over from where I think I remember I was.

I should note that this doesn't ONLY happen with Firefox videos going into full-screen, it has also happened after launching a game and returning to the desktop. This strengthens my belief that this has to do with GPU switching and/or video "mode" change(s).

Assuming I'm correct (my IQ is 5,000 and I do do the very big brians), is there any way to control how videos go into full-screen in Firefox? Or "lock it" to a specific GPU? I've rummaged through about:config and haven't seen anything that seems directly relevant.

I've already tried using the Windows settings to tell the system that Firefox.exe should use the integrated Intel graphics only, but this has no effect.

I remember I used to use "Media Player Classic" many years ago, and it had a slew of options of how to render full-screen video. IIRC, it had stuff like "Overlay," "Windowed," "Windowed borderless," "DirectX," etc. This make me wonder if there's multiple ways of chosing how to render video in full-screen, then maybe one could direct Firefox to use a different one than the default and my problem might disappear? Or maybe one could tell Windows that if an app wants to go into full-screen video mode, Windows should pick a specific mode for it?

I'm not a Windows developer, so I don't know :) But I'm hoping someone has a good tip, because I'm finding myself using this system more and more, and this is my biggest problem with it currently.

Thanks in advance :)

Hi :) I use Firefox on my Asus laptop running Windows 10. It's one of these laptops with both integrated and dedicated graphics (Intel plus Nvidia). I often experience this issue when putting a video in full-screen (especially when viewing trailers on Steam, but this may just be because I mainly use my Windows laptop for gaming, and thus most of my video consumption here is from steam). This screen will briefly (for less than one second) turn black and audio will pause before the video appears in full-screen, and playback resumes normally. It "feels" like a GPU switch is taking place, I'd assume from the integrated graphics to the GeForce card. This is not the proble. The issue appears when I return from full-screen mode. I always have several Command Prompts open with SSH connections to my Linux server and sometimes my MacBook Pro. These windows are now empty. That is, all text is gone, and I can no longer interact with the sessions. They're not "broken," as in they're not saying "Not responding" and don't ask to be forcefully closed, they're just black windows with borders around them. All I can do is close them all down and open new ones to reconnect and start over from where I think I remember I was. I should note that this doesn't ONLY happen with Firefox videos going into full-screen, it has also happened after launching a game and returning to the desktop. This strengthens my belief that this has to do with GPU switching and/or video "mode" change(s). Assuming I'm correct (my IQ is 5,000 and I do do the very big brians), is there any way to control how videos go into full-screen in Firefox? Or "lock it" to a specific GPU? I've rummaged through about:config and haven't seen anything that seems directly relevant. I've already tried using the Windows settings to tell the system that Firefox.exe should use the integrated Intel graphics only, but this has no effect. I remember I used to use "Media Player Classic" many years ago, and it had a slew of options of how to render full-screen video. IIRC, it had stuff like "Overlay," "Windowed," "Windowed borderless," "DirectX," etc. This make me wonder if there's multiple ways of chosing how to render video in full-screen, then maybe one could direct Firefox to use a different one than the default and my problem might disappear? Or maybe one could tell Windows that if an app wants to go into full-screen video mode, Windows should pick a specific mode for it? I'm not a Windows developer, so I don't know :) But I'm hoping someone has a good tip, because I'm finding myself using this system more and more, and this is my biggest problem with it currently. Thanks in advance :)

Všetky odpovede (3)

more options

Hi,

I really don't think there's any GPU switch during the process. There's only one GPU all the time (that one from the GPU 1 section in about:support) and it's usually Intel by default.

Try to set up firefox.exe to use NVidia in your GPU settings.

more options

Hi TyDranio, thanks for replying :)

I had actually also tried that before, and I see now that I only just wrote that I tried to make Firefox use Intel, so sorry for not providing full info :)

However, I've been diving deeper into the behavior, and also monitoring Event Viewer to see if there were any clues popping up there when it happens, and it turned out that yes, there was.

In fact, this is the message that popped up every time, indicating that the window manager crashed and was restarted:

The Desktop Window Manager process has exited. (Process exit code: 0xc00001ad, Restart count: 1, Primary display device ID: Intel(R) Iris(R) Xe Graphics)

The obvious thing is to see if there are more recent drivers, and I did first install new Intel drivers directly from their own website. This didn't immediately fix the problem, although I had yet to actually restart. I then also fetched the latest Nvidia drivers from their website and updated those, too, and restarted.

This was yesterday, and so far - knock on wood - I haven't had an instance of the problem happening since then.

It's clear, though, that it isn't a Firefox issue (I didn't think I was, though, I just thought I might configure Firefox to help work around it), and also that it isn't (just) related to video playback, because just before I updated my drivers yesterday, it started happening with other apps (non-game apps) and also when simply opening a new tab in Firefox or even switching to another one. It also correlated with me having a lot of other apps open, and thus consuming more memory than usual. I also have way over 100 tabs in Firefox distributed across 11 windows currently. Most of the tabs are asleep (via Auto Tab Discard extension, love that btw), but still, there's a lot of memory consumption on this system.

I can't help but suspect the Intel drivers to be the culprit. I noticed that the drivers on the Intel website were for Iris and ARC cards, and following Gamers Nexus on YouTube I know about the horrific driver state that followed their ARC GPU launch. Seeing as how the iGPU uses system memory in lieu of VRAM, and this seems to correlate with high over-all memory consumption in Windows, I'm wondering if they've been using some buggy memory management code. AFAICT, the way this iGPU+GPU thingamajig works on this laptop, it always needs the iGPU to be active, even when it's the Nvidia GPU that's pulling the cart, and so that would allow for iGPU driver problems to surface even when an app is told to use just the Nvidia card.

Either way, sorry for the verbosity (I'm old, you youngsters with your hashymctags and instamagrams and whatnot don't like it), but I'm concluding that it's not possible to do anything in Firefox to prevent it, and it also seems like this latest driver update actually fixed it.

Thanks for your input, and have a great weekend :)

more options

Hi, we are aware of issues with Intel(R) Iris(R) Xe Graphics driver. But version 30.0.101.1340 and higher should be ok.