Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Enable title bar in profile

  • 6 odpovedí
  • 0 má tento problém
  • 13 zobrazení
  • Posledná odpoveď od niebelungen

more options

Hi,

I'm on an a pretty old Linux Xubuntu pc, but with the latest FireFox. In a profile I regularity use I unchecked the Title Bar checkbox in the Customize Toolbar screen, but then FF crashed and I can't get that profile opened again. I can still open other profiles (because I still use the old-fashioned profile manager and don't need to go into about:profiles), but when I open that particular profile, after some hangups, I only get FF in the taskbar, but no screen opens so I can't change the setting back again.

Is there a file in the profile folder I can edit or something like that to enable the Title Bar option again to see if that profile wants to open normally again?

In case that's not possible I can copy that particular profile into a new profile, but then I will undoubtedly also copy the title bar setting, which I don't want. So can I copy the profile except for the one file with that setting and use the file from the new profile instead? What file would that than be?

I hope someone can help me out. Thanks in advance for any help.

Hi, I'm on an a pretty old Linux Xubuntu pc, but with the latest FireFox. In a profile I regularity use I unchecked the Title Bar checkbox in the Customize Toolbar screen, but then FF crashed and I can't get that profile opened again. I can still open other profiles (because I still use the old-fashioned profile manager and don't need to go into about:profiles), but when I open that particular profile, after some hangups, I only get FF in the taskbar, but no screen opens so I can't change the setting back again. Is there a file in the profile folder I can edit or something like that to enable the Title Bar option again to see if that profile wants to open normally again? In case that's not possible I can copy that particular profile into a new profile, but then I will undoubtedly also copy the title bar setting, which I don't want. So can I copy the profile except for the one file with that setting and use the file from the new profile instead? What file would that than be? I hope someone can help me out. Thanks in advance for any help.

Vybrané riešenie

I forgot about how this works. It is stored as browser.tabs.inTitlebar on the about:config page, so you simply need to set this pref to 0 (meaning 'No'). You can search prefs.js for this pref or add the line if it doesn't appear there (it might not be there is the pref is default).

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (6)

more options

Press Alt or F10 to bring up the Menu Bar. Then View > Toolbars > Bookmarks Toolbar. Right-click on a blank spot on the toolbar and select Bookmarks Toolbar. Right-click on a blank spot on the toolbar and select Customize Toolbar. Look for Show / Hide Toolbars or just Toolbars at the bottom left.

more options

Thanks for the reply, but I've got the feeling you're trying to answer an entirely different question. I asked if there's a file in which I can edit the Title Bar option, or create a new profile in which I can copy the other profile but without the file that stores the Title Bar setting.

As I described the first problem is that the Firefox screen/window doesn't open. I only got a tab in he taskbar (I just tried again and opening this profile results in my computer hanging for 10 minutes before I get enough control again to stop FF from the taskbar), nothing more. So there is nothing to bring up a Menu in, let alone get to the Customize Toolbar screen, which I opened to change this setting in the first place before things went wrong.

I hope someone can help me out with this.

Upravil(a) niebelungen dňa

more options

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

more options

Thanks cor-el. Unfortunately this didn't help. First I checked the file for mentions of "title", but there was nothing in relation to the title-bar. But I still tried and renamed the file. When I started FF with that profile at first I got a window that was too large in height for my screen, but I couldn't resize the height. I opened the Customize toolbar screen, but because I couldn't resize the window I couldn't get to the bottom to check the title-bar setting. Then I restarted FF in that profile and FF froze or something like that, so I restarted it again and then my entire system kind of froze again, until I managed to close FF from the taskbar again.

But I went through this sequence before, before I changed the name of xulstore.json, so this didn't have much to do with it anyway.

more options

Vybrané riešenie

I forgot about how this works. It is stored as browser.tabs.inTitlebar on the about:config page, so you simply need to set this pref to 0 (meaning 'No'). You can search prefs.js for this pref or add the line if it doesn't appear there (it might not be there is the pref is default).

Upravil(a) cor-el dňa

more options

Thanks, that did the trick :-) The line was there already (set to 1) and just set it to 0 as you said and that profile started like before. Obviously FF and my old Xubuntu do not play nice together in every aspect.

I searched the web and the FF site for this setting, but nothing with this prefs.js file showed up. But this saves me from copying all my settings and stuff to another profile to get things back as they were.

Thanks !!