Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox add-ons (extensions) specifically IDM and Grammarly failed to load when opening firefox

  • 6 odpovedí
  • 1 má tento problém
  • 50 zobrazení
  • Posledná odpoveď od nagz06

more options

Whenever I open my firefox browser (always up-to-date), certain add-on extensions specifically, IDM and Grammarly fail to load always. In order for them to load, I still need to go to the "manage extensions" then turn on-off in order for them to work. I have tried different solutions that this link provided link text but none of them worked. Can anyone offer a definite solution in my problem?

Všetky odpovede (6)

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files"

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Pomohla vám táto odpoveď?

more options

FredMcD said

It’s possible that there is a problem with the file(s) that store the extensions registry. Type about:support in the address bar and press enter. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory. Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required. After, restart Firefox. See "Corrupt extension files" +++++++++++++++++++++++++++ You will have to approve the updating one last time.

I also have done this, still the same after the restart.

Pomohla vám táto odpoveď?

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Pomohla vám táto odpoveď?

more options

Try to clear the startup cache via the "Help -> More Troubleshooting Information" (about:support) page.

Upravil(a) cor-el dňa

Pomohla vám táto odpoveď?

more options

FredMcD said

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

I don't have programs like that. My firefox is installed on my NVME drive. The rest of my firefox add-ons still loaded with no problems, except for IDM and Grammarly

Upravil(a) nagz06 dňa

Pomohla vám táto odpoveď?

more options

cor-el said

Try to clear the startup cache via the "Help -> More Troubleshooting Information" (about:support) page.

Also tried this one, still IDM and Grammarly did not load, but the rest of my extensions were loaded

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.