Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop Firefox suggesting "Search with Google" or "Search with Amazon"

  • 4 odpovede
  • 2 majú tento problém
  • 815 zobrazení
  • Posledná odpoveď od cewinter

more options

I'm using 83.0b6 (64-bit) with both an address bar and search bar. Recently, if I type a g into the address bar the second suggestion is "search with google directly from the address bar. Typing an a does the same thing for amazon. Search suggestions are turned off. Top sites are unchecked in the address bar settings. All Firefox home content is unchecked in settings.

Is it possible to remove these "search with" suggestions from the address bar drop down? Thanks.

Vybrané riešenie

This occurs in Firefox Developer Edition with browser.urlbar.update2 = true in about:config. It seems to be a new kind of keyword integration.

Čítať túto odpoveď v kontexte 👍 2

Všetky odpovede (4)

more options

Could you attach a screenshot of what you see (blur out everything personal / irrelevant)? I do not use Firefox in English so I am not sure what you are referring to.

One thing that comes to my mind is a bar of search engine logos that let you switch on the fly. As I have my hands on the keyboard as I type, I prefer keywords to select the search engine, and it also allows for "unofficial search engines" via keywords and the %s parameter in bookmarks. To turn off those, go to Options / Search / One-click search engines and uncheck all. You may find more help here: Assign shortcuts to search engines How to search IMDB, Wikipedia and more from the address bar

more options

Sure. It's the second item on the drop down list on the first two screenshots. I can't find One-click search engines in my setting, but I do have a search shortcuts section. Removing google and amazon from that list doesn't affect the behavior. https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-10-31-08-42-34-b2f5ff.png https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-10-31-08-42-42-0cc175.png https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-10-31-08-42-50-03c7c0.png

more options

Vybrané riešenie

This occurs in Firefox Developer Edition with browser.urlbar.update2 = true in about:config. It seems to be a new kind of keyword integration.

more options

That gets rid of it. Thank you!