X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Linux/Fedora30 h.264 media "is not supported" but downloaded video plays fine

Ran
Pridané

ffmpeg is installed

== From twitter web page: error in web console:

For example, on twitter i get a "the media could not be played" placeholder and this in the web console:

HTTP “Content-Type” of “video/mp4” is not supported. Load of media resource https://video.twimg.com/amplify_video/1149302678771683333/vid/1280x720/qFCcMLAnjR_MBans.mp4?tag=13 failed. home

The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.42E01E mp4a.40.2"

When i click on that link in the error it saves the video to /tmp and plays it in ffplay.. and in preferences->Applications, video/mp4 shows up with ffplay configured.

== Plays fine with a local file

When I put that mp4 link in the address bar, it gives me a download dialog, I can download that file, and play it in firefox from the command line:

firefox qFCcMLAnjR_MBans.mp4

== Plays fine with a local html file with the video control html element:

When i open a local html file with the video control element that plays the video. So why do I get those errors when this is viewed on the twitter website?

Any pointers appreciated.

Thanks!

ffmpeg is installed == From twitter web page: error in web console: For example, on twitter i get a "the media could not be played" placeholder and this in the web console: <i><b> HTTP “Content-Type” of “video/mp4” is not supported. Load of media resource https://video.twimg.com/amplify_video/1149302678771683333/vid/1280x720/qFCcMLAnjR_MBans.mp4?tag=13 failed. home The video on this page can’t be played. Your system may not have the required video codecs for: video/mp4; codecs="avc1.42E01E mp4a.40.2" </i></b> When i click on that link in the error it saves the video to /tmp and plays it in ffplay.. and in preferences->Applications, video/mp4 shows up with ffplay configured. == Plays fine with a local file When I put that mp4 link in the address bar, it gives me a download dialog, I can download that file, and play it in firefox from the command line: firefox qFCcMLAnjR_MBans.mp4 == Plays fine with a local html file with the video control html element: When i open a local html file with the video control element that plays the video. So why do I get those errors when this is viewed on the twitter website? Any pointers appreciated. Thanks!

Upravil(a) Ran dňa

Citácia

Ďalšie informácie o systéme

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Viac informácií

hellosct1 15 riešení 149 odpovedí

Hi,

it is possible to be active and see the HD by following the following link

https://support.mozilla.org/en-US/kb/firefox-4k-ultra-high-definition-youtube-videos

Hi, it is possible to be active and see the HD by following the following link https://support.mozilla.org/en-US/kb/firefox-4k-ultra-high-definition-youtube-videos
Pomohlo vám to?
Citácia
cor-el
  • Top 10 Contributor
  • Moderator
17467 riešení 157838 odpovedí

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.


gvfs-mime --query video/mp4
Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. *https://www.mozilla.org/en-US/firefox/all/ ---- gvfs-mime --query video/mp4
Pomohlo vám to?
Citácia
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.