Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Youtube block autoplay not working

  • 7 ответов
  • 0 имеют эту проблему
  • 498 просмотров
  • Последний ответ от HabibiFreshUFC

more options

Hello,

Recently Firefox tends to start autoplaying a YouTube video if I am on the tab.

Before it would not play the video if i am on the tab unless I physically press play.

It still works if I open a YouTube video in a tab that is not active, it will not autoplay, but as soon as I hover over and click on that tab it will start playing, however I do not want this to happen, I want it to pretty much always be autoplay blocked regardless if tab is active or not and I want to physically press play in order for it to start.

How to revert it to that state?

My block audio and video setting in firefox is already turned on, not sure what to do, pretty sure I did nothing on my end.

Right now I have to use extension called "disable autoplay" just to get by.

Thanks guys!

Hello, Recently Firefox tends to start autoplaying a YouTube video if I am on the tab. Before it would not play the video if i am on the tab unless I physically press play. It still works if I open a YouTube video in a tab that is not active, it will not autoplay, but as soon as I hover over and click on that tab it will start playing, however I do not want this to happen, I want it to pretty much always be autoplay blocked regardless if tab is active or not and I want to physically press play in order for it to start. How to revert it to that state? My block audio and video setting in firefox is already turned on, not sure what to do, pretty sure I did nothing on my end. Right now I have to use extension called "disable autoplay" just to get by. Thanks guys!

Выбранное решение

You can look at these prefs on the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.block-autoplay-until-in-foreground

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Прочитайте этот ответ в контексте 👍 3

Все ответы (7)

more options

Did you check you settings in youtube in playback & performance? Not sure if this will help but worth a shot. This latest update has been a nightmare all around I see. I lost my ability to print and no matter what I do, it doesn't solve it.

more options

janpre2001 said

Did you check you settings in youtube in playback & performance? Not sure if this will help but worth a shot. This latest update has been a nightmare all around I see. I lost my ability to print and no matter what I do, it doesn't solve it.

In chrome it works perfect, was there a firefox update that broke this? Or was it a youtube update?

Изменено HabibiFreshUFC

more options

Выбранное решение

You can look at these prefs on the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.block-autoplay-until-in-foreground

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


more options

Beast!

This one fixed it "media.autoplay.blocking_policy = 2 "

more options

Do you know how to make it so YouTube remembers where I left off it seems to have stopped saving where I left a video off...

more options

HabibiFreshUFC said

if I open a YouTube video in a tab that is not active, it will not autoplay, but as soon as I hover over and click on that tab it will start playing

New youtube tabs should not autoplay like you describe if you are blocking audio & video with no other changes.

HabibiFreshUFC said

make it so YouTube remembers where I left off

You need to be logged in to a youtube account with history enabled and it only works for longer videos that you have watched for a while.

Test in Troubleshoot Mode to rule out interference from extensions.

more options