Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

When I enter a image in my eMail signature, Thunderbird forgets the path and only keeps the filename, making the image disappear.

  • 10 ответов
  • 2 имеют эту проблему
  • 28 просмотров
  • Последний ответ от Roland Tanglao

more options

I had to leave Thunderbird because every time I try and create a customized signature, as much as Thunderbird excels in that area, the image storage drops the filename's path every time.

Example:

image loaded: http://rich.allcorn.us/files/headshot.png

when I go back to it: headshot.jpg


It forgets the path, so the file doesn't show up in the eMail. I purposefully put it "on the web" so it could be accessed from anywhere!

When is Thunderbird going to fix this so I can leave Apple's mail program and go back to Thunderbird?

-rich- Rich Allcorn eMail: rich@allcorn.us website: http://rich.allcorn.us

I had to leave Thunderbird because every time I try and create a customized signature, as much as Thunderbird excels in that area, the image storage drops the filename's path every time. Example: image loaded: http://rich.allcorn.us/files/headshot.png when I go back to it: headshot.jpg It forgets the path, so the file doesn't show up in the eMail. I purposefully put it "on the web" so it could be accessed from anywhere! When is Thunderbird going to fix this so I can leave Apple's mail program and go back to Thunderbird? -rich- Rich Allcorn eMail: rich@allcorn.us website: http://rich.allcorn.us

Все ответы (10)

more options

Please post the exact HTML that you use, as others are not experience this problem.

more options

The HTML is automatically created. I am using the graphics interface for setup. I even tried going into the HTML editor and manually adding the path. It removes that path as soon as the HTML file is saved!

(see pics)

more options

In the middle image you have location as headshot.jpg. That box should have the URL . In the alt text you have the URL. Switch those and click the box to include image in message. Once you get it the way you want, you could copy and paste the HTML in the sig area of account for automatic insertion.

more options

I followed the instructions here:

https://support.mozilla.org/en-US/kb/signatures#w_including-image-files-in-signatures

and entered your remote png URL in the Image Location box and also on the Link tab. Checked 'Attach this image...'. Saved as a File (html) and added it as a signature in Account Settings. Sent a test message, and the signature appeared in the message composer and the received message. The html source of the file shows the correct path. Tested on TB 115/W11. Maybe there is some difference in OS X about permissions.

more options

On the first reply ... I'm sorry, I wasn't clear enough on my photo images.

When I enter it, I always use the full path/filename but Thunderbird drops the path after I save the file. Then when you open it back up, the path is not there!!!


On the 2nd one, I've tried selecting and deselecting the "attach file to message" box. Still no change.


Sorry guys ... thanks for the ideas, though. I'm an ITguy of over 23+ years, and have tried most of what I would have someone else try in a scenario like this one.

Your efforts are appreciated! -rich-

more options

What is the actual HTML that is saved showing though? Sure the path is not being saved. I get that. Now perhaps we can work out why. Is perhaps the moz-do-not-send tag being inappropriately applied

What version of Thunderbird are you using?

more options

I enter the entire path/filename and even checked the html ... it's all there. But then when I open the .html file again, the path has been removed. The file pathname is an Internet path, not a local path.

I hope this helps.

P. S. It's the latest release of Thunderbird. (I thought maybe upgrading would have fixed it ... no.)

more options

is the moz-do-not-send tag present. I would expect it to be. What is is set to. This value controls if there is supposed to be an internal image, or an external link. Loosing the URL sounds like it might be related to the inclusion of the image in the email.

I can see it is not set to include in image in your images. But what is actually appearing in the HTML. It may be we have an apple bug here. I have nothing apple to even consider trying to replicate the issue. I see no point trying on Windows as the windows users already tried and could not replicate.

Perhaps make a paste of the actual HTML source so I stop asking. https://pastebin.mozilla.org/ just click the paste snippet on the right to get a link to your data and paste it here. I do suggest a rather long retention as I probably will not even get an email in an hour.

more options

I experience the same exact problem, not only with images in the signature, but on any part of the email: when I save an email as an html file, the .html file will remove everything in the URL but the file name, and the image file will (sometimes) be saved to the same directory as the html file.

I am using Mac as well and latest release, although this is happening to me for a year or so as far as I can remember, but finally found a proper thread where to post this.

Find attached some images and the full HTML as requested is here: https://pastebin.mozilla.org/gMPp85fm

Thank you very much in advance

Изменено Luis_Ro

more options

Hi Rich:

Works perfectly for me on gmail to gmail, on macOS Ventura latest, Thunderbird daily (I don't think there are any signature differences between daily and TB115)

https://pastebin.mozilla.org/oHDDoOYK is the HTML for my image

I'm sure Thunderbird has signature bugs but I'm also sure after 10 :-) seconds of looking at your complicated HTML in the pastebin that your HTML could probably be simplified and hopefully that would make it work.

Cheers! -- ....Roland p.s. If you want to continue debugging this, then you'll have to do the usual troubleshooting process as you know since like me you've worked in IT for decades :-)

Namely: Please try troubleshoot mode: https://support.mozilla.org/en-US/kb/troubleshoot-mode-thunderbird

If that doesn't help: Please provide the following troubleshooting details to help us help you:

  1. let us know your email provider (unlikely to cause the problem but stranger things have happened) e.g. gmail,
  2. let us know what operating system e.g. macOS Ventura or Yosemite or whatnot
  3. let us know what 3rd party software like add-ons, anti-virus or firewalls you are using (and please try disabling them and see if that helps)

And since you are an IT guy, please give us the simplest possible testcase i.e. the simplest HTML that reproduces the problem. Your current HTML is not the simplest possible :-) !