Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Thunderbird for Mac Can't Access E-Mail - unable to login to server

  • 34 ответа
  • 1 имеет эту проблему
  • 305 просмотров
  • Последний ответ от Matt

more options

I've followed the troubleshooting for installing Thunderbird for Mac (both 68.3.1 and 72.0b3), but I still can't get it to access my 2 GMail accounts in Mac OS 10.11 (El Capitan)?? Ironically, Thunderbird 3.1.11 works fine on an older Mac OS 10.4.11 (Tiger), but just too slowly for me....??

I've tried both auto-configure, and manually configuring the accounts, but I keep getting an error saying it can't get to the gmail server?? I've also tried No Authentication, but it still won't go through....??

I think it really should be a lot easier to configure than this--can anybody help fix this??


Thanks! --Jackie

Приложенные скриншоты

Изменено Wayne Mery

Выбранное решение

Matt said

I will have to look and see if I can find the topic again.

Found it. https://support.mozilla.org/en-US/questions/1275293

Прочитайте этот ответ в контексте 👍 1

Все ответы (20)

more options

I would have expected the yellow band to say something about being unable to find settings. Those settings are not the ones Thunderbird should retrieve from the web.

The automatic setting are at the link below and use oAuth for authentication in the case of IMAP and SMTP. https://autoconfig.thunderbird.net/v1.1/gmail.com

If Thunderbird does offer some suggestion it can not find settings for gmail, that means you have firewall issues, or something else is blocking the outgoing connection necessary to retrieve the settings. If you have one of those internet security suites, it is probably the issue.

If you have run some sort of security scan you might want to check to see if Thunderbird is still set to accept cookies in the preferences. oAuth uses cookies and will not work without them.

more options

Sorry, I don't see anything at the link you gave me--it just goes to an .html document, with no formatting....??

I did previously use 0Auth for authentication when I tried different settings, but the GMail accounts still wouldn't access the server....??

I also checked my firewall proxy in my Mac Settings, and there are none (or set to be off).

What else could be blocking the outgoing connection?

Will check the cookies preferences when I get home later--that's a possibility.

This is strange, because I had no prob setting up the older Thunderbird 3 on my older Mac, and it still works, but just is slow as I mentioned earlier.....;/


Thanks! --Jackie

more options

OK, I checked at home that the cookies for Thunderbird are accepted, and they are.

There is no "OAuth2" choice in the manual set-up (attached).....??

I have been using the ports and set-up configurations suggested by GMail here: <https://support.google.com/mail/answer/7126229?visit_id=637144776023701564-1470184629&rd=1>.

They seem to be the same ones at the link (when I strip the .html code) you sent me.

I've also tried the STARTTLS option for the servers, but that doesn't work, either.....??

So I'm still stymied as to what the settings are supposed to be....??


Thanks! --Jackie

more options

Attached is a picture of the window that appears when I added a gmail account, then clicked Manual config. The settings are the correct ones, entered automatically for an IMAP account. TB 68/W10. Similar picture with 72b3. Don't know why the Mac version omits the imap and smtp from the beginning of the server names and inputs Autodetect authentication.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

more options

Thanks!

But I did try those settings already (even adding the "imap" and "smtp" manually before the domain). See attached.

However, in my version there's no 0Auth2 choice.....??

Still can't get into the server......??

The port #s are correct, according to the GMail instructions. The only difference is the no 0Auth2 choice.....?? And this is in beta 72, when I thought that bug was supposed to have been fixed....??

Like I said, this is so odd, because I can choose the exact same settings in the older version of Mac Thunderbird 3, and I have no prob accessing the server....?? (In that version, I just use "normal password".)

In 72, I did try the other choices for password, but they don't get me into the server, either......??


Thanks! --Jackie

more options

What is your version? Help > about.

I am thinking it is not 68 and that it is from before 38 as that is the version where oauth2.0 was first offered.

more options

As you have stated in the original post, using TB 68 or 72beta, the option for OAuth2 authentication is missing from the menu. I don't have a Mac to confirm this, but it looks like a pretty bad omission. In the meantime, you can use 'normal password', but in that case you should enable access by 'less-secure apps' in you gmail account settings, and if you have two-step verification on the account, you must create an 'app password' and use that in TB instead of the regular account password. If you have to use an app password, delete any obsolete passwords in Preferences/Security/Passwords/Saved Passwords, if they exist, to avoid further conflicts. One of the advantages of OAuth for gmail is it is independent of 'less-secure' and 2-step verification status.

more options

First, update your TB to the LATEST Version: 68.4.1 ----> from here: https://download.mozilla.org/?product=thunderbird-68.4.1-SSL&os=osx&lang=en-US Just released.

I just did that, and when I go to set up my gmail account I see this Window (I clicked the "Manual Config" Button to expand it.):

Изменено Sea Mac

more options

These are the methods allowed on the "authentication" dropdowns shown ... first for Incoming Server ... second for Outgoing Server: and I find no trace of an "oAuth" method here ...

more options

Thanks everyone, for all your replies! Much appreciated! ;)

Unfortunately, I still can't access the GMail server. ;(

I downloaded and installed Mac 68.4.1 as suggested. I've attached the screenshot of the manual config window. Looks like the same as 68.3.1 or beta 72, so no change there. Still doesn't have any option to choose 0Auth2 for password. Only the previous options I showed you folks.

Also, I've already gone into my GMail accounts and allowed for less secure apps. I don't use 2-step authentication.

Under Preferences, my firewall is off.

Dunno if I should choose STARTTLS, but it doesn't matter because when I do I still can't get in......??

Again, dunno why I can't get in with these latest versions, while I get in fine with TB3 on an older Mac.....?? You would think the security would be lower, so more difficult to make compatible.....??

The only thing I can think of is the new format of GMail may be making it harder to get in, but why would that be so (i.e., "standard" vs. "basic")......??

Also, I had no prob configuring my GMail accounts with my new used Android phone, so why this difficulty with TB......??

Any ideas.....?? ;)


Thanks! --Jackie

more options

Well, just one last thing to try before you call Apple Tech Support over this issue. Go back into the panel that you just posted the screenshot of: and set all 6 of the dropdown selectors under Port, SSL, and Authentication back to Automatic - as seen in MY first screenshot - and then click the "Re-test" button. If/When that fails to detect your settings - Please call Apple Technical Support over this issue.

I agree there is no Option for Oauth2 under any of the Authentication dropdown selectors - Kerberos and NTLM (whatever that is) are the last 2 choices. But mine is working fine without it.

Изменено Sea Mac

more options

Could I ask you to file a bug for the missing oAuth. I have no idea what is going on there, but I would have thought we would have heard a lot more complains about it not being there.

This is important as Google have announced that they are not going to allow the use of Normal Password in the very near future. So it will be oAuth or a new mail client.

more options

Matt said

Could I ask you to file a bug for the missing oAuth. I have no idea what is going on there, but I would have thought we would have heard a lot more complains about it not being there. This is important as Google have announced that they are not going to allow the use of Normal Password in the very near future. So it will be oAuth or a new mail client.

ohh and cc me on it.

more options

If the account works on the old Mac and the phone, there must be something on the El Cap Mac interfering with the setup. If the old Mac and the phone are connecting on the same network through the same modem/router, I doubt there is anything wrong there. Start the El Cap Mac in OS X safe mode as a test of any startup apps, such as antivirus, password managers or related security programs, that might be having an effect when you run TB.

more options

Can't find a link for filing a bug. Maybe you can do it - since I don't know how.

Изменено Sea Mac

more options

Sea Mac said

Can't find a link for filing a bug. Maybe you can do it - since I don't know how.

https://bugzilla.mozilla.org/enter_bug.cgi#h=dupes%7CThunderbird

more options

https://bugzilla.mozilla.org/show_bug.cgi?id=1609249 Don't know how to add you to that bug. You seem to assume I know all of these things already ...

more options

When you submit the bug, include a link to this support thread, and then post the Bugzilla link here so users know where it is if they want to vote or receive Bugzilla notifications.

more options

Sea Mac said

https://bugzilla.mozilla.org/show_bug.cgi?id=1609249 Don't know how to add you to that bug. You seem to assume I know all of these things already ...

If you check the Bug you will see I did that already. I can't upvote my own bug, but if this is that important: I suggest you ALL pile onto it with your own comments and upvotes.

more options

Thanks again, everyone, for your replies! ;)

Yes, the old Mac and old TB are running on the same network/router.

No, I don't have anti-virus or other security software running on the Mac with El Capitan.

Oh, and the preferences in the v68 or v72 TB are set to accept cookies.

I've already tried setting all the options to Auto-Detect, but nada....??

And I echo Sea Mac--I don't see a link for filing a bug report, nor how to cc: Matt.....?

I sure hope they fix the bug that doesn't include 0Auth2, and whatever TB doesn't seem to like about connecting with Macs running El Capitan.....??

And I don't think Apple Support will help in this regard--TB is not an Apple product, and what they bundle with Macs is Safari, not TB......;/


Thanks! --Jackie

  1. 1
  2. 2