Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Adobe flash will not remain active on our 24h emergency medical web site, need it to alert us to medical data

  • 30 ответов
  • 2 имеют эту проблему
  • 198 просмотров
  • Последний ответ от James

more options

We have medical data coming in 24/7. Our alarm runs off flash. Since the update there isn't a choice to "allow and remember", which is causing us to have to remember to refresh the page constantly. A big problem for the night-staff, problem for the day-staff also as we keep forgeting and data is not alarming. PLEASE HELP!!

Все ответы (20)

more options

Mozilla, in the latest version, has removed the option for flash to be set to Always Allow.

I would recommend you downgrade to a prior version for now;

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

I have filed a Bug Report explaining that; https://bugzilla.mozilla.org/show_bug.cgi?id=1581664 Many users complaining of removing 'Always Allow' for flash player

Whether they do anything about this . . . . .

more options

Your IT admin can use enterprise policy to always allow flash on your medical alert website: https://support.mozilla.org/af/kb/manage-flash-firefox-enterprise .

more options

Thanks for your help FredMdD, -will stay tuned and hope the bug report helps! Thanks gijs, unfortunately we are a very small company and I am the IT person and I wouldn't have a clue on how to do what you describe. Sounds like a good idea though.

Hoping Firefox will realize how many of us "little people" rely on Adobe Flash

more options

FredMdD, here are instructions for setting enterprise policy using a simple `policies.json` text file in a new sub-directory called "distribution" in your Firefox directory:

https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson

You can use this "Enterprise Policy Generator" extension to create the `policies.json` text file using an easy GUI:

https://addons.mozilla.org/firefox/addon/enterprise-policy-generator/

For example, I created the following `policies.json` text file to allow Flash on my favorite Flash site (zombo.com):

``` {

 "policies": {
   "FlashPlugin": {
     "Allow": [
       "http://www.zombo.com/"
     ]
   }
 }

} ```

I saved that file to my Firefox directory: `C:\Program Files\Mozilla Firefox\distribution\policies.json`. I launched Firefox, opened zombo.com, and confirmed that Flash ran automatically.

more options
more options

for in the long run as you cannot use the Flash Plugin forever. https://developer.mozilla.org/en-US/docs/Plugins/Flash_to_HTML5

more options

Flash will never die! It will live on in the hearts of thousands (and old websites) forever. Don't remember flash for the security risk that it is, but instead remember it for the source of entertainment that it was. Remember the smiles it brought us, the games we played, the websites it ran (and still runs). As long as we keep flash in our hearts (and our browsers) it will never truly die, so let us take a moment of silence to remember Adobe Flash. *bows his head and sad music plays*

Изменено Sin Shadow Fox

more options

Firefox 70 (release date: October 22) will fix a bug that caused Firefox to forget after just one hour that you had clicked to allow Flash to run. Firefox 70 will remember until you quit Firefox.

https://bugzilla.mozilla.org/show_bug.cgi?id=1581664

If you absolutely need Flash to automatically run on a specific website (such as a work intranet website), then Firefox's enterprise policies.json file is the answer. See a comment above for instructions on creating a policies.json:

https://support.mozilla.org/en-US/questions/1268957#answer-1252862

more options

Chris Peterson said

FredMdD, here are instructions for setting enterprise policy using a simple `policies.json` text file in a new sub-directory called "distribution" in your Firefox directory: https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson You can use this "Enterprise Policy Generator" extension to create the `policies.json` text file using an easy GUI: https://addons.mozilla.org/firefox/addon/enterprise-policy-generator/ For example, I created the following `policies.json` text file to allow Flash on my favorite Flash site (zombo.com): ``` { "policies": { "FlashPlugin": { "Allow": [ "http://www.zombo.com/" ] } } } ``` I saved that file to my Firefox directory: `C:\Program Files\Mozilla Firefox\distribution\policies.json`. I launched Firefox, opened zombo.com, and confirmed that Flash ran automatically.

This method does not seem to work... FF 71.0, x86 and/or x64

Generated following code for policies.jason file in distribution folder which does not work....

{

 "policies": {
   "FlashPlugin": {
     "Allow": [
       "http://academy.ahima.org",
       "http://campus.ahima.org",
       "https://campus.ahima.org",
       "https://campus.ahima.org/vlab/Simulations/Vista/DataRetrieval"
     ],
     "Default": true
   }
 }

}

What is wrong how do I get it to work?

NEEDLESS TO SAY I SHOULD NOT HAVE TO DO ALL OF THIS AS I, THE IT SUPPORT FOR MY CAMPUS, MUST ALWAYS BE ABLE TO PERMANENTLY, AS NEEDED, ALLOW SOMETHING TO RUN FLASH, JAVA, ETC... I MUST ALWAYS BE IN CHARGE I WILL DECIDE WHAT IS SAFE AND WHAT IS NOT AND WHAT RISKS I WILL TAKE NOT Mozilla! DUH COMMON SENSE REALLY. QUIT TRYING TO BABY SIT ME PLEASE!!!!!!!!

more options

I feel your pain ralph. I'm also sick of this merry go round. first they said they fixed this in FF v70 and there was no option to leave it on or at least i couldn't find it then i finally got the FF v71 update a few days ago and i still can find the option. I'm getting realty sick of mozzila

more options

Hi RalphMalph555, just to check, there's no a in "policies.json" on your actual system, just in your reply?

It seems your file matches the documentation, but I haven't compared in detail:

https://github.com/mozilla/policy-templates#flashplugin

If necessary, you can do it via Group Policy, which may be easier if you need to implement on numerous systems.

Customizing Firefox Using Group Policy (Windows)

more options

Hi Sin Shadow Fox, what was changed in Firefox 70 was extending the "allow" from 1 hour to your entire session (i.e., until you exit Firefox). There wasn't a change bringing back an interactive "allow forever" option.

I see you posted in Bugzilla that you can't click the Login button on Pandora, but I don't see how that is connected to the Flash plugin. Perhaps we should continue on that in your thread here: https://support.mozilla.org/questions/1269506

more options

RalphMalph555 said

Generated following code for policies.jason file in distribution folder which does not work....

It is policies.json, not jason. You can check on the about:policies page, if policy is active, or not.

more options

RalphMalph555 said

NEEDLESS TO SAY I SHOULD NOT HAVE TO DO ALL OF THIS AS I, THE IT SUPPORT FOR MY CAMPUS, MUST ALWAYS BE ABLE TO PERMANENTLY, AS NEEDED, ALLOW SOMETHING TO RUN FLASH, JAVA, ETC... I MUST ALWAYS BE IN CHARGE I WILL DECIDE WHAT IS SAFE AND WHAT IS NOT AND WHAT RISKS I WILL TAKE NOT Mozilla! DUH COMMON SENSE REALLY. QUIT TRYING TO BABY SIT ME PLEASE!!!!!!!!

I see that you Spammed the Bug 1581664 comment 35. Your comment will likely be hidden soon.

Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html before you make any more comments in any Bugs in the bugzilla.mozilla.org general issues tracker. It is not a discussion forum (like SUMO is) nor is it a advocacy forum.


Btw the only NPAPI Plugin that has been allowed to run since the Firefox 52.0 Release has been the Flash Player Plugin from Adobe.

The Java Plugin is not being used by any web browser now days except maybe IE. Even Oracle has been in the process for a long time of depreciating their ever vulnerable Java Plugin as only Java 8 comes with the Plugin and not newer Java.

Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? https://support.mozilla.org/en-US/kb/npapi-plugins


The way the Flash Player Plugin from Adobe is being supported is not something only Mozilla is doing as other web browsers companies are doing more of less the same as time goes on till Adobe completely Ends of Life their Flash Player by end of 2020. https://blog.mozilla.org/futurereleases/2017/07/25/firefox-roadmap-flash-end-life/

Изменено James

more options

RalphMalph555, your policies.json code works for me. When I copy/paste it into my C:\Program Files\Mozilla Firefox\distribution\policies.json file, Firefox then automatically loads the Flash page on https://campus.ahima.org/vlab/Simulations/Vista/DataRetrieval/ without asking me to click to run Flash.

I suspect the "policies.jason" file name was the problem on your computer.

jscher2000 and TyDraniu, thanks for your helping debugging this policy file problem!

more options

@RalphMalph555

You can see on the policies page that you need a trailing backslash after the domain and that one you didn't include above.


{
  "policies": {
    "FlashPlugin": {
      "Allow": ["http://example.org/"],
      "Block": ["http://example.edu/"],
      "Default": true | false,
      "Locked": true | false
    }
  }

}

more options

I don't think a trailing backslash after the domain name is the problem with RalphMalph555's policies.json file. I copy/pasted his exact JSON code above into my policies.json file and then my Firefox successfully loaded the Flash page on https://campus.ahima.org/vlab/Simulations/Vista/DataRetrieval/ without asking me to click to run Flash.

more options

jscher2000 said

Hi RalphMalph555, just to check, there's no a in "policies.json" on your actual system, just in your reply? It seems your file matches the documentation, but I haven't compared in detail: https://github.com/mozilla/policy-templates#flashplugin If necessary, you can do it via Group Policy, which may be easier if you need to implement on numerous systems. Customizing Firefox Using Group Policy (Windows)

No "a" in the file name on the PC, just a typo on my part. It could have been though as I am prone to making such mistakes... Fat Fingers on the Keyboard....

I see where others say it works for them, unfortunately it still does not work for me..... With or without an "ending /" on the URL.

Thanks for trying...

It would be nice if Mozilla would just quite trying to babysit us!

Thanks again,

Ralph

  1. 1
  2. 2