Search Support

I can't find search tools on google with the android Firefox

  • 6 ответов
  • 8 имеют эту проблему
  • 1493 просмотра
  • Последний ответ от jscher2000

more options

When I search someting on google with my desktop fox, I can find 'search tools' on search results page.

like this image, videos, news.... serach tools

However, searching with my android fox, I can't see it. With other mobile browsers, I can see it. Why can't I see it with firefox?

Выбранное решение

You could lie to Google search and telling it Firefox is Chrome. That might cause unintended consequences but it's easier to undo than it is to set up in the first place. This is a two-browser operation:

(1) On Firefox for Android, select and copy the following if possible to avoid excess typing (either):

general.useragent.override.www.google.com

(2) Open a new tab to about:config (type about:config in the Awesomebar and tap the go arrow or tap Enter).

You may want to bookmark this for easier future access.

(3) In the search box, type useragent and pause while Firefox filters the list

(4) Scroll down and look for a preference named general.useragent.site_specific_overrides and confirm that it has its default value of true. If it is set to false, tap the Reset button to switch it back to true.

(5) Scroll back up and tap the large "+" button to the left of the search box to add a new setting

(A) The name of the preference should be

general.useragent.override.google.com (for all Google sites) general.useragent.override.www.google.com (for search specifically)

It's easiest to paste and edit. If you are typing it, watch out for autocorrect inserting spaces or changing capitalization, and make sure to clean that up.

(B) On the right side, tap Boolean and in the popup change it to String

(C) Temporarily assign any text, e.g., abc

(D) Then click Create

(6) Switch over to Chrome and open the following page:

https://www.jeffersonscher.com/res/jstest.php

(7) Select and copy the user agent string -- it appears in red

(8) Switch back to the about:config tab in Firefox, double-tap the temporary text, delete it, and paste the user agent string you copied, then tap any other preference to finish the edit.

If you run a search that opens in Google, Firefox should now send the Chrome user agent string and -- surprise! -- Search Tools. See attached screen shots.

When I tried this, I cleared cache and cookies before running the test, to make sure it was clean. To do that, you can go into:

menu > Settings > Clear Private Data

I selected only the categories I wanted to clear, which in my case were: Search history, Form history, Cookies & active logins, and Cache.

If you decide you want to undo this, return to about:config, find the override preferences, and tap Reset next to each preference to clear it.

Прочитайте этот ответ в контексте 👍 2

All Replies (6)

more options

Hi

You may need to view Google in a desktop view instead of the default mobile view.

This article will walk you through how to turn on and use Desktop View in Firefox for Android.

I hope this helps, but if not, please come back here and we can look into a different solution for you.

more options

With UC Browser, I can use search tools in mobile view. Why can't Firefox do it like UC?

more options

This is what Google gives us. You can complain to Google about their search results page on their forums:

https://productforums.google.com/forum/#!forum/websearch

more options

Выбранное решение

You could lie to Google search and telling it Firefox is Chrome. That might cause unintended consequences but it's easier to undo than it is to set up in the first place. This is a two-browser operation:

(1) On Firefox for Android, select and copy the following if possible to avoid excess typing (either):

general.useragent.override.www.google.com

(2) Open a new tab to about:config (type about:config in the Awesomebar and tap the go arrow or tap Enter).

You may want to bookmark this for easier future access.

(3) In the search box, type useragent and pause while Firefox filters the list

(4) Scroll down and look for a preference named general.useragent.site_specific_overrides and confirm that it has its default value of true. If it is set to false, tap the Reset button to switch it back to true.

(5) Scroll back up and tap the large "+" button to the left of the search box to add a new setting

(A) The name of the preference should be

general.useragent.override.google.com (for all Google sites) general.useragent.override.www.google.com (for search specifically)

It's easiest to paste and edit. If you are typing it, watch out for autocorrect inserting spaces or changing capitalization, and make sure to clean that up.

(B) On the right side, tap Boolean and in the popup change it to String

(C) Temporarily assign any text, e.g., abc

(D) Then click Create

(6) Switch over to Chrome and open the following page:

https://www.jeffersonscher.com/res/jstest.php

(7) Select and copy the user agent string -- it appears in red

(8) Switch back to the about:config tab in Firefox, double-tap the temporary text, delete it, and paste the user agent string you copied, then tap any other preference to finish the edit.

If you run a search that opens in Google, Firefox should now send the Chrome user agent string and -- surprise! -- Search Tools. See attached screen shots.

When I tried this, I cleared cache and cookies before running the test, to make sure it was clean. To do that, you can go into:

menu > Settings > Clear Private Data

I selected only the categories I wanted to clear, which in my case were: Search history, Form history, Cookies & active logins, and Cache.

If you decide you want to undo this, return to about:config, find the override preferences, and tap Reset next to each preference to clear it.

more options

My mobile phone automatically connects to google.co.kr, so I typed "google.co.kr" instead of "google.com". And, It works.

Thank you so much!!!!!!!!!!!!!!!

more options

As a footnote, it also works with "www.google.de" (screenshots attached).