X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

I want my homepage to be https://startpage.com/. Firefox will not start up with this as my homepage no matter what I do. How do I fix this?

Размещено

I can set the homepage to google or Firefox, but if I use startpage.com, Firefox starts up with a blank new tab.

I can set the homepage to google or Firefox, but if I use startpage.com, Firefox starts up with a blank new tab.

Дополнительные сведения о системе

Установленные плагины

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.74.2 for Mozilla browsers
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.2.172
  • 5.1.40728.0
  • VLC media player Web Plugin

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Дополнительная информация

jscher2000
  • Top 10 Contributor
8792 решений 71906 ответов
Размещено

Are you using the full URL, including the protocol at the beginning and the slash at the end? That avoids having to follow redirects:

https://startpage.com/

You can edit either on the Options page -- see: Startup, home page, tabs, and download settings -- or in the about:config preferences editor (steps further down).

If that still gives you a blank page, does it help to use the reload button (or Ctrl+r) or does it stay blank?


If the Options page is acting up, try this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste home and pause while the list is filtered

(3) Double-click the browser.startup.homepage preference and edit it to https://startpage.com/ and click OK

Note: if this preference has a status of "Locked" then we can help you remove the lock.

Are you using the full URL, including the protocol at the beginning and the slash at the end? That avoids having to follow redirects: https://startpage.com/ You can edit either on the Options page -- see: [[Startup, home page, tabs, and download settings]] -- or in the about:config preferences editor (steps further down). If that still gives you a blank page, does it help to use the reload button (or Ctrl+r) or does it stay blank? ---- If the Options page is acting up, try this way: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''home''' and pause while the list is filtered (3) Double-click the '''browser.startup.homepage''' preference and edit it to '''https://startpage.com/''' and click OK Note: if this preference has a status of "Locked" then we can help you remove the lock.
cor-el
  • Top 10 Contributor
  • Moderator
17575 решений 158980 ответов
Размещено

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 ---- Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

Задавший вопрос

None of these have solved this. This started after updating to Firefox 44 Previous versions worked fine.

None of these have solved this. This started after updating to Firefox 44 Previous versions worked fine.
cor-el
  • Top 10 Contributor
  • Moderator
17575 решений 158980 ответов
Размещено

Can you set that page as the home page and does it open if you click the Home button on the Navigation Toolbar?

If it only happens when you start Firefox then check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

Can you set that page as the home page and does it open if you click the Home button on the Navigation Toolbar? If it only happens when you start Firefox then check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

Задавший вопрос

The target line is fine. If I click the Home button, it goes to Startpage.

None of this happens if I set the home page to any other page, like Google, or Firefox.

This problem only started when Firefox updated to 44

The target line is fine. If I click the Home button, it goes to Startpage. None of this happens if I set the home page to any other page, like Google, or Firefox. This problem only started when Firefox updated to 44
cor-el
  • Top 10 Contributor
  • Moderator
17575 решений 158980 ответов
Размещено

So you only get a blank page if you start Firefox with the startup setting to show the home page and the home page is set to the startpage website?

Any other use of the home page toolbar button works?

So you only get a blank page if you start Firefox with the startup setting to show the home page and the home page is set to the startpage website? Any other use of the home page toolbar button works?

Задавший вопрос

Yes, starting Firefox by any method, taskbar, desktop shortcut will open a blank new tab.

As far as I can tell, clicking the home button on the toolbar will take me to my https://startpage.com/ home page.

In the past few days, on rare occasion, Firefox would open to startpage.com, but now it only opens a blank tab.

Yes, starting Firefox by any method, taskbar, desktop shortcut will open a blank new tab. As far as I can tell, clicking the home button on the toolbar will take me to my https://startpage.com/ home page. In the past few days, on rare occasion, Firefox would open to startpage.com, but now it only opens a blank tab.
jscher2000
  • Top 10 Contributor
8792 решений 71906 ответов
Размещено

We had a couple other reports of Firefox 44 starting up to a blank page instead of loading the home page. In both cases, users solved the problem by renaming or removing the prefs.js file, which often contains dozens of settings, and we didn't learn which particular setting was causing the issue.

We had a couple other reports of Firefox 44 starting up to a blank page instead of loading the home page. In both cases, users solved the problem by renaming or removing the prefs.js file, which often contains dozens of settings, and we didn't learn which particular setting was causing the issue. * [https://support.mozilla.org/questions/1108049 Firefox open with new tab not default home page] * [https://support.mozilla.org/questions/1106790 When I open Firefox it does not go to my home page even though my setting are set to go to home page when Firefox is opened.]

Задавший вопрос

Where do I find the prefs.js file? I looked under the about:config page and this file is not there.

Where do I find the prefs.js file? I looked under the about:config page and this file is not there.
jscher2000
  • Top 10 Contributor
8792 решений 71906 ответов
Размещено

Полезный ответ

The prefs.js file can be found in your currently active Firefox profile folder. It stores most of the customized preferences you see displayed in about:config. (Preferences that have their default value are not added to prefs.js.) If you want to try renaming it:

From within Firefox, open the profile folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename prefs.js to something like prefs-old.js (so you can reverse this if it's more painful than helpful, and for later comparison).

Start Firefox back up again and... do you get your home page? If necessary, use History > Restore Previous Session to get your tabs back.

The prefs.js file can be found in your currently active Firefox profile folder. It stores most of the customized preferences you see displayed in about:config. (Preferences that have their default value are not added to prefs.js.) If you want to try renaming it: From within Firefox, open the profile folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''prefs.js''' to something like '''prefs-old.js''' (so you can reverse this if it's more painful than helpful, and for later comparison). Start Firefox back up again and... do you get your home page? If necessary, use History > Restore Previous Session to get your tabs back.

Задавший вопрос

I followed this last set of instructions and I am cautiously optimistic that this has fixed the problem. I have started and shut down Firefox several times and so far it seems to be working. Previous solutions would work for a short while, but then I would have the same problem.

I have a couple of other computers to try this on.

I'll keep you posted as to whether I have further issues, but so far, everything looks good.

Thank you all for your assistance.

I followed this last set of instructions and I am cautiously optimistic that this has fixed the problem. I have started and shut down Firefox several times and so far it seems to be working. Previous solutions would work for a short while, but then I would have the same problem. I have a couple of other computers to try this on. I'll keep you posted as to whether I have further issues, but so far, everything looks good. Thank you all for your assistance.

Задавший вопрос

I spoke too soon. In the past day or so, this problem has been recurring randomly. At this point, about 20 percent of the time, when I start Firefox, I will get a blank new tab instead of my homepage. On another computer, this problem began much more quickly. On that one, I have 4 prefs.js-old versions that I have renamed and it makes the problem go away for about a day, then it returns.

I spoke too soon. In the past day or so, this problem has been recurring randomly. At this point, about 20 percent of the time, when I start Firefox, I will get a blank new tab instead of my homepage. On another computer, this problem began much more quickly. On that one, I have 4 prefs.js-old versions that I have renamed and it makes the problem go away for about a day, then it returns.
jscher2000
  • Top 10 Contributor
8792 решений 71906 ответов
Размещено

Hi StratoBlue, yesterday I was alerted to one cause of this issue: when Firefox is set to clear history at shutdown and does not finish the job -- for example, because Windows prematurely "killed" Firefox -- it will resume trying to clear history at startup. There is a timing bug in the code when the home page doesn't open quickly enough which halts the startup process. That bug will be fixed in Firefox 45.

One reason renaming prefs.js might have helped is that it would have turned off the "Clear history when Firefox closes" option, which seems to be at the root of the problem. As soon as you turn that back on, the conditions are present for the bug to be triggered again.

I don't know whether it makes any difference, but if you usually close Firefox using the red "X" button on the title bar, or any other standard Windows method, try using Exit from the menu to see whether that helps. Either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Hi StratoBlue, yesterday I was alerted to one cause of this issue: when Firefox is set to clear history at shutdown and does not finish the job -- for example, because Windows prematurely "killed" Firefox -- it will resume trying to clear history at startup. There is a timing bug in the code when the home page doesn't open quickly enough which halts the startup process. That bug will be fixed in Firefox 45. One reason renaming prefs.js might have helped is that it would have turned off the "Clear history when Firefox closes" option, which seems to be at the root of the problem. As soon as you turn that back on, the conditions are present for the bug to be triggered again. I don't know whether it makes any difference, but if you usually close Firefox using the red "X" button on the title bar, or any other standard Windows method, try using Exit from the menu to see whether that helps. Either: * "3-bar" menu button > "power" button * (menu bar) File > Exit
John99 971 решений 13138 ответов
Размещено

There is a possibility that some of you are suffering from a known bug with Firefox 44. ( Bug 1243549 - When I run (launch, open...) Firefox for the first time during a session I get a blank page instead of my usual home page. )

The defining features of the bug are

  • Firefox has been set to clear History on closedown
  • An intermittent problem on closedown {You may not be directly aware of that)
  • Problems on restarting after the close down issue. This could result in for instance a blank tab displaying.

For further info please see my post in

There is a possibility that some of you are suffering from a known bug with Firefox 44. (<sub> Bug 1243549 - When I run (launch, open...) Firefox for the first time during a session I get a blank page instead of my usual home page.</sub> ) The defining features of the bug are *Firefox has been set to '''clear History''' on closedown * An intermittent problem on closedown {You may not be directly aware of that) * '''Problems on restarting''' after the close down issue. This could result in for instance a blank tab displaying. '''For further info''' please see my post in * Would You Please Just Fix The Not Going To Homepage Issue With Firefox [/questions/1110662#answer-846478]