Pesquisar no site de suporte

Evite golpes de suporte. Nunca pedimos que você ligue ou envie uma mensagem de texto para um número de telefone, ou compartilhe informações pessoais. Denuncie atividades suspeitas usando a opção “Denunciar abuso”.

Learn More

Esta discussão foi arquivada. Faça uma nova pergunta se precisa de ajuda.

"Always use private browsing mode" on Linux opens multiple windows on launch, and no indication I'm actually in private mode

  • 3 respostas
  • 1 tem este problema
  • 1 visualização
  • Última resposta de Christian

more options

I use Firefox 87 on a number of notebooks duel booting various distros of linux (Mint, Manjaro, and MX Linux) and Windows 10, as well as a desktop running Windows 10.

On the notebooks Firefox is set to always use private browsing mode in both linux and Windows. On the desktop machine it isn't, but I always have private windows open. On the desktop version of Firefox private windows have the purple circle with a mask icon to show they are private. On the machines that are set to always use private mode Firefox never shows that icon, so I have to go on faith that they are private. Is there a reason always private doesn't also have the private icon?

Also, on the machines where Firefox is launched in always private mode, it always open 2 separate windows. This is a consistent thing when in always private mode.

I use Firefox 87 on a number of notebooks duel booting various distros of linux (Mint, Manjaro, and MX Linux) and Windows 10, as well as a desktop running Windows 10. On the notebooks Firefox is set to always use private browsing mode in both linux and Windows. On the desktop machine it isn't, but I always have private windows open. On the desktop version of Firefox private windows have the purple circle with a mask icon to show they are private. On the machines that are set to always use private mode Firefox never shows that icon, so I have to go on faith that they are private. Is there a reason always private doesn't also have the private icon? Also, on the machines where Firefox is launched in always private mode, it always open 2 separate windows. This is a consistent thing when in always private mode.

Todas as respostas (3)

more options

Christian said

On the desktop version of Firefox private windows have the purple circle with a mask icon to show they are private. On the machines that are set to always use private mode Firefox never shows that icon, so I have to go on faith that they are private. Is there a reason always private doesn't also have the private icon?

It has always been that way, but I don't know why. For verification, you can use this storage test page that has a consistent type of failure in private windows: https://firefox-storage-test.glitch.me/

Also, on the machines where Firefox is launched in always private mode, it always open 2 separate windows. This is a consistent thing when in always private mode.

I don't know why that would be. Does your desktop shortcut have any command-line parameters that might be triggering an extra window?

more options

You should also be able to check this via the File menu. In permanent Private Browsing mode only "New Private Window" is present and "New Window" is missing in the File menu.

You can also open the about:privatebrowsing page. See about:about for all available about pages.

more options

jscher2000 said

Christian said

On the desktop version of Firefox private windows have the purple circle with a mask icon to show they are private. On the machines that are set to always use private mode Firefox never shows that icon, so I have to go on faith that they are private. Is there a reason always private doesn't also have the private icon?

It has always been that way, but I don't know why. For verification, you can use this storage test page that has a consistent type of failure in private windows: https://firefox-storage-test.glitch.me/

Well, I guess I like the visual reminder, so I'll just set them to launch normally, and open a private window.

Also, on the machines where Firefox is launched in always private mode, it always open 2 separate windows. This is a consistent thing when in always private mode.

I don't know why that would be. Does your desktop shortcut have any command-line parameters that might be triggering an extra window?

No, I'm usually launching Firefox from the task bar in Windows or the menus in linux. Plus, after switching Firefox back to not starting up in private mode, the double windows on launch stops.