Przeszukaj pomoc

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts rendering problem

  • 5 odpowiedzi
  • 9 osób ma ten problem
  • 3726 wyświetleń
  • Ostatnia odpowiedź od ad_verbum

more options

After upgrading to Firefox 44.0.2 fonts on some web pages look blurred and are thinner than should be. It is easy to notice problem comparing this page: https://support.mozilla.org/pl/questions/firefox rendered in FF 44.0.2 with FF 44.0 or with Chrome.

Wybrane rozwiązanie

"Support for Direct2D 1.0 has been dropped in . Windows 7 users can install the Platform Update to re-enable Direct2D support (to fix font rendering issues)" Source : https://www.mozilla.org/en-US/firefox/44.0/releasenotes/

As the above solution suggested, you can try the platform update to see if it makes any difference or not.

https://www.microsoft.com/en-ca/download/details.aspx?id=36805

Przeczytaj tę odpowiedź w całym kontekście 👍 3

Wszystkie odpowiedzi (5)

more options

Wybrane rozwiązanie

"Support for Direct2D 1.0 has been dropped in . Windows 7 users can install the Platform Update to re-enable Direct2D support (to fix font rendering issues)" Source : https://www.mozilla.org/en-US/firefox/44.0/releasenotes/

As the above solution suggested, you can try the platform update to see if it makes any difference or not.

https://www.microsoft.com/en-ca/download/details.aspx?id=36805

more options

Could you check on whether your Firefox is using hardware acceleration? You can do that on the support information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics header and check the table that follows for:

  • Direct2D Enabled = true
  • GPU Accelerated Windows => numerator of the fraction = denominator

Those should indicate that hardware acceleration is being applied.

more options

Scroll down to the Graphics header and check the table that follows for:

  • Direct2D Enabled = true
  • GPU Accelerated Windows => numerator of the fraction = denominator


I can't find settings you mentioned but found these: gfx.driver-init.feature-d2d: true gfx.driver-init.feature-d3d11: true

more options

Hi ad_verbum, I think those are in the "Important Modified Preferences" list. There is a separate "Graphics" table.

more options

jscher2000 said

Hi ad_verbum, I think those are in the "Important Modified Preferences" list. There is a separate "Graphics" table.

I had to install Microsoft actualization mentioned by Samrat Bhattacharjee in first answer on my question. Earlier I hadn't these parameters listed. Now I have "Direct2D Enabled = true" and problem with badly looking fonts is resolved.