Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

Previous Session

  • 7 odpowiedzi
  • 1 osoba ma ten problem
  • 22 wyświetlenia
  • Ostatnia odpowiedź od cbrookej

more options

Despite setting to keep previous tabs open, on each close and re-open of Firefox, all tabs are closed and only the homepage tab is open in new session.

Happening on multiple Mac computers. If Force Closed, option to restore previous session is available. But not had success in closing Firefox normally and re-opening with previous session tabs.

Is there a bug?

Despite setting to keep previous tabs open, on each close and re-open of Firefox, all tabs are closed and only the homepage tab is open in new session. Happening on multiple Mac computers. If Force Closed, option to restore previous session is available. But not had success in closing Firefox normally and re-opening with previous session tabs. Is there a bug?

Wybrane rozwiązanie

Make sure that you do not close all open windows, but close the Firefox application (Firefox > Quit) while the window(s) are still open.

In case you use "Clear history when Firefox closes" :

  • do not clear the Browsing History
  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
Przeczytaj tę odpowiedź w całym kontekście 👍 1

Wszystkie odpowiedzi (7)

more options

Wybrane rozwiązanie

Make sure that you do not close all open windows, but close the Firefox application (Firefox > Quit) while the window(s) are still open.

In case you use "Clear history when Firefox closes" :

  • do not clear the Browsing History
  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

Zmodyfikowany przez cor-el w dniu

more options

Solved. Thanks.

more options

"close the Firefox application (Firefox > Qui) while the window(s) are still open."

I would like to be able to close the Firefox program. I don't underestand "(Firefox>Qui)" How can I access this option?

more options

This question is about Firefox on a Mac computer. On Mac you close the Firefox application via the Firefox menu (Firefox > Quit) (the 't' got lost in my above reply).

You can close Firefox via the power button in the "3-bar" menu button drop-down or via the file menu. You can tap the Alt key or press F10 to show the Menu Bar.

  • "3-bar" menu button > Exit (Power button)
    (Windows: File > Exit; Mac: Firefox > Quit Firefox; Linux: File > Quit)
more options

Thank you for your reply.

I am running Windows. I noticed that the instructions were for a Mac, but I thought I could figure out how to do it with Windows. It seems I am not that clever.

Will you please tell me how to do it in Windows?

brookej

more options

The instructions for all platforms are in my above reply. There is a close button in the "3-bar" menu button drop-down list. You can find this menu button at the right end of the Navigation Toolbar. At the bottom of the menu there are three icons. The first is the Customize icon, the seconds the Help (?) button, and the third the button to close Firefox. You can also find the Exit item in the File menu. You can tap the Alt key or press F10 to show the Menu Bar.

more options

Thank you! This will be very helpful.

brookej