Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

right-click context menu overlaps google apps context menus

  • 7 odpowiedzi
  • 8 osób ma ten problem
  • 421 wyświetleń
  • Ostatnia odpowiedź od cryscryb

more options

Ever since my update to 32.0.3 every time I'm in a web app, and I right-click the Firefox context menu now overlaps the application menu. I've already tried making sure that javascript settings to disable and replace context menus is enabled. Upon restart the same thing happens. This setting enabled or disabled, makes no no difference. I've disabled and removed all other add-ons. Cleared caches. I've tried removing Firefox and all associated profiles, then re-installing and double-checking the "disable or replace context menu settings". I've installed FF in a new location after removing FF and all associated profiles and add-ons. Nothing works. In-browser apps with context menus are now useless because the FF context menu lands squarely overtop of each menu. It's driving me crazy. Going to try downgrading next.

Ever since my update to 32.0.3 every time I'm in a web app, and I right-click the Firefox context menu now overlaps the application menu. I've already tried making sure that javascript settings to disable and replace context menus is enabled. Upon restart the same thing happens. This setting enabled or disabled, makes no no difference. I've disabled and removed all other add-ons. Cleared caches. I've tried removing Firefox and all associated profiles, then re-installing and double-checking the "disable or replace context menu settings". I've installed FF in a new location after removing FF and all associated profiles and add-ons. Nothing works. In-browser apps with context menus are now useless because the FF context menu lands squarely overtop of each menu. It's driving me crazy. Going to try downgrading next.

Wybrane rozwiązanie

Hmm, why isn't yours working?!

The only way I could get the Firefox context menu to pop-up in front of Google's menu (with dom.event.contextmenu.enabled=true) was to right-click a second time after the Google menu appeared, or double-right-click the first time.

Experimenting around, I discovered I could clear Firefox's context menu by pressing and releasing the Alt key. Does that work for you as a temporary workaround?

Przeczytaj tę odpowiedź w całym kontekście 👍 0

Wszystkie odpowiedzi (7)

more options

You should be able to close the Firefox context menu, either with the ESC key or by clicking the mouse on the Google context menu. The default setting of dom.event.contextmenu.enabled is false to enable websites to replace the context menu.

more options

What setting did you change in about:config? Here's my understanding:

dom.event.contextmenu.enabled

  • true (default): sites can replace Firefox's context menu
  • false: sites CANNOT replace Firefox's context menu, so Firefox's menu may appear in front of the site's menu -- usually a single tap on the Esc key will clear Firefox's menu and leave the site's menu, but sometimes both are cleared
more options

dom.event.contextmenu.enabled is currently set to true. Still, FF's context menu overlaps the Google Apps context menu

more options

(And yes, I did reboot Firefox to ensure the settings were still there and had taken effect, with the same result). I also tried setting it to false and rebooting, again double checking the functionality or settings. Neither setting works. Hitting the escape button every time is not a fix either, it actually makes both menus disappear. I also can't simply click on what's below the FF menu if I can't read the labels beneath (these functions change depending on what's clicked on so I can't simply memorize what's underneath).

more options

Wybrane rozwiązanie

Hmm, why isn't yours working?!

The only way I could get the Firefox context menu to pop-up in front of Google's menu (with dom.event.contextmenu.enabled=true) was to right-click a second time after the Google menu appeared, or double-right-click the first time.

Experimenting around, I discovered I could clear Firefox's context menu by pressing and releasing the Alt key. Does that work for you as a temporary workaround?

Zmodyfikowany przez jscher2000 - Support Volunteer w dniu

more options

Ah, wonderful! Yes, that does provide a temporary workaround. :)

On a side note, I even tried restarting Firefox in safemode with dom.event.contextmenu.enabled set to true and now the FF context menu only triggers on top of the other menu about 50% of the time. Still odd.

I'll stick with the Alt temporary solutions for now. Thank you! Thank you! Thank you!

more options

I'm wondering if it might actually be an issue with the USB/driver or mouse then. I've tried a second device in a different USB with the same result. The idea that you can get this to happen on double-click makes me think though that there's maybe something's up with the pointer device/driver or settings then. :|

It's a touch-screen that seems to have some funny issues with different pointers at times. Will investigate further!