Firefox przestał ostrzegać przed zamknięciem wielu kart i okien

Ten artykuł może być nieaktualny.

Dokonano istotnej zmiany w angielskiej wersji artykułu, na podstawie której został on stworzony. Do czasu zaktualizowania strony może być przydatny ten artykuł: How do I restore my tabs from last time?

Jeśli podczas zamykania Firefoksa przestało się wyświetlać pytanie Czy Firefox ma przywrócić aktualne karty przy następnym uruchomieniu?, może to świadczyć o złej konfiguracji ustawień, problemem z rozszerzeniami lub uszkodzonymi plikami powodującymi awarie komponentów Firefoksa.


Nieprawidłowa konfiguracja ustawień

Jeżeli ustawienia Firefoksa są skonfigurowane inaczej niż poniżej, ostrzeżenie się nie pojawi.

  1. Na górze okna Firefoksa naciśnij przycisk Firefox i wybierz Opcje.Na górze okna Firefoksa kliknij menu Narzędzia i wybierz Opcje.Na pasku menu kliknij Firefox i wybierz Preferencje…Na górze okna Firefoksa kliknij menu Edycja i wybierz Preferencje…
  2. Wybierz panel Główne i opcję Po uruchomieniu programu Firefox ustaw na wyświetl stronę startową.
  3. Przejdź do panelu Karty i zaznacz Ostrzegaj przed zamknięciem wielu kart.
  4. Przejdź do panelu Prywatność i odznacz Zawsze usuwaj dane prywatne, gdy zamykam program Firefox.
  5. Naciśnij przycisk OK, by zamknąć okno opcjiNaciśnij przycisk Zamknij, by zamknąć okno preferencjiZamknij okno preferencji
  1. Na górze okna Firefoksa naciśnij przycisk Firefox i wybierz Opcje.Na górze okna Firefoksa kliknij menu Narzędzia i wybierz Opcje.Na pasku menu kliknij Firefox i wybierz Preferencje…Na górze okna Firefoksa kliknij menu Edycja i wybierz Preferencje…
  2. Wybierz panel Ogólne, Główne w Firefoksie 3.5 i opcję Po uruchomieniu programu Firefox ustaw na wyświetl stronę startową.
  3. Przejdź do panelu Karty i zaznacz Ostrzegaj przed zamknięciem wielu kart.
  4. Przejdź do panelu Prywatność i sprawdź czy opcja Program Firefox: jest ustawiona na będzie pamiętał historię lub będzie używał ustawień historii użytkownika.
    • Jeżeli opcja Program Firefox: jest ustawiona na będzie używał ustawień historii użytkownika, odznacz Czyść historię podczas zamykania programu Firefox.
  5. Naciśnij przycisk OK, by zamknąć okno opcjiNaciśnij przycisk Zamknij, by zamknąć okno preferencjiZamknij okno preferencji


Jeżeli w Firefoksie 4 to pytanie nadal się nie pojawia:

  1. W pasku adresu wpisz about:config i naciśnij klawisz EnterReturn.
    Zostanie wyświetlona strona z ostrzeżeniem Grozi utratą gwarancji!. By wyświetlić tę stronę, naciśnij przycisk Zachowam ostrożność, obiecuję!.

  2. Za pomocą paska filtru znajdź parametry browser.warnOnQuit i browser.showQuitWarning. Oba powinny mieć wartość true. Jeśli widzisz wartość false, należy ją zmienić:
  3. Kliknij prawym przyciskiem myszy dany parametr i z menu kontekstowego wybierz Przełącz.

Nieprawidłowa interakcja rozszerzenia

Niektóre rozszerzenia, np. Tab Mix Plus powodują problemy. W jaki sposób sprawdzić, czy powodem problemu jest rozszerzenie, dowiesz się z artykułu Rozwiązywanie problemów z rozszerzeniami i motywami.

Uszkodzone pliki

Firefox przechowuje pliki z informacjami użytkownika w oddzielnym folderze zwanym folderem profilu. Jeden lub więcej plików znajdujących się w tym folderze mógł zostać uszkodzony.

  1. Otwórz folder profilu:

    1. Na górze okna Firefoksa naciśnij przycisk Firefox i kliknij menu PomocNa pasku menu, kliknij menu PomocNa górze okna Firefoksa, kliknij menu Pomoc, a następnie wybierz Informacje dla pomocy technicznej. Zostanie otwarta karta zawierająca informacje dla pomocy technicznej.
    2. W sekcji Informacje o aplikacji naciśnij przycisk Otwórz folder zawierającyPokaż folderPokaż w FinderzeOtwórz katalog. Zostanie otwarte okno zawierające plikifolder twojego profilu.
      Jeśli nie możesz otworzyć lub używać Firefoksa, postępuj według instrukcji zawartych w artykule: Odszukanie profilu bez otwierania Firefoksa.

  2. Na górze okna Firefoksa naciśnij przycisk Firefox i wybierz ZakończNa górze okna Firefoksa kliknij menu Plik i wybierz ZakończNa pasku menu kliknij menu Firefox i wybierz Zakończ program FirefoxNa górze okna Firefoksa kliknij menu Plik i wybierz Zakończ
    • Upewnij się, że Firefox nie jest uruchomiony.
  3. Zmień w swoim profilu nazwy następujących plików:
    • Nazwę pliku formhistory.sqlite na formhistory.sqlite.bak.
    • Nazwę pliku sessionstore.js na sessionstore.js.bak.
Uwaga: Jeśli zajdzie potrzeba przywrócenia starych wersji tych plików, usuń nowe wersje plików, a następnie z nazwy starych plików usuń .bak.

Czy ten artykuł okazał się pomocny? Proszę czekać…

Osoby, które pomogły w tworzeniu tego artykułu: teo951, TyDraniu. Ty też możesz pomóc - sprawdź jak.