Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using the page up/down buttons makes the browser go back/forward one page, respectively.

  • 11 svar
  • 182 har dette problemet
  • 3 views
  • Siste svar av upnorth29

more options

When I attempt to use the page down key it doesn't respond. That is when I noticed that when I press the page up key, it takes me back to the previous page I was on. Pressing the page down key takes me back again. I does not scroll through the window like it normally used to. I've disabled all my addons without any resolution to my problem. Is this a new feature? Can I disable it?

When I attempt to use the page down key it doesn't respond. That is when I noticed that when I press the page up key, it takes me back to the previous page I was on. Pressing the page down key takes me back again. I does not scroll through the window like it normally used to. I've disabled all my addons without any resolution to my problem. Is this a new feature? Can I disable it?

Endret av paintballzero

All Replies (11)

more options

Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox


If that didn't help then do a clean reinstall.

  • Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
  • Don't remove personal data if you uninstall the current version.
  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Endret av cor-el

more options

Did what cor-el suggested, uninstalling and deleting the folder. Actually worked, for a short time. Now, it takes me to the previous page on page up, and page down does nothing. Really wish I hadn't gone to 4.0. Pagination is fairly basic behavior to be tested before releasing any UI based software.

more options

Okay, here's how I can cause it consistently.

Shut down FF. Open it up. Google something. Results page up/down just fine. Come to support.mozilla.com Enter something in Search Firefox Help text box. Press up/down. Now, pagination with the page keys no longer function properly.

more options
more options

I have a many plug-ins for FF4:

Shockwave Flash 10.2.153.1

Adobe Acrobat 10.0.1.434 Google Update 1.2.183.39 Microsoft Office 2010 14.0.4730.1010 Microsoft Office 2010 14.0.4761.1000 Silverlight Plug-in 4.0.60129.0 Winamp Application Detector 5.6.1.3133

For me, only the Shockwave plug-in was causing this problem. Disabling it fixed the issue, but then I can't use Flash. There may be other plug-ins that also affect this.

more options

Note that updating to Flash Player 10.3.180.65 Beta 2 resolves this problem with the Shockwave plug-in

more options

@HSuke

Thanks for your response. I tried updating to the beta version, however the problem still persists. :/

more options

Thank you for your help Hsuke, but as of Firefox 4.01 on Windows 7 32-bit, the problem occurs independently of shockwave plugin.

I'm running it from a Samsung NF310. Is it possible that the hotkey manager causes this? It seems unlikely, since the keys function properly in every other context-- Word, file windows, Chrome, IE.

more options

Its been reported that some of users, like me, are having this problem on their Asus model laptops. Another common factor between the models could be the use of Elantech drivers for touchpad mouses.

The bugzilla.com link provided above has a fix that has worked for me so far. It goes as following:

1. Go to about:config

2. Find ui.elantech_gesture_hacks.enabled

3. Change its value from -1 to 0

4. Restart FF

5. If you run into a bug that option was designed to fix (non-working page swipe gestures), install the latest Elantech driver (http://www.techspot.com/drivers/driver/file/information/14513/) and reboot.

I has proven to work for me. However, I did not need to install the latest driver or have not had to so far, thus I cannot confirm that part of the fix.

Endret av paintballzero

more options

about:config>browser.sessionhistory.max_entries change from 2 to 50.

more options

I use an Asus laptop and ran into this problem. And this solution was super helpful. I have no idea how my PageUp/PageDown just stopped working and took me back pages all of a sudden but it was sooo frustrating!!! Why the he** would that even happen...grrr!!!! Thanks for the great reply though!! :):)