On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

web site is displayed in text format

more options

Did a update to the latest FF (36.0.4). Now some of the websites I visit are display in a TEXT format, Not in HTML. Before the update all was fine. Not all web site just some.. I.E. This one now is affected https://www.creditkarma.com/auth/logon

Credit Cards
   Best Credit Cards
   Search All Credit Cards
   Balance Transfer Credit Cards
   Low Interest Credit Cards
   Cash Back Credit Cards

Loans ...


Thought the issue might be the style guide, but not sure. The other site that is displayed differently is this Mozilla site. It's all text format. This is running on a MAC Yosemite 10.10.2 Thx for your help!!

Did a update to the latest FF (36.0.4). Now some of the websites I visit are display in a TEXT format, Not in HTML. Before the update all was fine. Not all web site just some.. I.E. This one now is affected https://www.creditkarma.com/auth/logon Credit Cards Best Credit Cards Search All Credit Cards Balance Transfer Credit Cards Low Interest Credit Cards Cash Back Credit Cards Loans ... Thought the issue might be the style guide, but not sure. The other site that is displayed differently is this Mozilla site. It's all text format. This is running on a MAC Yosemite 10.10.2 Thx for your help!!

Endret av jimmyc

All Replies (10)

more options

Make sure that you do not block CSS files.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see what content is blocked and has a zero file size.

more options

I tried the suggestion above. No luck.. Seems like it started after I upgraded. Some site work and some don't. The Mozilla site being one of them that doesn't, I edited this via Safari. FITBIT site shows all text too. Will remove FF and see if I can download an older release. Unless support has any other suggestions. Could there be anything in the "System Preferences" under security?? Thanks

more options

Two questions:

(1) Have you noticed Firefox objecting to the security certificates for any sites, and/or made any exceptions?

(2) Some users have reported that during a recent upgrade, Firefox presenting the Refresh button, indicating that Firefox was running slowly and performance could be improved by restoring original settings. This creates an "Old Firefox Data" folder on the desktop with your old settings files. Do you see anything like that?

more options

Thx for the reply... Yes to #1 FF has be objecting to security certs for quite a while (1yr). I just create an exception and connect. No issues till the update.

No for #2 Don't see any "odd" folders that shouldn't be there.

more options

Check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Check out why the site is untrusted and click "Technical Details" to expand this section. If the certificate is not trusted because no issuer chain was provided (sec_error_unknown_issuer) then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

  • Note that some firewalls monitor (secure) connections and that programs like Sendori or FiddlerRoot can intercept connections and send their own certificate instead of the website's certificate.
  • Note that it is not recommended to add a permanent exception in cases like this, so only use it to inspect the certificate.
more options

jimmyc -- please in the future ask about those security warnings! We are here for you!

Anyway, when you create an exception for a site (e.g., mozilla.org) it does not cover related servers that the site uses. If the style sheets are located on those servers, Firefox silently fails to retrieve them and doesn't let you create an exception. The pattern you are seeing is the new normal.

cor-el's post should help you get to the root of the problem. Hopefully it's your security software and not malware/hackers intercepting all your web traffic.

more options

Cor-el: Date/Time look okay Looked at the cert and it is CommonName is cdn.mozilla.net and is issued by DigiCert, Expires 12/14/15 It does show Unknown Identity and is not trusted.

Question; On that screen where you can click to view, there is a box

 "Permanently store this exception"

That box is grayed out and I don't see any way to make it active. I do click "Confirm Security Except" and get connections but I have to do that every time. Seems like there should be a way to Store it

more options

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

Endret av cor-el

more options

Okay Private Browsing was on, turned it off. Cleared all history, caches and cookies, stopped FF and restarted. It now accepts and stores certs. Still getting text mode for the mozilla login site and a few others. Speed has always bee fine no issues there, just some sites display in text format. I'm out of ideas Style sheets look okay...

more options

Let's dig into the certificate a little further.

https://support.cdn.mozilla.net/static/img/firefox-512.png?v=1

click the padlock/error triangle > More Information > View Certificate

Does your cert issuer and hierarchy look like the attached? What do you see?